3 Replies Latest reply on Oct 14, 2014 12:23 AM by AlexT_Intel

    Initramfs fails to build

    dklue

      Hi everyone,

      I have been successful with building a yocto build up to the point of it creating the initramfs file,

      first I get a error right off the bat: unable to get checksum for core-image-minimal-initramfs,

      then when its almost done I get the error that in the update_font_cache, has an extra character

      after -e expression 8th character, I dont have my notes with me, but it is something like this, it

      wont write the initramfs file, I dont know if its from the first warning that it doesnt get the check sum

      or if their is a error in the update_font_cache script, I looked at the file in 0.7 and in 0.9 and they are

      the same, can someone shed some light on this or run into this error ?

        • 1. Re: Initramfs fails to build
          Intel_Jesus

          Hi dklue,

           

          We uploaded a lot of documents Friday afternoon and your post got lost. Can you provide the exact error message from your terminal? Either in a txt file or a screen shot, whichever one fits the whole message.

           

          Regards,

          JEspinoza

          • 2. Re: Initramfs fails to build
            xbolshe

            Today I have done a successful compilation of "meta-clanton_v1.0.1.tar.gz" with patches for v1.0.3. That was not so easy.

             

            During compilation the following problems was fixed by me:

             

            1. OpenCV-2.4.3 file does not exist (just look at http://sourceforge.net/projects/opencvlibrary/files/opencv-unix/)

                So, I killed a patch for OpenCV-2.4.3 and modified to opencv-2.4.9.zip

             

            2. The same problem described above (like "-e expression 8th character") with "update_font_cache" and "update_pixbuf_cache" is present with "meta-clanton_v1.0.1.tar.gz" with patches for v1.0.3

                A problem looks like for both scripts:

            adsdsds.png

             

                Need to install the following packages (which are not described in "Intel®Quark™ SoC X1000 Board Support Package (BSP) Build and Software User Guide"  from June 16, 2014):

             

            Commands

                    # apt-get install qemu

                    # apt-get install libgdk-pixbuf2.0-dev

             

              Aslo I have modified these two files like this (I am not sure that it was right):

              

            update_font_cache

            #!/bin/sh

             

            echo "exec->  update_font_cache"

             

            PSEUDO_UNLOAD=1 qemuwrapper -L $D -E LD_LIBRARY_PATH=$D/${libdir}:$D/${base_libdir}\

                                $D${bindir}/fc-cache --sysroot=$D > /dev/null 2>/dev/null

             

            rc=$?

             

            echo "exec->  update_font_cache :ret_code=" $rc

            A trouble was with "/dev/null 2>&1"

             

            update_pixbuf_cache

            #!/bin/sh

             

            echo "exec -> update_pixbuf_cache"

             

            #export GDK_PIXBUF_MODULEDIR=$D${libdir}/gdk-pixbuf-2.0/2.10.0/loaders

            export GDK_PIXBUF_MODULEDIR=/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders

             

            PSEUDO_UNLOAD=1 qemuwrapper -L $D -E LD_LIBRARY_PATH=$D/${libdir}:$D/${base_libdir}\

                $D${bindir}/gdk-pixbuf-query-loaders \

                >$GDK_PIXBUF_MODULEDIR/../loaders.cache 2>/dev/null && \

                sed -i -e "s:$D::g" $GDK_PIXBUF_MODULEDIR/../loaders.cache

             

            rc=$?

             

            echo "exec -> update_pixbuf_cache :ret=" $rc

             

            Also I modified rights for /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache, because bitbake is executed not from root.

             

            Need to note that there is no recommendation for RAM memory in the Chapter 2 of "Intel®Quark™ SoC X1000 Board Support Package (BSP) Build and Software User Guide".

            As I saw 6-8 tasks with 0,5 Gb RAM usage are often during a compilation. I used about 6,8 Gb of RAM for compilation.

             

            And my result:

             

            aaaass.png

             

            asasa.png

            • 3. Re: Initramfs fails to build
              AlexT_Intel

              RAM needs largely depend on BB_NUM_THREADS and PARALLEL_MAKE settings in your build/conf/local.conf file. For one, I was successfully building this on VMs with 2GB and 4GB of RAM with these being set to 2 & 2 and 4 & 4 respectively.