9 Replies Latest reply on Aug 7, 2015 6:21 AM by RemedioCino

    Intel Adv-N 6235 Wifi not connecting

    mryan12

      Hi everybody,

       

      I'm having an issue connecting to wifi using an Intel Advanced-N N6235. Regarding my use case, I was originally trying to get it working on a Yocto image with Java preinstalled found here: Intel-NTU Connected Context Computing Center. After a while, I figured that the image may have been the issue, so I switched back to the Intel supplied Yocto image, but I have not been able to get it to work on that either.

       

      I have been following Sergey's guide (Intel Galileo Meets Wireless - Malinov Family Web Presence), and everything seemed to go well until I tried connecting.

       

      Here is my dmesg output for iwlwifi and wlan0, and ifconfig:

      root@clanton:~# dmesg | grep -e 'iwlwifi' -e 'wlan0'

      [   13.804085] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)

      [   13.810331] iwlwifi 0000:01:00.0: enabling bus mastering

      [   13.810920] iwlwifi 0000:01:00.0: irq 45 for MSI/MSI-X

      [   13.917544] iwlwifi 0000:01:00.0: loaded firmware version 18.168.6.1

      [   14.202763] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUG disabled

      [   14.208753] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEBUGFS disabled

      [   14.215050] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled

      [   14.221956] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled

      [   14.228815] iwlwifi 0000:01:00.0: CONFIG_IWLWIFI_P2P disabled

      [   14.234772] iwlwifi 0000:01:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0

      [   14.253130] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

      [   18.455170] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

      [   18.467643] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0

      [   18.905993] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S

      [   18.918477] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0

      [   19.401464] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

      [   22.781474] wlan0: authenticate with d8:a2:5e:8d:b9:7e

      [   22.812497] wlan0: send auth to d8:a2:5e:8d:b9:7e (try 1/3)

      [   22.820822] wlan0: authenticated

      [   22.825812] wlan0: waiting for beacon from d8:a2:5e:8d:b9:7e

      [   27.838154] wlan0: authenticate with d8:a2:5e:8d:b9:7e

      [   27.847857] wlan0: send auth to d8:a2:5e:8d:b9:7e (try 1/3)

      [   27.854056] wlan0: deauthenticating from d8:a2:5e:8d:b9:7e by local choice (reason=3)

      [   32.031058] wlan0: authenticate with d8:a2:5e:8d:b9:7e

      [   32.040712] wlan0: send auth to d8:a2:5e:8d:b9:7e (try 1/3)

      [   32.049538] wlan0: authenticated

      [   32.054588] wlan0: waiting for beacon from d8:a2:5e:8d:b9:7e

      [   32.130264] wlan0: associate with d8:a2:5e:8d:b9:7e (try 1/3)

      [   32.138861] wlan0: RX AssocResp from d8:a2:5e:8d:b9:7e (capab=0x411 status=0 aid=1)

      [   32.171852] wlan0: associated

      [   32.175045] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

      root@clanton:~# ping google.com

      ping: bad address 'google.com'

       

       

      I found another forum post which had a similar deauthenticating issue here (wifi not working), and as a result tried connecting with security on and off, and checked the wpa_supplicant.conf file to no avail.

      wlan0     Link encap:Ethernet  HWaddr C4:D9:87:34:33:11

                inet6 addr: fe80::c6d9:87ff:fe34:3311/64 Scope:Link

                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                RX packets:43 errors:0 dropped:0 overruns:0 frame:0

                TX packets:10 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:10266 (10.0 KiB)  TX bytes:1142 (1.1 KiB)

       

       

      One other thing I found which I think probably is relevant is the fact that ifdown throws this error. It may be because it is not connected, but I thought I'd add it in case it is important:

      root@clanton:~# ifdown wlan0

      ifdown: interface wlan0 not configured

      root@clanton:~# ifup wlan0

      udhcpc (v1.20.2) started

      Sending discover...

      Sending discover...

      Sending discover...

      No lease, failing

      root@clanton:~# ifdown wlan0

      ifdown: interface wlan0 not configured

       

       

      If anyone could provide some help, that would be greatly appreciated. Thanks!

       

      Editing this in as an addendum: I tried running iwconfig after ifup, it shows the network:

      root@clanton:/etc/init.d# iwconfig

      wlan0     IEEE 802.11abgn  ESSID:"galileo"

                Mode:Managed  Frequency:2.462 GHz  Access Point: D8:A2:5E:8D:B9:7E 

                Bit Rate=6 Mb/s   Tx-Power=15 dBm 

                Retry  long limit:7   RTS thr:off   Fragment thr:off

                Encryption key:off

                Power Management:off

                Link Quality=70/70  Signal level=-29 dBm

                Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

                Tx excessive retries:0  Invalid misc:0   Missed beacon:0

       

       

      lo        no wireless extensions.

       

       

      eth0      no wireless extensions.

      However, running a ping command to google or another device on the network fails. If I connect with other devices, I am able to access the internet, so I know it's not an issue with the network

        • 1. Re: Intel Adv-N 6235 Wifi not connecting
          Intel_Raad

          I tested the Adv-N 6235 following Sergey's blog running Linux provided by Intel and its working. I noticed a difference in the negotiation between your card <-> router and my card <-> my router, I also noticed that your card did not obtain IPv4. When I execute "ifconfig wlan0", the output is:

           

          wlan0     Link encap:Ethernet  HWaddr B4:B6:76:F5:AC:B7 
                    inet addr:172.20.10.14  Bcast:0.0.0.0  Mask:255.255.255.240
                    inet6 addr: 2600:1010:b10f:2bd9:b6b6:76ff:fef5:acb7/64 Scope:Global
                    inet6 addr: fe80::b6b6:76ff:fef5:acb7/64 Scope:Link
                    UP BROADCAST MULTICAST  MTU:1500  Metric:1
                    RX packets:38 errors:0 dropped:0 overruns:0 frame:0
                    TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
                    collisions:0 txqueuelen:1000
                    RX bytes:6100 (5.9 KiB)  TX bytes:4355 (4.2 KiB)

           

          Lines 2 and 3 above shows my card negotiated with my router and successfully obtained IP address, I believe your card working fine but your router rejecting it, check your router configuration.

          Lineslinll

          • 2. Re: Intel Adv-N 6235 Wifi not connecting
            mryan12

            Hi Raad,

             

            Thanks for your help and sorry for the late reply - I didn't have access to the Galileo for the past few days. I looked through my router configuration several times over and could not see anything that could be wrong with it, so I went back to the board to see if I couldn't work something out. Eventually I did get it working, but I cannot seem to figure out why this solution works. After looking through some other Linux forum posts regarding the deauthenticating reason=3 message, many people said there could be multiple wpa_supplicant processes running. Looking through my process list, I did see two wpa_supplicants, so I tried killing them. That didn't work, so I decided to take it a step further and did the following:

             

            killall wpa_supplicant

            killall iwlwifi

            ifup wlan0

             

            After that, the wifi connected without a problem, and I was able to replicate it after restarting the board as well. Do you have any idea what this is doing to get it to work? Note that killing iwlwifi individually does not work either - both of them have to be killed for it to work, and I have not done anything with iwlwifi aside from what was directed on Sergey's blog. I'm hesitant to move forward with this at this point because it seems really hacky, but hey - if it works, it works right?

            • 3. Re: Intel Adv-N 6235 Wifi not connecting
              Intel_Jesus

              Hi mryan12,

               

              Are you using the LINUX IMAGE FOR SD for Intel Galileo or did you build your own? If you are using the LINUX IMAGE FOR SD, try re-downloading the image because the wpa_supplicant should only start if you configure it in the file /etc/network/interfaces. Can you provide that file as an attached file?

               

              Regards,

              JEspinoza

              • 4. Re: Intel Adv-N 6235 Wifi not connecting
                balou1974

                I had just same problems using an Atheros card (ath5k). Problem seems to be that connman doesn't find wlan0 ...

                I disabled connman and configured wpa-supplicant and interfaces. This works ... but cannot be the solution.

                Starting with 0.9.0 of the sd-card-image you can use opkg (like apt-get). Alex T. from Intel set up a server for that.

                Please search the forum! After configuration of opkg you can install connman-client, connman-tools and connman-test ...

                This should help finding the problem.

                 

                regards balou

                • 5. Re: Intel Adv-N 6235 Wifi not connecting
                  mryan12

                  Hey guys,

                   

                  Thanks for the responses. JEspinoza, I am using a version of Yocto which has the JDK on it (found here: Intel-NTU Connected Context Computing Center). I have also attached the /etc/network/interfaces file to this post (Note that the actual file is not .txt, I just added it to the attached file). I had put in auto wlan0 before, but took it out when I started running into issues. However, seeing as how wpa_supplicant *is* starting up still, I will try to start over with a fresh copy of the Linux image and see if that changes anything (will report back later today).

                   

                  balou, I'm not sure I completely understand your post. What configuration of opkg are you referring to? I have tried searching the forum for anything regarding connman and opkg, but have been unable to find anything relevant. Could you point me in the right direction?

                   

                  Thanks again for the help guys!

                   

                  mryan12

                  • 6. Re: Intel Adv-N 6235 Wifi not connecting
                    balou1974

                    This may help you a bit did a quick search Please read everything, Alex changed the package repository ...

                    Regarding the wifi problem:

                    -use version 0.9.0 of the SD card image

                    -follow the guide you mentioned at start (not the LSB-Image, the first solution regarding wpa-supplicant)

                    -telnet to your galileo (use the headphones like serial plug)

                    -login 'root'

                    -enter 'chmod 644 /etc/init.d/connman'

                    -kill connman daemon

                    -try 'ifconfig wlan0 up'

                    -if you can connect 'ifconfig' to your wlan do a 'reboot'

                    -that was my way to fix it but it is not a fine solution because connman should handle it

                     

                    How to enable the Yocto-provided package management capability

                    • 7. Re: Intel Adv-N 6235 Wifi not connecting
                      mryan12

                      Hi balou,

                       

                      I tried those steps out and they didn't seem to help for me. That said, they are also somewhat similar to my own homemade solution above that I've been using for the time being. I also went into the connman shell, and it was able to find wlan0, so I'm guessing the issue does not have to do with connman.

                       

                      On the other hand, when I tried starting with a fresh image (two times now), I ran into some rfkill issues that I do not think I had to deal with before (not unblocking wlan0). I'm guessing that this is an indication that I just messed before since and am now facing the root cause of the issue, although we'll see if/when I can unblock wlan. I'll update you guys if I get any further information. Till then, I guess I'll just stick with the method I have above, which seems to be working well.

                       

                      Thanks again!

                       

                      mryan12

                      • 8. Re: Intel Adv-N 6235 Wifi not connecting
                        bjmurphy

                        Did you ever find out what the underlying problem was with this?

                         

                        The reason I ask is that my board is behaving exactly the same, with the same "fix" (i.e. killall wpa_supplicant; killall iwlwifi; ifup wlan0 etc.) working. However, this is way too much like black magic for me, plus it has to be re-done each time the board is restarted (or maybe these commands can be put into some startup script?).

                         

                        Anyway, I was wondering if you've discovered a more permanent fix.

                         

                        Regards

                        bjmurphy

                        • 9. Re: Intel Adv-N 6235 Wifi not connecting
                          RemedioCino

                          Hi Balou,

                           

                          I assume  (from your post) you succeded  in using wifi atheros pci card.

                          Can you kindly tell me what have you done to get it working ?

                          Did you put some firmware file in /libb/firmware ?

                          I would appreciate if you can help me.

                           

                          Thansk a Lot

                          Maurizio