6 Replies Latest reply on Nov 13, 2014 3:52 AM by Thuy

    Intel(R) Centrino(R) Wireless-N 135 Configuration

    Nandu

      Hi,

      I'm using IoT DevKit Ver.1.0 and trying to configure WiFi Card and running some configuration issue "No lease, failing...".

      Pls. could you help me if missing something important?

      Following is my configuration / terminal output:


      root@clanton:~# uname -a
      Linux clanton 3.8.7-yocto-standard #1 Thu Feb 20 13:34:58 GMT 2014 i586 GNU/Linux
      root@clanton:~#


      root@clanton:~# dmesg | grep -I Centrino
      [    9.903487] iwlwifi 0000:01:00.0: Detected Intel(R) Centrino(R) Wireless-N 135 BGN, REV=0x120
      root@clanton:~#


      root@clanton:~# cat /etc/wpa_supplicant.conf

      network={
         ssid="<My SSID>"
         #psk="<My Pass phrase>"
         psk=afaedfe3a9f17c5679ddff1cbc7c2fe77e2292e97f9cacadc073ca6bde319ce0
      }

       

      root@clanton:~# iwconfig
      wlan0     IEEE 802.11bgn  ESSID:off/any
                Mode:Managed  Frequency:2.417 GHz  Access Point: Not-Associated
                Tx-Power=off
                Retry  long limit:7   RTS thr:off   Fragment thr:off
                Encryption key:off
                Power Management:off

      lo        no wireless extensions.

      eth0      no wireless extensions.

      root@clanton:~# ifup wlan0
      ifup: interface wlan0 already configured
      root@clanton:~# iwconfig
      wlan0     IEEE 802.11bgn  ESSID:off/any
                Mode:Managed  Frequency:2.417 GHz  Access Point: Not-Associated
                Tx-Power=off
                Retry  long limit:7   RTS thr:off   Fragment thr:off
                Encryption key:off
                Power Management:off

      lo        no wireless extensions.

      eth0      no wireless extensions.

      root@clanton:~# ifdown wlan0
      root@clanton:~# ifup wlan0
      Successfully initialized wpa_supplicant
      rfkill: WLAN soft blocked
      Could not set interface wlan0 flags (UP): Operation not possible due to RF-kill
      ifconfig: SIOCSIFFLAGS: Operation not possible due to RF-kill
      root@clanton:~# rfkill list
      0: phy0: wlan
              Soft blocked: yes
              Hard blocked: no
      1: hci0: bluetooth
              Soft blocked: yes
              Hard blocked: no
      root@clanton:~# rfkill unblock 0
      [  532.456188] iwlwifi 0000:01:00.0: L1 Disabled; Enabling L0S
      root@clanton:~# [  532.500653] iwlwifi 0000:01:00.0: Radio type=0x0-0x0-0x0
      [  532.837179] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
      [  533.379423] wlan0: authenticate with 00:26:5a:2c:f1:a0
      [  533.502667] wlan0: send auth to 00:26:5a:2c:f1:a0 (try 1/3)
      [  533.510800] wlan0: authenticated
      [  533.521880] wlan0: associate with 00:26:5a:2c:f1:a0 (try 1/3)
      [  533.531932] wlan0: RX AssocResp from 00:26:5a:2c:f1:a0 (capab=0x431 status=0 aid=9)
      [  533.549373] wlan0: associated
      .
      .
      .
      .

      root@clanton:~# cat /etc/network/interfaces

       

      # /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

      # The loopback interface
      auto lo
      iface lo inet loopback

      # Wireless interfaces
      auto wlan0
      iface wlan0 inet dhcp
         wireless_mode managed
         wireless_essid any
         wpa-driver wext
         wpa-conf /etc/wpa_supplicant.conf

      iface atml0 inet dhcp

      # Wired or wireless interfaces
      auto eth0
      iface eth0 inet dhcp
      iface eth1 inet dhcp

      # Ethernet/RNDIS gadget (g_ether)
      # ... or on host side, usbnet and random hwaddr
      iface usb0 inet static
         address 192.168.7.2
         netmask 255.255.255.0
         network 192.168.7.0
         gateway 192.168.7.1

      # Bluetooth networking
      iface bnep0 inet dhcp

       


      root@clanton:~# ifup wlan0
      udhcpc (v1.21.1) started
      Sending discover...
      Sending discover...
      Sending discover...
      No lease, failing
      root@clanton:~#

       

       

       

      Thanks

       

      Nandkishor