7 Replies Latest reply on Mar 7, 2014 9:07 PM by wardell12

    Can't seem to install latest RST drivers in windows 8.1

    SputNick7

      So I have been reformatting my computer this week. due problems. When I set up my computer to install I used raid management set two corsair 90 GT in raid 0. Booted into windows 8.1 install and during the drive selection screen. said load new drivers. which then I picked the latest RST driver (12.9.0.1001). after it loaded them hit install.

       

      Was checking speeds. they seem bit off. So I enable write back. speed seem to pick up. I then started to set up a few other things. Checked to see if TRIM would have worked and. after using trimcheck .05, it says CONCLUSION: TRIM appears to be NOT WORKING <or has not kicked in yet.>

       

      So first thing I did was go to check which driver was loaded for my hard drivers.  Checking in Device manager opening the properties of the drive. it say the driver loaded is:     Driver Provider: Microsoft, Driver Date: 6/21/2006, Driver Version 6.3.96.00.16384

       

      So I went online and downloaded the latest driver from intel's webpage. everytime I try and update it by selecting the folder which has the iaStorAC.inf it tells me that " The best deriver software for your device is already installed"

       

      if that was the case should it not say 12.9.0.1001 in device properties.

       

      I know the two ssd can be in raid0 due to my old motherboard being an asus p8zzv-deluxe with windows 7 working.

       

      My question is do I really have the latest driver install if not. How get them to install or force windows 8.1 to accept a driver update

       

      My current set up (not going to list every part of just basic info if need more just ask)

       

      OS: Windows 8.1 64bit, Installed with UEFI and GPT

      Motherboard: Asus z87-Deluxe

      Ram: 16gigs

      Hard drives: 2x Corsair CSSD-F90GBGT-BK in raid 0

      1x Corsair CSSD-F120GBLS, 2xWD 1tb sata 3 black in raid 1, 1X WD 1tb sata 2 black

      PSU 860i

       

      EDIT: forgot to finish end question

        • 1. Re: Can't seem to install latest RST drivers in windows 8.1
          kevin_intel

          Hi SputNick7,

           

          I am sorry to hear you are having problems but let me help you.

           

          The driver version 12.9 is the latest driver we have. It is important to mention that win 8 and Win 8.1 already have the RAID drivers included in the Operating System Kernel so there is no need to install any other driver besides the driver version 12.9

          • 2. Re: Can't seem to install latest RST drivers in windows 8.1
            SputNick7


            Hey Kevin thanks for the respond. It seems I was looking in the wrong section to check raid drivers installed.  Was looking under Disk Drives. Not Storage Controllers. So that was my first problem.

             

            It seem the problem is looking to be one or two things here. During reformat I upgraded my Corsair F90GT firmware to 5.2 on both drives. Reason system had some unstable moments was like well lets try it. From reading in there forum it would seem that there firmware breaks TRIM, That or the latest driver with the z87 platform doesn't wana play nice with raid trim.

             

            IF there is someway to run test before I try and downgrade my firmware which seem like it will brink my drive im will to test. Just need to know what info required or what plan of attack to help this problem get fixed.

             

            Thanks for your time.

            • 3. Re: Can't seem to install latest RST drivers in windows 8.1
              wardell12

              Hello kevin_Intel :I am having the same problem. However,I purchased my computer with a win8 operating system which I updated to win8. In the process of updating,my Intel RST Raid driver was corrupted and no longer useable. I deleted it and attempted to download/install from both Lenovo and Intel's download sites without success. Later I attempted to install ver 12.9.0.1001(f6flpy-x64.zip. using setupRST.exe. I selected the win8.1 version. I reported this problem to allan_intel and joe_ Intel previously but I could not communicate with them because I had my pop up blocker on. Allan told me that I might have to do a clean install to re-install the RST driver. I saved the f6flpy-x64.zip to my computer via setupRST.exe and attempted to run it. This has been at least 4 times. If I have to purchase and clean install win8.1,I will wait until I purchase a win8.1 based laptop and have the clean install performed. I would like your opinion about the necessity for performing a clean install to restore the RST driver. I want it for monitoring and reporting on any problems with my SATA drive. Thanks.

              • 4. Re: Can't seem to install latest RST drivers in windows 8.1
                SputNick7

                Wardell12. I have a question. You say you have downloaded f6flpy-x64.zip. from reading what you have tried extract the files into another folder before trying to update your storage driver?

                 

                I don't think installing the setupRST.exe will update your drivers. Would like more info on that if I am right or not.

                • 5. Re: Can't seem to install latest RST drivers in windows 8.1
                  wardell12

                  Hello Sputnick7-According to allan_intel,it is impossible to install f6flpy-x64.zip without using setupRST.exe..In my case,I had errors  and corrupted files removed from my computer which did not correct the problem. There is nothing left for me to do to correct this problem is to clean install Win8.1. You will need your  Win8.1 product key to download 8.1.

                  • 6. Re: Can't seem to install latest RST drivers in windows 8.1
                    SputNick7

                    Wardell12. So I have installed the Drivers during windows 8.1 Installation you just need to unzip the file first save it to an USB. Then load them during the hard drive selection stage.

                     

                    Here is an update. I just bout four new Corsair Force 128GS and put them in raid 0. During the install of Windows 7 Loaded the latest intel raid drivers. Got windows installed. Loaded drivers need to check trim.

                    It worked both With Trim Checker 0.5 and Hex Editor. So the driver seem to work in windows 7.

                     

                    But when I install Windows 8.1 after fully erasing the SSD. Rebuilding the Raid in bios. Load up Windows 8.1 install from another source. With latest intel driver installed Check trim windows says its working with Fsutil behavior query DisableDeleteNotify. it shows up 0.

                     

                    When I use Trim Checker 0.5 and a Hex editor. the trim is not working. the hex on the sector of the SSD still shows up with info not 00 00 00 00 so trim is clearly not working.

                     

                    People have been saying update bios. Which is will not help due to it working in Windows 7 not 8.1 they also say to try different raid drivers. So here is my question how do I downgrade an already installed raid driver once its been installed at a core level of install? and will windows 8.1 allow me to install an older verson then the one that comes on the install disk?

                    • 7. Re: Can't seem to install latest RST drivers in windows 8.1
                      wardell12

                      Hello Sput Nick7-Someone sent me an email suggesting that I download the latest Intel RST driver to a flash drive and install the driver from the flash drive. Have you tried this?