7 Replies Latest reply on May 21, 2014 12:08 PM by gen2thomas

    D54250WYKH doesn't recognise Crucial M4 or Samsung 840 Pro SATA SSD

    BradJ

      Hi all,

       

      This is my second D54250 NUC and this time I went for the 2.5" SATA model so I could use one of the SSD drives I already had. I paid an extra $50 for it.

       

      I tried both of my SSD drives and the NUC would not detect either of them. The symptom was the same for both. The HDD light on top would flash briefly on startup, it would takes ages to get into the BIOS, and the SATA devices tab in the BIOS says "not installed".  I tried two platter SATA HDD's and both worked fine.

       

      I updated the BIOS to the latest version.

      I reset the BIOS to the default settings and I tried lots of different BIOS settings that I thought might make a difference but nothing worked.

       

      Is there anything else I can try?

      Is it likely intel will improve SSD compatibility, so should I wait, or do I just need to go out and buy an intel SSD?

       

      I'm wishing now I had just bought the cheaper D54250WYK with the lower profile and put the money towards a new, compatible, mSata drive.

       

      For for those interested my first NUC is an HTPC running xbmc and my second NUC is an ESXi server for work related VM's.

       

      Brad.