2 Replies Latest reply on Apr 7, 2014 4:10 PM by JPMontero_Intel

    [Newbie] Run binary on board and Yocto Eclipse questions




      I am new to Galileo so please excuse any newbie aspects of my questions.


      First question:


      I have created an Yocto Eclipse project and build the most basic "Hello world" application. I have used the cross compiler tools chain from Yocto ADT installer. It runs on my x86_64 (Ubuntu 13.04) I guess that is ok, Intel Galileo is a x86 32bit arch, correct?.


      I have "scp" the binary to the Galileo board /home/root/test3.


      $ scp test3 root@


      I can find the binary on my Galileo:


        root@clanton:~# ls -l

      -rwxrwxrwx    1 root     root          8838 Jan  1 00:34 test3



      but when I run it it fails:


      root@clanton:~# ./test3

      -sh: ./test3: No such file or directory


      Anyone got any ideas?


      Second question is more fuzzy:


      I would like to be able to upload and run the application from Eclipse, I guess from the Yocto Eclipse plugin. Anyone done that? I have both IP connection over Ethernet and a fully operational serial communication over 3,5mm stereo-plug.


         / Mikael


      Message was edited by: Mikael Carslsson Some update: I have now been able to solve first question. The error message is due to incompatible binary. The binary test3, was build for my host, native Linux x86_63 Ubuntu 13.04 and not Galileo. Using the the cross toolchain from command line, with automake, I could build the binary, transfer the binary to target, and execute the binary successfully. This binary give the same message in native Linux, but works on target. So I guess my presumption about Galileo binary should work on native Linux is incorrect. During my first try, when I wrote the question, I tried to build the binary from Eclipse with support from the Yocto plug-in. Obviously I have configured the plug-in incorrect. So, question 1 is solved.