1 2 Previous Next 23 Replies Latest reply on Jul 31, 2014 5:54 AM by krish_22

    Bitbake Errors

    JamesBond

      Hi guys,

       

      When following malinov's guide to build a LCD, I got the following error upon bitbake. Can anyone either post the full, loadable files or give me an answer? Thanks!

      Bitbake Error - Ubuntu 13 - Pastebin.com

       

      Edit: Put text file into pastebin

        • 1. Re: Bitbake Errors
          rmm200

          My claim: You are running a build using "distro clanton-full" after running a build using "distro clanton-tiny".

          You can't do that. You built "image-spi" first maybe?

          Delete your yocto_build directory and start over for your full build - if my guess is correct.

          • 2. Re: Bitbake Errors
            AlexT_Intel

            That's because of the newer gcc version in ubuntu 13.10. I have a fix for specifically this failure in my yocto layer at http://github.com/alext-mkrs/meta-alext-galileo, but it unfortunately fails at later step anyway, with a more enigmatic error, so I haven't pursued that further :)

             

            So the working fix here is "use 12.04" if you like Ubuntu, or one of the other supported distros/versions.

            1 of 1 people found this helpful
            • 3. Re: Bitbake Errors
              JamesBond

              Thank you, Alex. I'll try that as soon as I can.

              • 4. Re: Bitbake Errors
                JamesBond

                UPDATE:

                Unfortunately, when I bitbaked with Ubuntu 12.04, I got another error message. For the sake of this post, I have included a pastebin instead. Please help!

                 

                Bitbake Error - Pastebin.com

                • 5. Re: Bitbake Errors
                  AlexT_Intel

                  Looks like that was a network glitch, either with your ISP or host/mirrors of Linux kernel:

                  ERROR: Fetcher failure: Fetch command failed with exit code 128, output:

                  Cloning into bare repository '/home/JamesBond/meta-clanton_v0.7.5/yocto_build/downloads/git2/git.kernel.org.pub.JamesBondscm.linux.kernel.git.stable.linux-stable.git'...

                   

                  fatal: read error: Connection reset by peer

                  fatal: early EOF

                  fatal: index-pack failed

                   

                  ERROR: Function failed: Fetcher failure for URL: 'git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git;branch=linux-3.8.y'. Unable to fetch URL from any source.

                   

                  Just run the same "bitbake image-sdk" again, it will start where it left off and hopefully the second try will fetch the data.

                  • 6. Re: Bitbake Errors
                    JamesBond

                    Hmm.

                     

                    I tried bitbaking again and recieved the same exact error (couldn't find the git link). Any recommendations?

                    • 7. Re: Bitbake Errors
                      AlexT_Intel

                      Well... It may be a problem with your recipes then. As far as I understand, you're building the LSB+SDK image based on instructions from SergeyK's blog, right? I'd suggest double-checking that you have done everything he has in his instructions to make sure you're doing it right.

                       

                      There's also a log file you can take a look at, for the pastebin log it was at home/JamesBond/meta-clanton_v0.7.5/yocto_build/tmp/work/clanton-poky-linux/linux-yocto-clanton/3.8-r0/temp/log.do_fetch.29823

                       

                      Check it out, maybe there are some more details on the error, which could shed some more light on that.

                      • 8. Re: Bitbake Errors
                        mdelgert

                        @JamesBond I have been having same exact issue as you for last 3 days. Previously I had no issue, also restored my server from several backup to verify I didn't break my own recipe.

                         

                        Yocto check-in notes poky - Poky Build Tool and Metadata appears to be the culprit meta-clanton_v0.7.5 depends on this during bitbake process. I would file a heat ticket with Intel to add a mirror or alternative.

                         

                        poky - Poky Build Tool and Metadata

                         

                        AgeCommit message (Expand)AuthorFilesLines
                        2 daysguile: fix the depends for target recipesdylanPaul Eggleton1-1/+1
                        3 dayslibx11: backport _XEatDataWords APIPaul Eggleton2-0/+66
                        1 of 1 people found this helpful
                        • 9. Re: Bitbake Errors
                          JamesBond

                          So I suppose the only fix now is to wait it out? While we're waiting for that to happen, could anybody post their (old) working bitbaked LSB? Thanks.

                          • 10. Re: Bitbake Errors
                            rmm200

                            If it were me - and this error is truly 0.7.5 specific, I would move on to the 0.9.0 BSP. There seem to be major improvements in the packaging and documentation since 0.7.5, and 0.8.0 is no longer available.

                            • 11. Re: Bitbake Errors
                              AlexT_Intel

                              Yeah, but bugs too :) It doesn't compile for me yet, failing at dmidecode, which has a Makefile incompatible with newer make. And that is on the supported distro (openSUSE 12.3).

                               

                              On the topic-I'll run the 0.7.5 recompile today to check if I get the same error as OP.

                              • 12. Re: Bitbake Errors
                                AlexT_Intel

                                I don't get that error, just tried. It took some time to go through the do_fetch stage, but it fetched and built everything successfully (but I've tried on the unmodified sources, so again - check you set it up correctly per Sergey's instructions).

                                 

                                JamesBond, try this sequence. Not that it does too much magic, but maybe that's some bitbake caching glitch:

                                 

                                bitbake -c cleanall linux-yocto-clanton
                                bitbake -c cleanall virtual/kernel
                                bitbake linux-yocto-clanton
                                
                                
                                

                                 

                                That should clean everythign up for the kernel part and build just the kernel package. If it fails - let's see what the error is. If it passes - you should be able to run "bitbake image-whatever_it_was" and it will continue to build it.

                                1 of 1 people found this helpful
                                • 13. Re: Bitbake Errors
                                  JamesBond

                                  How would you switch to a later BSP? I can't seem to find the download link. Thanks for your help!

                                  • 14. Re: Bitbake Errors
                                    JamesBond

                                    EDIT:

                                    Your three lines of code worked! I am now running bitbake image-sdk in hopes that it goes through this time.

                                    1 2 Previous Next