6 Replies Latest reply on Feb 6, 2014 7:14 AM by JasonHoffman

    DN2820 Bios wont update?

    MrLockett

      Hello,

       

      I am trying to update the BIOS through the BIOS menu by pressing F7, when doing so it says product ID not found. Any ideas on what to do?

       

      Also,

       

      I have successfully installed Ubuntu 13.10 but I got no Audio through HDMI, only the headphone jack, I tried to install Ubuntu 13.04 and 12.04 and both installs were unsuccessful. Any idea if these versions of Ubuntu will work with this hardware?

       

      Thanks,

        • 1. Re: DN2820 Bios wont update?
          MrLockett

          Just found this link, I believe this will solve the issue and will give it a go tonight. I was thinking the BIOS update would download automatically.

           

          http://download.intel.com/support/motherboards/desktop/sb/f7biosflashupdateinstructions.pdf

          • 2. Re: DN2820 Bios wont update?
            JasonHoffman

            Hi MrLockett,

             

            I had the same issue with mine when I got it.  You're correct in your second message that it doesn't update over the Internet from the bios. You'll want to download the BIOS and put it on a flash drive, then go into the BIOS menu.  When you hit F7 it'll ask if you want to check for a bios, just say no and then point to the bios on the flash drive.

             

            For the HDMI audio problem try this (it's not a NUC-specific problem):

             

             

             

            1. Add the following groups to your account: audio, pulse, pulse-access, video, voice
            2. In a terminal window run the following:
              1. sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily
              2. apt update
              3. apt install oem-audio-hda-daily-dkms

             

            I hope this helps.

             

            Jason

            • 3. Re: DN2820 Bios wont update?
              MrLockett

              Thank you so much for the reply, I will try this when I get home and report if this worked.

               

              Another question, I tried to install Ubuntu 13.04 because XBMC would not load with 13.10 and I could not figure out the reason why. After scouring the internet, it appears that XBMC will only work on 13.04 and below.

               

              I installed 13.04 and it appeared to install but now it only boots into terminal and no GUI, i searched the net for this and tried the startx command and it did nothing. It comes back with Fatal Error, no screen. Any advice would be great, otherwise I will just try to install 13.10 again, but I am afaraid that XBMC wont work.


              Thank you again. Totally new to Ubuntu so this is a new world for me.

              • 4. Re: DN2820 Bios wont update?
                JasonHoffman

                To be honest I haven't used plain Ubuntu on mine. I'm running Linux Mint 16 (Petra) and it works perfectly.  After I applied the HDMI audio fix I have no issues and XBMC is rock solid.

                • 5. Re: DN2820 Bios wont update?
                  MrLockett

                  Just wanted to say thanks and that this did help the system. I decided to go with Linux Mint 16 since it was working for you and everything is working great. I got XBMC, HDMI Audio and plex running, all very smoothly. One thing that I did notice is that when I loaded up Mint for the first time it looked as though I was on an extended desktop, even now when I go into the diplay settings it appears as if there is another "Unkown Monitor" Available. This made it so that I could not see the installation disc on the homepage when I first tried to setup the OS. Not sure what is causing this, but I suspect it is the same thing that was causing my "No Screens" Error in ubuntu 13.04.

                   

                  Thank you again for all of your help.

                  • 6. Re: DN2820 Bios wont update?
                    JasonHoffman

                    Awesome!  Glad you're up and running.

                     

                    I had the same issue with the display.  Here's how you get around it:

                    • Right-click on the desktop and select Change Desktop Background, then clicking All Settings.
                    • Open the Display settings.  You'll see a phantom 1024X768 display set as default
                    • Disable the phantom display and your HDMI connection will become the primary and everything should start working.