1 Reply Latest reply on Feb 6, 2014 8:14 AM by kevin_intel

    USB 3 not working properly on DH67BL

    Pritam

      On the DH67BL I just cannot get a USB 3.0 drive [Expansion 1TB] to work. It works fine on USB 2.0 ports and also USB 2.0 devices works fine on the USB 3.0 ports.

      I have updated the BIOS and Renesas driver and do not have any bios optimization enabled. It detects the drive sometimes but quickly disconnects and eventually stops detecting.

       

      I see two issue using UVCView.x86, the same physical port is detected as port 2 for USB 3 device and port 3 for USB 2 device on the USB 3 RootHub

      And bMaxPacketSize0 as 0x09 when the USB 3 drive is connected to the USB 3 port

      And *!*ERROR:  High Speed Devices require bMaxPacketSize0 = 64, also the MaxPower is detected as only 36mA

       

      It works perfectly on the USB 2.0 ports. bMaxPacketSize0  is detected as 0x40  and MaxPower as 500mA

       

      Tried to search for any clues on intel community and elsewhere and tried out many small changes [power managment, disable USB optimization etc] but just couldn't get it to work.

       

      Appreciate if anybody has some suggestion as to what could be wrong here. Have attached UVCView output for USB 3 and USB 2 ports just in case somebody can make sense out of it.

       

      Renesas: Driver 2.1.28.0

      Firmware 3028

       

      Board: DH67BL

      Version: AAG10189-211

      BIOS: BLH6710H.86A.0160.2012.1204.1156

       

      Pritam

      Pritam