3 Replies Latest reply on Feb 6, 2014 7:21 AM by allan_intel

    RAID 1 going to degraded every other day or so

    ohange

      I have a pair of ST31000528AS 3.5" SATA drives in a RAID-1 configuration. (1TB =~ 930GB usable).

       

      I just upgraded this from a simple volume to a mirrored volume, using an identical (*) drive.  This identical drive was a RMA replacement from Seagate, and is the exact model number, but there are some minor differences:

       

      1) The Seagate Part Number differs, although the model number is the same --> could this perhaps be because it's a refurb drive?

       

      2) The firmwares are not exactly the same.  Original drive is CC46.  Added drive is CC38.  Current on Seagate's site is CC49.  Interestingly, by putting in the S/N of the original drive, I get the warranty information (valid through 2015), and a recommendation to upgrade to CC49.  But putting in the S/N from the refurb returned drive, I get similar warranty information (valid through 2015) and a notice that there are no firmwares offered. (Strange, no?)

       

      At any rate, I notice the behavior of this drive/volume is such that after a while of inactivity, the drive has gone to sleep/standby, and requires a second or two to spin back up.  Some Google-fu has taught me that this drive does not go into any kind of advanced power saving mode on its own, thus, it is commanded to a sleep state by the OS.  In my case, that's Win7x64.

       

      This is an Acer Veriton M680 system, with the Intel Rapid Storage Technology Onboard ROM version 9.5.0.1037.

       

      After an overnight of leaving the system alone, I wake the system to find the mirror volume "degraded" - but upon hitting reset, it rebuilds the volume just fine, and all is fine and dandy.

       

      My suspicions are as follows - but looking for confirmation here:

       

      1) The iRST is detecting a false error due to spinup time and figuring one of the drives is timing out on response... but once it's spun up, it can reset and continue as normal. The rebuild succeeds and the drive is normal, until I leave the system alone long enough for it to go do it's power-save thing.

       

      2) The difference in spinup time could be due to drive age, but could also be due to being different production runs, or any other number of factors. The different firmware levels could also be the culprit.

       

      3) Lastly, this could also be an issue that has been corrected in a newer version of the Option ROM firmware (9.5.0.1037 --> newer version is 9.6.0.1047 I believe?)   Acer does not show that 9.6.x download, but it's available here on Intel's website.

       

      Does Intel recommend I:

      - Synchronize the drive firmwares?

      - Download the Intel Option ROM Software from Intel and update the Option ROM?

      - Not use RAID 1?

       

      I would like to get 2 more drives and go to RAID 10 but am concerned about doing so until I understand this behavior a little better.

       

      r

        • 1. Re: RAID 1 going to degraded every other day or so
          allan_intel

          I am sorry to hear that have had issues with your hard drives.

          To answer your questions:

          1. Yes, it will be OK to get the latest drive firmware.

          2. Option ROM is only update if a BIOS update contains new version of the option ROM. If you are referring to Rapid Storage software, then, this is recommended.

          3. Please bear in mind, this type of issue may occur because you may have defective SATA controller on your board. The usage of RAID 1 prevents data loss.

           

          Allan.

          1 of 1 people found this helpful
          • 2. Re: RAID 1 going to degraded every other day or so
            ohange

            Thanks for your reply.

             

            In my searching, I uncovered an issue where the OS can spin down the underlying drive of an inactive volume.  That is in the Windows Control Panel, under Power... Advanced...  I have set the HDD Spindown to "Never" - I will see if this works, but in looking at the other thread, it did resolve the issue, and the issue was exactly the same as I was seeing.

             

            I did notice that downloading the latest Driver did only contain the driver and GUI, thus, the only way to flash the firmware on the IRST controller is via a BIOS update, and mine is at the newest, so my 9.5.0.1037 is as new as that will be, although I'm aware there are other newer ones out... it seems it's safe to leave that as-is.

             

            I will update the drive firmwares, as that is just a normal/smart thing to do anyway, and now that I know the issues I was having were unrelated to drive firmware, I feel safe doing that.

             

            If I wanted to take this data and move it to RAID 10, please confirm that I understand it accurately:  2-drive RAID-1 to 4-drive RAID-10 is not supported directly. I would have to do the following:

             

            1) Reset the RAID-1 set to non-RAID (this may warn about data loss, but as long as it's the only volume on the drive, it should be a data-safe operation)...

            2) Add two new drives to the system.

            3) Select one drive of the formerly mirrored set, and choose to create a RAID-10 set, using that drive, plus three other drives.

            4) Allow IRST to create the volume and migrate the data accordingly

             

            Does that look correct?

             

            Is this correct?

            • 3. Re: RAID 1 going to degraded every other day or so
              allan_intel

              1) Reset the RAID-1 set to non-RAID (this may warn about data loss, but as long as it's the only volume on the drive, it should be a data-safe operation)... yes, that’s correct.

              2) Add two new drives to the system. Yes.

              3) Select one drive of the formerly mirrored set, and choose to create a RAID-10 set, using that drive, plus three other drives. yes, that’s correct.

              4) Allow IRST to create the volume and migrate the data accordingly. Yes, you are right on this procedure.


              Allan.