2 Replies Latest reply on Feb 3, 2014 7:44 PM by RemoNonaz

    Removable Drive Not Showing Up

    RemoNonaz

      I don't  know for sure if this is an Intel issue or a Windows issue:

       

      I have a DZ68BC MB at BIOS 0039, which seems fine.

      I have four SATA devices in the system now C:120GB SSD, F:1.5TB, D: 0.5TB,  E: DVD

       

      I want to add a removable hard drive bay to the system for doing large backups. I've installed the hardware and wired up the drive bay, but the system will not see any drive I put in the bay. I wired a drive directly to the MB and got the same results as the bay, so I don't think there is a problem with the drive bay or cable.

       

      I know there are essentially three sets of SATA ports on this board: 2-PCH 6GB, 2 Marvel 6GB and 4-PCH 3GB.

       

      Initially, I had the C drive and the DVD on the Intel PCH 6GB ports, the 1.5 and 0.5 drives on the Marvel ports and the removable hard drive on the PCH 3GB ports. The removable drive did not show in BIOS or win7.

       

      I swapped the DVD and removable drive so that the DVD is on port 0 of the 3GB ports and the removable drive is on port 1 (2nd) of the Intel 6GB ports. The DVD has been found by the BIOS and Win 7, but the removable drive is still not present, despite hardware refresh requests in Windows and setting the BIOS to enable removable drives.

       

      After fussing with this for quite a while, I was about to give up when suddenly my removable drive showed up. I was able to repartition it, reformat it and assign it drive letter R. With some more fussing I was able to do this with 6 of the 8 drives I have. I ran backup onto 3 of the 6 drives without any issue. I then tried again to get the remaining 2 drives to show up so that I could reformat them. No go. Now I can't get any of the 8 to show up, including the ones that are reformated and have backup data on them.

       

      I've been doing the refresh and rescan disks from the Disk Management screen right along. Once in a while it works; mostly not. I tried rebooting the system with the 4th drive installed and that does not work. I also checked the BIOS to make sure that the removable drive position is enabled for hot swap. I've also noticed that frequently after making BIOS changes, on the next boot the Intel Management has adrives   ! in Device Manager. Rebooting the system has cleared this every time so far.

       

      Anyone want to venture as to what is happening?

       

      More info - more bizarre:

       

      I decided to reboot the system into BIOS and see again if the drive was there. It was not. I removed the drive from the hot swap drive bay and took the SATA and power connector off the drive bay and put them on the drive directly and booted into BIOS again. This time the drive was there.

       

      So, I booted the OS. The drive was present.  I disconnected the drive - power first, then SATA cable. After doing this, the drive activity LED stayed on for about a minute. When it extinguished, the drive disappeared from Windows.  I took one of the drives that I hadn't reformatted yet and connected it to the leads, SATA first, power second without shutting down. Near instant recognition by Windows. I set it up and went on to do this with the other remaining unformatted drive and I checked one of the previously written to drives. All OK, no problems with recognition.

       

      So this would lead you to say, the drive carrier is broken or screwed up somehow. I reconnected the SATA and power cable to the drive carrier and inserted a drive. Presto - the drive shows up in Windows, just like is supposed to. Right now I am writing a bunch of files to it for storage.. This was looking good, so I started another backup to one of the drives. About ten minutes in, the screen went black and I had the message: Unkown File System: Rescue Grub. I  rebooted. The drive was there and so was the ! in Intel Management Engine. I booted again. This time IME cleared and the drive was also there. The backup was about half done and it is being completed now. Still weird.

       

      I've checked again in the morning and the drive bay continues to work OK. I have no idea how I got from where I started to where I am, but all seems well. Luck or ignorance - I don't know.