1 2 Previous Next 28 Replies Latest reply on Sep 16, 2014 12:04 AM by demoncamber

    Netflix, D34010WYK and 5.1 audio

    kari-s

      This combination just does not work. There is probably another discussion about it here, but I did not find it.

      The problem has been mentioned also elsewhere, like in here: AnandTech | Intel's Haswell NUC: D54250WYK UCFF PC Review

       

      I should have the most recent drivers for D34010WYK. 2 channel Netflix works well in HDMI, but 5.1. does not work at all.

       

      Will there be a solution to this? This has been a known thing for a long time already.

        • 1. Re: Netflix, D34010WYK and 5.1 audio
          kari-s

          I forgot to mention: the problem is in Metro version of Netflix in Windows 8.1.

          • 2. Re: Netflix, D34010WYK and 5.1 audio
            kari-s

            I answer to myself: the problem was solved by disabling legacy boot.

            Then HDMI dd5.1+ will work without problems. Very strange.

            • 3. Re: Netflix, D34010WYK and 5.1 audio
              d97ulf

              I can confirm that disabling legacy boot on my D54250WYK also solves this issue. However, I am a little bit surprised that this BIOS option has anything to do with the audio driver...

               

              Thanks for the tip!

              • 4. Re: Netflix, D34010WYK and 5.1 audio
                pr0xzen

                @d97ulf

                 

                Your NUC (D54250WYK) is a Haswell NUC. This nuc has got the Intel Management Engine driver - which is needed for Protected Audio Path. Installing this driver should solve this issue these platforms. Now, the Bay Trail systems however...

                • 5. Re: Netflix, D34010WYK and 5.1 audio
                  d97ulf

                  @pr0xzen:

                   

                  Ok, I see. I can also confirm in this thread that legacy option in BIOS does not seem to have anything to do with this issue (which is kind of a relief). Further testing showed that it did not influence the behavior in the Netflix Metro app.

                   

                  I guess it is more likely that I got lucky with installing a driver bundle that actually includes the Intel Management Engine driver as pr0xzen suggests. This could have been done in the background by Windows update...

                  • 6. Re: Netflix, D34010WYK and 5.1 audio
                    kari-s

                    Netflix Metro used to work before I updated my BIOS. Now it does not work any more with 5.1. audio HDMI. I have Intel Management Engine installed. At least I installed it by hand. The two most recent BIOSes seem to have problems with 5.1. HDMI in Netflix Metro. Disabling legacy boot does not help any more.

                    • 7. Re: Netflix, D34010WYK and 5.1 audio
                      AlexanderR

                      I have a D54250WYKH and i have the same problem.  IME driver is installed but 5.1 in netflix metro doesn't work. Haven't tried the legacy "fix" since i can't get in to the bios anymore(the nuc logo and promt is gone).

                      • 8. Re: Netflix, D34010WYK and 5.1 audio
                        pr0xzen

                        Did you activate Fast Boot?

                         

                        If so - when booting the NUC - push and hold the power button for ~2-3 seconds (or until you hear a beep, although I don't think the NUCs give any sound. Mine doesn't). This should either give you boot options on-screen, or send you straight to BIOS. Might take a few tries to get the timing right.

                         

                        The Legacy "fix" isn't really a fix - Legacy mode ("old BIOS mode") limits the capabilities like e.g. proper hdmi audio throughput etc. With these units, you can't have both - atleast not under Windows 7/8. I believe it is in the documentation - although it should be more "pronounced". This, and a decent explanation of both UEFI and Legacy support - what it does, and how it will affect operation and OS. With modern, EFI/UEFI supported OS'es - Legacy boot should be disabled unless you need to use old usb stuff during boot, wich doesn't function witouy Legacy USB support. Some UEFI "BIOS"es can be misleading in regards to this, some have both Legacy (BIOS) boot, and Legacy USB support. As far as can go - try to limit settings to Legacy USB support, and only if needed.

                        • 9. Re: Netflix, D34010WYK and 5.1 audio
                          AlexanderR

                          Fastboot isn't enabled. Maybe it has enabled itself since the machine boots windows amazingly fast. But the check box is blank in the bios. So far this bios seems like a mess.

                          • 10. Re: Netflix, D34010WYK and 5.1 audio
                            pr0xzen

                            Did the procedure help you get into BIOS? If so, that is the most important thing.

                             

                            Tip: This is not available for all editions, but if you hover over an option and want to know more, what it does etc - Press F1.

                            • 11. Re: Netflix, D34010WYK and 5.1 audio
                              AlexanderR

                              Yea, i got in to the bios using the 3 second button method. Problem was that it couldn't find any OS afterwards so it wouldn't boot. Flashed the 025 bios once more and it booted.

                              • 12. Re: Netflix, D34010WYK and 5.1 audio
                                pr0xzen

                                Either your bios (UEFI) was corrupted before the new flash, or settings loaded did not suit your system setup. Glad to hear the reflash helped though.

                                 

                                Have you been able to test Netflix Metro 5.1 DD+, with legacy settings disabled?

                                • 13. Re: Netflix, D34010WYK and 5.1 audio
                                  sylvia_intel

                                  Guys would you please let me know if you are still having this issue?

                                  If you do, please let have the following information:

                                   

                                  • NUC model number:
                                  • Graphics driver version:
                                  • BIOS version
                                  • Adapter you are using if any

                                   

                                  If you were able to solve this behavior, please let us know how you did.

                                   

                                  Thanks  a lot

                                  • 14. Re: Netflix, D34010WYK and 5.1 audio
                                    lhill

                                    Hi all,

                                     

                                    After much testing regarding this issue, we found a very simple workaround (at least with the Denon receiver tested here). In Control Panel > Sound, open the properties for the receiver on the Playback tab. Go to the Advanced tab and disable both of the Exclusive Mode options you see there.

                                     

                                    sound-properties.jpg

                                     

                                    Now check how the Dolby Digital 5.1 behaves. On our lab system, it immediately solved the problem. I'd like to get confirmation from others before I add this to our troubleshooting documentation on the support website.

                                     

                                    Lois

                                    1 2 Previous Next