0 Replies Latest reply on Jan 31, 2014 7:28 PM by bogchop

    DN2820FYKH - BIOS, Boot menu and update issues

    bogchop

      Hi there,

       

      I have three issues to report, using the latest BIOS update (21) for the DN2820FYKH. Installed is a 4GB kingston ram module (low voltage of course), and a Kingston V300 SSD (60GB).

       

      Keyboard/mouse

      First issue is with the keyboard going 'dead' in the BIOS. I have observed this randomly, and have also seen that this has occured on another NUC here on the forums. The mouse still works, and it has become quite frustrating.

       

      Boot menu

      For some reason, this has stopped working with the latest BIOS. When pressing the F key to access it, the screen changes to a light grey, and is stuck there until a hard reboot is performed. This was working fine with the factory BIOS that came (v15?).

       

      BIOS Update

      I cannot tell if this was fixed or not, but upon trying to update the original factory BIOS (again v15 i believe), you would receive an error saying unknown ID, or similar. I got around this by downloading it onto a USB stick and performing a manual update.

       

      Other things to note

      I've had issues installing OpenELEC (nightly builds have worked, official not yet so). Updated to BIOS 21 and things got better. I eventually got it to boot and install, however, upon rebooting from installation, I would constantly receive 'boot device not found' errors. I tried different combinations of legacy/fast boot, UEFI, etc... and to no avail. Eventually I gave up and tried restoring BIOS defaults, and for some magical reason, OpenELEC would now boot. I don't know how/why, but this is just my experience.

       

      That's all for now.

       

      Cheers.