4 Replies Latest reply on Feb 8, 2014 8:17 PM by Karlylite

    Only getting SATA Gen 1 Speed with INTEL 530 SSD

    Karlylite

      Hello all. I am stuck.

       

      I have an Aspire x3400 with nForce 720a chipset (??) which should support SATA II.

       

      I have installed a Intel 530 SSD which is SATA III.

       

      I boots fine after cloning the old drive to this new one. And it is quicker no doubt to load windows 7 - 64 bit.

       

      AS SSD shows Seq read of 130 MB/S and ~ 99 MB/S write.

       

      As well the ATA controller in Device Manager, says it is a Gen 1 Speed. (while the old drive connected externally via eSATA says it is at Gen2).

       

      I have tried the generic ATA controller and have also update to latest Nvidea driver for the controller. I have tried a new cable, and tried a different SATA port. No change.

       

      Any thoughts on how to get this SSD to SATA II speeds?

       

      Thanks aspire

        • 1. Re: Only getting SATA Gen 1 Speed with INTEL 530 SSD
          joe_intel

          I am sorry for your issue.

          It might help updating the system BIOS or Intel® SSD firmware.

          By “generic ATA controller” I guess you meant the Microsoft*’s inbox driver, which it is also a good idea.

          You may also want to test the Intel® SSD in a different system.

          • 2. Re: Only getting SATA Gen 1 Speed with INTEL 530 SSD
            bogdan

            What does ATTO Disk Benchmark show?

            • 3. Re: Only getting SATA Gen 1 Speed with INTEL 530 SSD
              parsec

              Sorry to say, it's the Nvidia SATA chipset and the Nvidia driver.

               

              This is an issue noticed by other Nvidia chipset board users, and some Mac PC users with Nvidia chipsets. It happens with any SSD that is SATA III.

               

              When a PC is started, the SATA chipset communicates with each drive it finds, and among other things negotiates the speed of the chipset - drive interface. Every drive has data that informs the SATA interface what speed it can operate at, a 530 has data identifying it as a SATA III, 6Gb/s drive. The Nvidia chipset was designed before SATA III existed, and does not recognize the SATA III identification as valid data, so to be safe switches to SATA I speeds, 1.5Gb/s. Your benchmark results show that clearly.

               

              Note the release date of the Nvidia driver, maybe 2008 at best? Nvidia abandon manufacture and support of their chipsets several years ago, meaning no new drivers. Unfortunately nothing can be done to fix this issue. I don't think a different driver helps, like the standard Microsoft driver available in your Windows installation. Worth a try but I don't recall anyone saying it made a difference.

               

              As I said, the same thing will happen with any SATA III drive, I've seen forum posts about this at OCZ, SanDisk, and for earlier Intel SATA III SSDs.

              • 4. Re: Only getting SATA Gen 1 Speed with INTEL 530 SSD
                Karlylite

                Thanks for the help! I have found this mentioned in a few places, but your answer puts an end to me searching for an answer.

                 

                I am building a new system with an ASRock 960GM/U3S3 FX motherboard and new CPU/RAM/PSU. We will see how that goes.

                 

                I will use the same SSD 530 and see what speeds I get.

                 

                Cheers and thanks again.

                 

                Steve