1 Reply Latest reply on Jan 29, 2014 3:02 AM by Sparky9334

    Intel i217-LM Duplex Problem

    Sparky9334

      We have an issue with the networking on the built-in i217-LM Intel NIC on HP EliteDesk 800 PCs

       

      100mb full just doesn't work. Our Allied Telesis switches are hard set to 100mb/Full but the PCs are reporting (in the NIC settings) 100mb/Half when we set the PC to auto negotiate or hard set to 100mb/Full. This causes collisions and we get dropped packets. A test PC is set to 1GB (switch too) and it works fine.

       

      Our network is 100mb/full and the switches are hard set (and we want it kept that way). I've played around with some of the settings and had no luck. If we have the switch and PC hard set to 100mb FULL we get problems.

       

      Any ideas? We want to hard set the PCs and the switch to 100mb/FULL like we have done on all the other PCs in the building!


      We've had some success with changing the "Wait for Link" in the advances settings to Off, but then when the PC reboots the network doesn't come back up unless we unplug and re-insert the cable.

        • 1. Re: Intel i217-LM Duplex Problem
          Sparky9334

          We found a solution to our issue with the i217-lm, assume it would be similar to the -v so worth a try.

           

          Regardless of whether we set the NIC to 100mb/full, it still tried to auto neg and neg and 100mb/half, despite switch set to 100mb/full and not to auto neg.

           

          To fix, search the registry for the key LinkNegotiationProcess, and set it to 2.

           

          In our case there were 3 instances that need changing.

           

          The default setting is 1, which is to auto negotiate. 2 is forced. This has solved the problem on all our HP EliteDesk 800s.

           

          Reg keys if anyone is interested, for our Intel i217-LM NIC:

           

          Windows Registry Editor Version 5.00

           

          [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

          "LinkNegotiationProcess"="2"

           

          [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

          "LinkNegotiationProcess"="2"

           

          [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

          "LinkNegotiationProcess"="2"