1 Reply Latest reply on Jan 24, 2014 8:57 AM by kevin_intel

    GPT, AHCI, Windows 8.1. IRST Intel Rapid Start + Storage Technology:  An unknown error has occurred

    dusf

      My laptop is an Asus Zenbook UX32A with an Intel® HM76 Express Chipset and 4GB of RAM. It has a 465GB HDD, and 22GB SSD. It supports Intel Rapid START Technology and Intel Rapid STORAGE Technology as Asus offer out of date Windows 7 x64 drivers for those technologies - I have called them about this and they told me they will not support clean installs, and no Windows 8 recovery media is available but I want a clean install anyway. Some months ago I did a clean install of Windows 7 and could never get these technologies to work and I am now experiencing the same problem on my clean Windows 8.1 install. Windows 8.1 is installed on a 100GB GPT partition of the HDD.

       

      The guides I have been using:

       

      http://download.intel.com/support/motherboards/desktop/sb/rapid_start_technology_user_guide_for_uefi1.pdf

       

      http://download.intel.com/support/chipsets/sb/intel_smart_response_technology_user_guide.pdf

       

      The Intel Rapid Start guide instructs I first make sure Intel Smart Response Technology installed, and the guide for that wants me to enable RAID in the BIOS. There is no RAID option in the BIOS, only IDE and AHCI, the latter of which I have selected. I continue anyway and run the Intel Rapid Storage Technology (RAID) setup - I have tried various versions from the ASUS site and the Intel site including an Intel NUC AHCI version. A few minutes after restarting the Intel Rapid Storage Technology manager appears in the system tray, and it opens up fine but there is never an accelerate option like in the guide, instead I see this:

       

      Intel Rapid Storage - Status.jpg

       

      Intel Rapid Storage - Manage.jpg

      I continue onto the Intel Rapid Storage Technology Guide for UEFI mode anyway. It instructs me to go into the BIOS options Advanced and Power section, find the option for Intel Rapid Start Technology and enable it setting the Hibernation Timer to immediately but those options are definitely not in my BIOS, just like the RAID option, and I check each restart during my attempt to install all of this. I then run the Command Prompt as administrator:

       

      C:\windows\system32>diskpart

       

      Microsoft DiskPart version 6.3.9600

       

      Copyright (C) 1999-2013 Microsoft Corporation.

      On computer: BANSHEE

       

      DISKPART> list disk

       

        Disk ###  Status        Size    Free    Dyn  Gpt

        --------  -------------  -------  -------  ---  ---

        Disk 0    Online          465 GB  365 GB        *

        Disk 1    Online          22 GB    22 GB

       

      DISKPART> select disk 1

       

      Disk 1 is now the selected disk.

       

      DISKPART> convert gpt

       

      DiskPart successfully converted the selected disk to GPT format.

       

      DISKPART> list disk

       

        Disk ###  Status        Size    Free    Dyn  Gpt

        --------  -------------  -------  -------  ---  ---

        Disk 0    Online          465 GB  365 GB        *

      * Disk 1    Online          22 GB    22 GB        *

       

      DISKPART> create partition efi size=4096

       

      DiskPart succeeded in creating the specified partition

       

      *************************************************************************************************************************************************************************

       

      Some non-official guides say the partition size should be larger so I have tried 4396 but it made no difference. I have also read instead of the 'create partition efi size=4096' command I should be using something like 'create part MSR size=4300' but this also made no difference.

       

      *************************************************************************************************************************************************************************

       

      DISKPART> list partition

       

        Partition ###  Type              Size    Offset

        -------------  ----------------  -------  -------

        Partition 1    Reserved          128 MB    17 KB

      * Partition 2    System            4096 MB  129 MB

       

      DISKPART> set id=D3BFE2DE-3DAF-11DF-BA40-E3A556D89593

       

      DiskPart successfully set the partition ID.

       

      DISKPART> detail disk

       

      SanDisk SSD i100 24GB

      Disk ID: {8C4539EA-CBAE-4016-BBF9-2ED02D409EF9}

      Type  : SATA

      Status : Online

      Path  : 1

      Target : 0

      LUN ID : 0

      Location Path : PCIROOT(0)#PCI(1F02)#ATA(C01T00L00)

      Current Read-only State : No

      Read-only  : No

      Boot Disk  : No

      Pagefile Disk  : No

      Hibernation File Disk  : No

      Crashdump Disk  : No

      Clustered Disk  : No

       

      There are no volumes.

       

      DISKPART> exit

       

      I then confirm in Windows Disk Management I can see the 4GB Healthy Primary Partition on the SSD. I reboot to allow the BIOS to pick up the partition, which still has no IRST or RAID options, and then I run Rapid Start Technology Installer_3.0.0.1053 and reboot again. Just like Intel Rapid Storage Technology before it, the Intel Rapid Start Technology manager is running in the system tray, and when I click it it tells me it is turned on BUT when I click on settings it notifies me 'An error occurred while loading the configuration information for Intel Rapid Start Technology' and sometimes once open it warns 'Intel Rapid Start Technology detected software-based whole disk encryption on this system. Intel strongly recommends disabling Intel Rapid Start Technology to help preserve the security benefits of your drive encrytion software. Click "OK" to disable Intel Rapid Start Technology of "Cancel" to keep Intel Rapid Start running' and I just close that window - I have no drive encryption setup, no Bitlocker, and the only security software I have are Avast Free, Malwarebytes Anti-Malware Free, and Comodo Firewall Free. The Intel Rapid Start Technology manager does load up, and I am able to see it is set on with the timer set to on and and 0 mintues but even after more restarts, I get the same errors.

       

      It is only natural to think I might have missed the BIOS options for RAID so please see the pictures below:

       

      20140123_113137.jpg

       

      20140123_113203.jpg

       

      20140123_113224.jpg

      I had the same problem following the MBR Intel Rapid Start guide when I tried this before converting the Windows system partition from MBR to GPT. Maybe I am using the wrong drivers? Maybe I am not supposed to be able to select RAID in BIOS? If you have any idea what I might be doing wrong, please please comment - this is keeping me awake at night!

       

       

       

       

        • 1. Re: GPT, AHCI, Windows 8.1. IRST Intel Rapid Start + Storage Technology:  An unknown error has occurred
          kevin_intel

          Hi dusf,

           

          I am sorry to hear you are having problems but let me help you.

           

          It is important to mention that we as Intel® provide the hardware to the computer manufactures and they will design and create special drivers with special configuration for their systems limiting sometimes features in the computer. This means that they pre-configure their systems with all special configurations to have it working with the original operating system.

           

          I am afraid that it is a must to have the chipset mode set as RAID in order to have the acceleration option working. If you are missing feature/options at the bios level, means that the computer manufacture has blocked this options. 

           

          My best recommendation is to confirm with the computer manufacture if those options can be unlocked to have the SMART and the Rapid Start technologies working.