7 Replies Latest reply on Mar 23, 2016 6:45 PM by ChknNRice

    I217-LM network adapter problem with 100MB full duplex

    Stephan

      I recently updated my Microsoft Deployment Toolkit repository with the latest cabs to support new Dell laptop.

       

      After the site is updated, I started having problem with older Dell Desktop and laptop reimaged. The problem was that the network cable show disconnected after powering up the system. The wire disconnected stayed disconnected until we physicaly disconnect the network cable and reconnect it. The 100MB full duplex setting was correct. Updating to the latest version of the driver fix the connection status problem on those older hardwares.

       

      We now have a persistent problem with the latest system having the I217-LM NIC onboard. The disconnected wrire status problem at boot up occured and with the latest driver downloaded from Intel we have a duplex connection problem. All our Dell switches are configured to force the connection to 100MB full duplex. We then force the NIC to 100MB full duplex. When we check the connection status in the Intel advanced tool, it shows 100mb half-duplex.

       

      After having tested all the possibilities, the only way we could achieved a stable connection to 100MB full-duplex is by setting both switch port and NIC to auto-negotiation. This is not an option for us because all the PC are daisy chain with an IP phone configured to work at 100MB full-duplex and with other NIC, auto-negotiation are not working well all the time.

       

      I tried with older driver version of the driver available for download and the connection status at bootup occured with all the version prior 18.7 and with 18.7 version, it is impossible to force the speed to 100MB full-duplex.

       

      Is it possible to have a quick fix for this problem? I am pretty sure it is a compatibility problem with the latest harware NIC, driver and Dell switches.

       

      Thanks for your attention.

        • 1. Re: I217-LM network adapter problem with 100MB full duplex
          Sparky9334

          We have the same issue on some new HP EliteDesk 800s with the i217-LM card.

           

          100mb full just doesn't work. The switches are hard set to 100mb/Full but the PCs are reporting 100mb/Half when we set to auto negotiate and hard set the PC to 100mb/Full. This causes collisions and we get dropped packets.

           

          A test PC is set to 1GB (switch too) and it works fine.

           

          Our network is 100mb/full and the switches are hard set (and we want it kept that way).

           

          Any ideas? We want to hard set the PCs and the switch to 100mb/FULL like we have done on all 800 PCs in the building!

          • 2. Re: I217-LM network adapter problem with 100MB full duplex
            gkraut

            Same issue with Dell Optiplex 9020's with with I217-lm card.  Auto-negotiate works fine but the network requires 100mb/Full Duplex.  When changing to this setting the NIC shows as no cable connected.

             

            Hopefully Intel will hop on this issue quickly.

            • 3. Re: I217-LM network adapter problem with 100MB full duplex
              kjansen

              We are having this same issue on our network Auto-negotiate seems to work fine only problem is some of our switches are set to 100/full.

              This problem started with our latest shipment of Dell 9020's and the I217-LM card.

                   Intel we need a fix for this!

              • 4. Re: I217-LM network adapter problem with 100MB full duplex
                Sparky9334

                We found a solution to our issue with the i217-lm.

                 

                Regardless of whether we set the NIC to 100mb/full, it still tried to auto neg and neg at 100mb/half, despite switch set to 100mb/full and not to auto neg.

                 

                To fix, search the registry for the key LinkNegotiationProcess, and set it to 2.

                 

                In our case there were 3 instances that need changing.

                 

                The default setting is 1, which is to auto negotiate. 2 is forced. This has solved the problem on all our HP EliteDesk 800s.

                 

                Reg keys if anyone is interested, for our Intel i217-LM NIC:

                 

                Windows Registry Editor Version 5.00

                 

                [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

                "LinkNegotiationProcess"="2"

                 

                [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

                "LinkNegotiationProcess"="2"

                 

                [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

                "LinkNegotiationProcess"="2"

                • 5. Re: I217-LM network adapter problem with 100MB full duplex
                  Stephan

                  Thanks Sparky9334,

                   

                  I just tested your solution and it worked for me.

                   

                  Just need to change the active version of CurrentControlSet

                  [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318}\0007]

                  "LinkNegotiationProcess"="2"

                   

                  I hope that the next release of PROWIN64 will fix this problem. So this tweek will not be necessary.

                  • 6. Re: I217-LM network adapter problem with 100MB full duplex
                    kjansen

                    I can also confirm that the three registry changes worked for our Dell 9020's.

                     

                    Thanks!

                    • 7. Re: I217-LM network adapter problem with 100MB full duplex
                      ChknNRice

                      This is still an issue.  Registry fix works for T7810s.  Driver versions don't matter.  I tried 4 different ones.