12 Replies Latest reply on Feb 11, 2014 2:31 PM by GregoryL

    eSATA port does not support hot plugging on DQ77MK

    GregoryL

      I recently bought a Vantec EZ Swap EX mobile rack enclosure and was trying to set it up but run into a problem that I'm not able to eject a device once it is connected, for some reason the device is not recognized as a hot pluggable and the only option to correctly eject a hard drive is to shutdown the machine. I've tried to connect to an external eSATA port and checked BIOS setting to make sure the port is enabled and marked as hot plaggable. But it still does not work as expected. I did try to connect just a hard drive without the enclosure just to make sure that it is not related to the enclosure. Besides the issue with the eSATA port, non of the internal ports work as hot pluggable as well (regardless of the BIOS settings) and i ideally would want to connect that enclosure to an internal port.

       

      I've seen some fixes related to that for 0048 BIOS, but i'm not sure i want to donwgrade my BIOS to that version. I have two computers based on the DQ77MK board on running Windows 8.1 x64 another running Windows 7 x64 with RST 12.8 and both have the same problem. Any help would be appreciated.

       

      DQ77MK with 0064 BIOS, version G39642-500

      Windows 8.1 x64 (UEFI enabled)

      RST 12.8

        • 1. Re: eSATA port does not support hot plugging on DQ77MK
          sylvia_intel

          Gregory, since BIOS v0048 fixed the issue you are experiencing, I think it will be necessary to install it.

           

          I recommend you to install the BIOS versions that include an Updated on the ME (Management Engine). These BIOS are 0048, 0052 and 0056.

          So, using the recovery method, please install BIOS 0048. Then, using the same technique, install BIOS v0052.

          Finally, you can update to version 0056.   Please test the eSATA after each BIOS installation.

           

          In addition to that, please use minimum system configuration and it will be important to take the motherboard out of the chassis. Follow this procedure on only one motherboard.

          • 2. Re: eSATA port does not support hot plugging on DQ77MK
            GregoryL

            After running bunch of tests i can definitely say that you have a few bugs in your Rapid Storage Technology drivers. First starting from 12.8 version it does not recognize eSATA port as hot pluggable. And none of the versions i've tried recognize internal ports as  hot pluggable, regardles sof BIOS settings and versions. I've tried with version 11.6, 11.7,12.0, 12.5 and 12.8. But if i just use Windows 8.1 drivers everything works. I only tested using AHCI mode.

             

            Here are the tests that I did:

             

            Fist I downgraded BIOS to 0048, which didn't fix anything. So I figured it wouldn't heart  to downgrade my RST drivers to 12.5 and to my surprise my eSATA port started working as expected, when I connect a device and it shows up in the list of removable devices and I can eject it. Although internal ports didn't show up in the list of removable devices.

             

            So i started upgrading BIOS from 0048 to 0052, 0056 and stopped at 0058. Regardless of the BIOS version eSATA port was working and internal ports won't.

             

            At this point i suspected that my problem with internal ports not working as hot pluggbale could be related to Intel drivers as well. So I reinstall Windows 8.1 x64 on a spare disk without installing Intel RST drivers and using default Windows AHCI driver. And both eSATA port and internal ports started working as expected, and once connected devices would show up in the list of removable devices.

             

            After that i installed RST 11.6 (looks like this is the first version that supports Windows 8) and internal ports stopped working as hot pluggable and after installing RST 12.8 eSATA port stopped working as hot pluggable.

             

            So looks like the problem is not related to BIOS but to the RST drivers.

             

            I could use the workaround and just use Windows drivers since everthing works with Windows drivers, but i'm going to use Intel Smart Response Technology and i cannot without Intel RST drivers.

             

            Any ETA on fixing this?

             

            Thanks.

            • 3. Re: eSATA port does not support hot plugging on DQ77MK
              sylvia_intel

              Thanks a lot for sharing all details on the troubleshooting performed.

              Before reporting this issue to the engineers, would you please try to install the latest version of the Intel® Rapid Storage Technology V12.9? Let me know the result.   https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23496&ProdId=2101&lang=eng&OSVersion=%0A%09%09%09%09%09%09%09%09%0A%09%09%09%09%09%09%09&DownloadType=    

              1 of 1 people found this helpful
              • 4. Re: eSATA port does not support hot plugging on DQ77MK
                GregoryL

                Upgrading to RST 12.9 fixed the eSATA port behavior on both Windows 8.1 x64 with AHCI and on WIndows 7 x64 with RAID configurations. I also see this as one of the problems that were resolved in that release in the release notes. But internal ports still not hot swappable, i can see an empty internal port in the RST management console when i make it hot pluggable, which was the case for all RST versions I tested, but once the device is connected there no option to eject it with out shutting down the computer.

                 

                I'm not sure what would be a good option to keep track of these issues on the forum, since this post has two issues one with eSATA and another with internal ports, they somewhat related, but it probably will be better to split them. So i don't mind marking this one as resolved and creating a separate topic for troubleshooting internal ports.

                 

                Thanks.

                • 5. Re: eSATA port does not support hot plugging on DQ77MK
                  sylvia_intel

                  I think it will be an excellent idea since the eSATA is working.

                  1 of 1 people found this helpful
                  • 6. Re: eSATA port does not support hot plugging on DQ77MK
                    GregoryL

                    I moved another problem with internal SATA ports into a separate topic

                    The specified item was not found.

                    • 7. Re: eSATA port does not support hot plugging on DQ77MK
                      GregoryL

                      Why the topic about second issues was deleted? I can see that i'm not the only one who has that problem with internal ports: https://communities.intel.com/message/179015#179015

                      • 9. Re: eSATA port does not support hot plugging on DQ77MK
                        sylvia_intel

                        GregoryL, first of all I don’t really know why your new post was deleted. I apologize.

                        I would like to inform you that hot plugging is a feature included on our desktop boards, but hot swappable is a feature specific for raid controllers,  mostly present on servers system.

                        • 10. Re: eSATA port does not support hot plugging on DQ77MK
                          GregoryL

                          According to the AHCI specification Hot Plug Operation supports both adding and removing devices, see page 88: https://www-ssl.intel.com/content/www/us/en/io/serial-ata/serial-ata-ahci-spec-rev1-3-1.html

                           

                          Although it is somewhat suggests that it is up to the software (driver) to properly handle it. It seems like the ability to properly eject hot plauugable SATA devices connecetd to internal ports was specifically disabled in the Intel driver for some strange reason. And that part is not clearly documented anywhere.

                           

                          And it is somewhat missleading that both internal ports and eSATA port have the same "hot pluggable" setting that works differently depending on the port.

                           

                          Interestingly enough those hot pluggable seetings in BIOS only have effect in Windows and don't have any effect in Linux, all ports return the same list of capabilities regardless of the BIOS settings and any SATA device can be stopped and unplugged. And Windows drivers also implement AHCI support correctly and allow devices to be ejected.

                           

                          Is there a reason why Intel drivers not fully support AHCI spec?

                           

                          Thanks.

                          • 11. Re: eSATA port does not support hot plugging on DQ77MK
                            sylvia_intel

                            Hardware level, it does support it. Therefore you are able to use it on Linux.

                             

                            Nut, Desktop drivers does not include full support for hot swappable, the reason is because it was specifically designed for server board’s environment.

                            • 12. Re: eSATA port does not support hot plugging on DQ77MK
                              GregoryL

                              I see Intel's point, that's true, i don't have server class hardware and i don't really want to get Intel's hardware RAID controller just for that, but it would be very useful to have that working for desktops as well. I guess i will have to stick with Microsoft driver for now.

                               

                              Thanks.