2 Replies Latest reply on Jan 21, 2014 5:41 AM by kevin_intel

    Storage Controller failing to update

    Sporkyy

      Hello,

       

      I'm having a few problems with updating a driver on my system, for some reason it refuses to install. I am running Windows 8 (I don't want to use 8.1) and this update is always availible in my automatic updates:

       

      Intel Corporation - Storage Controller - Intel(R) 7 Series Chipset Family Data AHCI Controller


      I have tried to manually (from site) install this update and automatically, but still it refuses to install it's self.


      System Specs:

      Dell Inspiron 3521

      Intel(R) Core(TM) i5- 3337U CPU @ 1.80 GHz (Turbo 2.7GHz) x64

      RAM: 8GB

      Windows 8

       

      I have disabled all Antivirus and Firewalls on my system when trying to install this software.

       

      Any ideas on how I can solve this issue?

       

      Thanks in advance guys.

        • 1. Re: Storage Controller failing to update
          Sporkyy

          This software also fails to install - However it does not appear in the Windows 8 automatic downloads, it is only visible from the Intel Drivers + Downloads site:

           

          Intel HM77 Chipset Driver - Chipset_Driver_C0M3R_WN_9.3.0.1021_A01.EXE (9MB)

          • 2. Re: Storage Controller failing to update
            kevin_intel

            Hi Sporkyy,

             

            I am sorry to hear you are having problems with the unit but let me help you with that.

             

            Based on the information you provide, the driver you are trying to install is the Chipset driver for your system. It is important to mention that the chipset driver is provided by the Computer Manufacture only because they sometimes set limitations in the software.

             

            My best recommendation for you is to contact the computer manufacture and get the latest chipset driver for your system. The one is showing under Windows Updates you can just ignore it if you do not want to install it or needed.