1 2 Previous Next 18 Replies Latest reply on Nov 5, 2014 1:00 PM by xbolshe

    Intel 7260 WiFi Support?

    ecf_in_md

      I bought a combo of Galileo and an Intel 7260HMW Wireless N adapter from a well-known online retailer. I assumed it would be compatible, but it seems not. First, it didn't come with the bracket needed to mount a half mini-pcie card into a mini-pcie slot. That was fixed inexpensively at the cost of a few days waiting. However, now that it is installed I can't seem to get it to work. I followed the instructions on Segey's blog, Intel Galileo Meets Wireless - Malinov Family Web Presence, and copied the appropriate firmware for the 7260 to the /lib/firmware directory. I am booting from the SD card image. I followed the rest of the directions but when I try ifconfig wlan0 up I get an error:

      ifconfig: SIOCGIFFLAGS: No such device

      It seems that the Intel Wifi driver is loaded. I see this in the output from dmesg:

      [   13.230283] Intel(R) Wireless WiFi driver for Linux, in-tree:

      [   13.236084] Copyright(c) 2003-2012 Intel Corporation

       

      I see the iwlwifi module in the output from lsmod:

      iwlwifi 77608 0 - Live 0xe103f000

       

      I am not 100% sure that the card is being detected. The output from lspci isn't very helpful:

      00:00.0 Class 0600: 8086:0958

      00:14.0 Class 0805: 8086:08a7

      00:14.1 Class 0700: 8086:0936

      00:14.2 Class 0c03: 8086:0939

      00:14.3 Class 0c03: 8086:0939

      00:14.4 Class 0c03: 8086:093a

      00:14.5 Class 0700: 8086:0936

      00:14.6 Class 0200: 8086:0937

      00:14.7 Class 0200: 8086:0937

      00:15.0 Class 0c80: 8086:0935

      00:15.1 Class 0c80: 8086:0935

      00:15.2 Class 0c80: 8086:0934

      00:17.0 Class 0604: 8086:11c3

      00:17.1 Class 0604: 8086:11c4

      00:1f.0 Class 0601: 8086:095e

      01:00.0 Class 0280: 8086:08b1

       

      None of that is meaningful to me. According to the website:

      http://wireless.kernel.org/en/users/Drivers/iwlwifi

      this device is supported for kernels 3.10 and later. I am guessing that is the problem, according to uname the kernel is 3.8.7. Any suggestions? I think the easiest thing is to buy an older wifi card.

        • 1. Re: Intel 7260 WiFi Support?
          Intel_Jesus

          Hi ecf_in_md,

           

          If i can get a hold of an Intel 7260HMW Wireless card in the next few days i will give this a shot.

          I would suggest using the Intel® Centrino® Wireless-N 135 since it is supported and the driver is already included in

          SD image.

           

          Regards,

          Intel_JEspinoza

          • 2. Re: Intel 7260 WiFi Support?
            Clayton Hofrock

            The good news is the device is being detected correctly:

             

            01:00.0 Class 0280: 8086:08b1

             

            Bus 1 is the PCIe bus. It is device 0 function 0 on that bus. 

             

            The Class 02 indicates that it is a Network device, and 80 I think indicates WiFi device.

             

            The 8086 indicates the vendor is Intel, and the 08b1 indicates that it is the 7260 Wireless card.

            1 of 1 people found this helpful
            • 3. Re: Intel 7260 WiFi Support?
              Intel_Jesus

              Hi ecf_in_md,

               

              I followed the same steps from Sergey's Blog (http://www.malinov.com/Home/sergey-s-blog/intelgalileo-addingwifi) and copied the firmware to /lib/firmware. I also got the same error as you: ifconfig: SIOCGIFFLAGS: No such device

               

              I tried both of the .ucode from http://wireless.kernel.org/en/users/Drivers/iwlwifi just to make sure i wasnt missing anything.

              - 3.10+

              - 3.13+

               

              I will continue to try to get it to work. It might just be that the drivers are not compatable with the kernal since the kernal is 3.8.7

               

              Regards,

              Intel_JEspinoza


              1 of 1 people found this helpful
              • 4. Re: Intel 7260 WiFi Support?
                ecf_in_md

                Thanks. I'm glad to know that the card is recognized. I was wondering where you found the information about the lspci output? I did some googling and looked at the lspci man page and found nothing. The version on the Galileo linux is from busybox, so I didn't see anything in the man page and I was too lazy to dig through the source.

                • 5. Re: Intel 7260 WiFi Support?
                  Clayton Hofrock

                  Mostly from experience. Every PCIE device has a Bus, Device, and Function number. That is obviously the first three numbers. You can see that a majority of the devices are on bus 0. Many of those are actually inside the galileo chip itself.

                   

                  To figure out if the class was correct I just googled, "class pcie code" which pointed to several sites that had tables like this on: Class Code Table (I probably could have looked at the PCIe book on my shelf, but google is quicker to search.

                   

                  The next numbers are the Vendor ID, 8086 is Intel's Vendor ID, and device ID. To make sure the device ID was correct, I again used google searching for "PCIE device id 8086 08b1" I had to include the Vendor ID, because each vendor could have a device with the 08B1 ID.

                   

                  While busy box does not have any built in manuals for their stuff, they should work the same as regular linux. After a few tries with google, I found this handy guide to decoding the lspci output:

                  Decoding PCI data and lspci output on Linux hosts

                  • 6. Re: Intel 7260 WiFi Support?
                    ecf_in_md

                    Thanks for the very helpful information.

                    Eric

                    • 7. Re: Intel 7260 WiFi Support?
                      AlexanderMerz

                      I've got the same card today and have trouble too. I also pulled the iwlwifi ucode. No success.

                       

                      I spend some time on Google an came across this patch: [1/4] linux-firmware: Update SRCREV, pull in iwlwifi-7260 support - Patchwork

                       

                      It seems that an more up-to-date version of poky/yocto might able to handle this. 

                      • 8. Re: Intel 7260 WiFi Support?
                        Intel_Jesus

                        Hi AlexanderMerz,

                         

                        What Linux image are you using? I am using the LSB built following Sergey's Blog http://www.malinov.com/Home/sergey-s-blog

                        Looking at directory /lib/firmware I can see a few Wi-Fi drivers including the iwlwifi-6000g2b-6.ucode as mentioned in Sergey’s Blog.

                        I can’t confirm that they work since I only have an N-135 card.

                         

                        Regards,

                        Intel_JEspinoza

                        • 9. Re: Intel 7260 WiFi Support?
                          AlexanderMerz

                          I use this image too. I also tried the firmware from iwlwifi - Linux Wireless (both versions).

                          If I understand the patch correctly and following the given timestamps, then these firmware drivers seems to work with newer Yocto releases that came after the first release of the Galileo BSP. So the problem is in fact, that the Galileo BSP provides a 3.8.x kernel, and not a newer 3.1x.x kernel

                          • 10. Re: Intel 7260 WiFi Support?
                            Fish

                            Gents,

                            My Galileo came with the Intel 7260 Wifi BT adapter and I also found that the kernel version of the Linux wifi driver does not match the Galielo 3.8 Yocto ?  Is this card not compatible ?  If so, I will not waste my time and I will order one that is currently working for other folks.

                             

                            I installed the 3.10 firmware version.  The only other choice was firmware 3.13.  Followed Sergey instructions.

                            Ex:

                            root@clanton:~# ifup wlan0

                            Successfully initialized wpa_supplicant

                            Count not read interface wlan0 flags: No such device

                            WEXT: Count not set interface 'wlan0' UP

                            wlan0: Failed to initialize driver interface

                            ifconfig: SIOCGIFFLAGS: No such device

                            root@clanton:~#

                             

                            Thank you,

                            Chris

                            • 11. Re: Intel 7260 WiFi Support?
                              Christianoel

                              I'm having the same problem, but as far as I have read, a kernel like 3.10.(xx) is preferred as stated earlier in the thread. However, is it possible to just compile the standard board sources (from the Intel site) with a newer kernel, just replacing the 3.8?

                              • 12. Re: Intel 7260 WiFi Support?
                                Fish

                                I gave up on the Intel 7260, I read in several places that the older Linux OS did not support the 7260.

                                I just received a new WIFI Centrino 135-N board and it was recognized upon booting up the Galileo.

                                I set the wpa_passphrase SSID and PASSWORD ok.

                                Getting NO LEASE, Failing when trying to connect.  I cannot bring the wireless interface up or down.

                                Anyone have an idea of what is not setup correctly ?

                                Do I have to modify the network interfaces file to auto connect or should it be connecting now ?

                                Fish

                                • 13. Re: Intel 7260 WiFi Support?
                                  Fish

                                  OK - WIFI is working.  Had the little antenna connected to the AUX only.  Added the second one to the main antenna terminal on the Centrino 135N and presto, Wifi sees networks and obtains lease... I will go back and try to get the 7260 working.

                                  • 14. Re: Intel 7260 WiFi Support?
                                    Christianoel

                                    I'm trying to do a new build with the 3.10 kernel with the support package from Intel, however I haven't been successful yet during the bitbake, I guess the patches doesn't really work with 3.10.

                                     

                                    EDIT: I guess I'll have to try to backport the firmware to 3.8. Will respond when I've tested it.

                                    1 2 Previous Next