6 Replies Latest reply on Feb 1, 2014 9:14 AM by Zorlac

    PS/2 not working on DZ87KLT-75K

    Zorlac

      My new Filco keyboard will only work via USB, no PS/2.

       

      I have the latest BIOS. I reset all setting to default and then reconfigured. Made sure the PS/2 port is enabled (checked).

       

      I tried a different keyboard using the USB to PS/2 adapter that was supplied with the Filco, and the other keyboard doesnt work either.

        • 1. Re: PS/2 not working on DZ87KLT-75K
          joe_intel

          Hello Zorlac, I am sorry for this issue.

           

          Please consider that if your keyboard is USB, probably the converter is not working. I suggest testing with a native PS/2 keyboard or mouse instead.

           

          Another possible troubleshooting step is testing the motherboard with minimum components out of the case, in a non-conductive surface.

           

          Otherwise, there is a chance that the port on the motherboard is not working. If so, you may contact your local Intel® support team for a warranty replacement.

           

          Contact Support

          • 2. Re: PS/2 not working on DZ87KLT-75K
            Zorlac

            Thank you for our response! I tried a native PS/2 keyboard and it works. This points to a problem with the adapter as you said. I then tried several adapters I was able to find and NONE of them work.

             

            I am assuming that no USB to PS/2 adapter is going to work for this specific Filco keyboard on my Z87 system board...

             

            Does Intel recommend a specific make/model of adapter to use?

            • 3. Re: PS/2 not working on DZ87KLT-75K
              joe_intel

              We usually encourage a direct connection between devices.

              We have a list of tested peripherals, which includes keyboards, but no trace of such adapters at this moment.

               

              Intel´┐Ż Desktop Board DZ87KLT-75K; Tested peripherals

               

              I am sorry for any inconvenience.

              • 4. Re: PS/2 not working on DZ87KLT-75K
                Zorlac

                Just wanted to update this post.

                 

                I was finally able to test my Filco keyboard with the USB to PS/2 adapter on another computer. It works perfect. So this tells me something is going on with the DZ87KLT-75K PS/2 combo port and there is nothing wrong with the Filco keyboard USB to PS/2 adapter that was included with the keyboard.

                 

                Why would a native PS/2 Microsoft keyboard work in said port, but not a Filco using a USB to PS/2 adapter? The Filco works great using USB on the same system board and works great via PS/2 on a different system board.

                • 5. Re: PS/2 not working on DZ87KLT-75K
                  joe_intel

                  I am sorry; this seems to be a compatibility issue.

                  • 6. Re: PS/2 not working on DZ87KLT-75K
                    Zorlac

                    Received my RMA board. I have done a full clean reformat with Windows 8.1 Pro x64, latest patches and latest drivers.

                     

                    - Board is a rev 305 instead of rev 304

                    - Board appears to be new

                    - Board allowed me to upgrade BIOS to 0447

                     

                    - PS/2 port still doesnt like my Filco keyboard. It worked once at POST to get me into the UEFI interface and then once in there it quit and hasnt worked since. I have to use USB still.