1 Reply Latest reply on Jan 5, 2014 12:18 PM by theveterans

    Intel® Centrino® Wireless-N 1030 / Router poor performance

    JohnDoe1234

      So I am having some issues with the speed of my wireless network.  I am not sure if it is something with my wireless card or router.  I have tried different settings but hoping someone can point me in the right direction.  Instead of anywhere close to 300mbps, my speed usually is at 72mbps and occasionally at 112 mbps.

      Windows 7 also, before anyone asks.

      Capture.JPG

      This is done sitting within 3 feet of my wireless router. It seems even in one room away but I wanted to eliminate all variable that I could to solve this.

       

      Wireless card: Intel® Centrino® Wireless-N 1030

      Router: Belkin N Wireless F5D8236-4 v3

       

      Setting on the router:

      Capture.JPG

      Capture.JPG

      Capture.JPG

       

      I have checked for and updated all drivers. Is there a limitation through my wireless card with the router?  I have tried different channels setting on the router with no real effect.  I would imagine the changing of various setting on the router would have some impact negatively or not on the speed. Any thoughts on what is wrong?

       

       

      Thanks for any help you can provide!

        • 1. Re: Intel® Centrino® Wireless-N 1030 / Router poor performance
          theveterans

          Try setting your Bandwidth to "40 MHz only" if there's an option. Here's the recommended Intel settings for maximum N connection: Wireless Networking — What are the recommended settings for 802.11n connectivity?

           

          The Centrino 1030 supports MIMO as well your router. However, if you have overlapping channels with your neighbor, your channel width will go back to 20 MHz and this will reduce your speed to 1/2 of the 40 MHz channel width.

           

          The 72 Mbps connection rate is obtained by 1x1 spatial stream, 64-QAM modulation and 20 MHz channel width. If your router is set to broadcast 300 Mbps connection and you're not getting that, it means there's WiFi interference in your location. Try switching to the best channel using Inssider and see if you can get at least 144 Mbps (2x2 spatial stream, 64-QAM modulation, 20 MHz channel width). An interference free WiFi will almost always give you 300 Mbps connection (2x2 stream, 64-QAM, 40 MHz channel width).

          • 2. Re: Intel® Centrino® Wireless-N 1030 / Router poor performance
            JohnDoe1234

            Thanks for the info theveterens!

             

            I used the setting at: Wireless Networking — What are the recommended settings for 802.11n connectivity? the best I could.  If not, I set the option as close as allowed.

             

            On the router side, The Bandwidth option is "20MHz only" or "20MHZ+40MHz Auto".  there is no option for "40MHz Only"  unless this is a setting in the reg that I would have to update.  I don't know enough about the details of the router to begin down that route.

             

            I used inSSIDer and based on the Link Score tried every Channel and extension variation.  This is after the previous settings were changed on the wireless Intel® Centrino® Wireless-N 1030.  The best I could come up with was Channel 11+7 with a Link Score of 42-45.  802.11n Max Rate 300 Co-Channel: 6-7 networks Overlapping: 8 networks Signal: -47 to -49 dbm 

            I live in a small 8 apt apartment building with a few houses nearby.  so that may explain some of the networks, but there are a lot more based on what inSSIDer is saying.

             

            After all that, the max I can get is 117Mbps with slight flux down to 58-71Mbps.

             

            I really wish I could get better performance out of my setup.  I don't know that there is anything else to try.  I really appreciate your help and pointing me at the info you did.  It made some of this a bit clearer for what is going on at least.

             

            If there is anything else you could think of me trying, please let me know.

            • 3. Re: Intel® Centrino® Wireless-N 1030 / Router poor performance
              theveterans

              Hi there

               

              Since you are living in an apt (like I do), IMO, I don't recommend using 40 MHz channel since it eats up 2 adjacent channels, mainly (1+5, 6+10 and 11+7) and this will cause overlapping with other neighbors which results to the fluctuating speeds that you see on your Windows status connection. In overcrowded situations, I recommend to set your router to 20 MHz only so you won't have overlapping channels like I have on my setup right now, despite having 20 routers in range. This gives me 144 Mbps most of the time which is the maximum I can get at 20 MHz channel width. However, I tried using 40 MHz channel width and it made the speed fluctuate a lot resulting in flaky WiFi performance.

               

              I suggest to read this article as well: http://www.metageek.net/support/why-channels-1-6-and-11/

               

              Capture.JPG