13 Replies Latest reply on Jan 6, 2016 6:04 AM by Deeznuts

    COM Port Issues - PC Does Not Recognize Board

    Elwood

      My recently received Galileo board does not show up as a COM port, or even initialize driver installation when connected to a PC; I have tried several different computers, with both USB 2.0 and 3.0 ports, and they are all the same. I have started by connecting the power adapter, and then connecting the USB client connector to the PC, and nothing happens. The LED Power light is on, but that is the only active status indicator. Any troubleshooting advice would be appreciated; thanks.

        • 1. Re: COM Port Issues - PC Does Not Recognize Board
          Intel_Jesus

          Hi Elwood,

           

          What OS are you using? When the Galileo is plugged in for the first time it might apear as "Gadget Serial". Is this the case?

          See section 4 on the Getting Stated PDF.

           

          https://communities.intel.com/docs/DOC-22204

           

          Regards,

          Intel_JEspinoza

          • 2. Re: COM Port Issues - PC Does Not Recognize Board
            Elwood

            The OS is Windows 7 Pro, 64-bit, SP1. There is no change in devices when it is plugged in; the computer just simply doesn't see it.

            • 3. Re: COM Port Issues - PC Does Not Recognize Board
              Intel_Jesus

              Elwood,

               

              I sent you a email from the ticket you opened.

               

              Regards,

              Intel_JEspinoza

              • 4. Re: COM Port Issues - PC Does Not Recognize Board
                Bill2

                Elwood

                I had a similar problem. Connected to computer, no sound, no failure to connect, no "Gadget Serial" in the Device Manger. Try this (power up the Galileo), open the "Device Manager"  then plug in the Galileo USB to see if any device shows up. If it does then confirm by removing the Galileo USB to see if it goes away. Update the driver on that device to the Galileo driver. I had a USB driver that I had installed for a totally unrelated project that the Galileo board accepted without any normal connection alerts. That may not be your problem. It worked for me. I am definitely not an expert so please proceed with caution.. I may have been just lucky.

                • 5. Re: COM Port Issues - PC Does Not Recognize Board
                  micheleBac

                  I have the same problems with:

                  1. windows 8.1 64bit ( see attachment for more detail)Immagine.jpg

                  2. Intel Galileo

                   

                  I Power up the board, wait start-up and the I plug usb cable into "USB Client" connector.

                   

                  Nothing appears on Device Manager : no device appears ....

                   

                  What can I do?

                   

                  Thanks

                   

                  Michele

                  • 6. Re: COM Port Issues - PC Does Not Recognize Board
                    Intel_Jesus

                    Hi micheleBac,

                     

                    Can you access you Intel Galileo Board Linux console using a serial cable?

                    The serial cable can give us more insight if the board boots successfully. Take a look at Intel Galileo Boards Console Serial Cables for more information on the serial cables. Can you also provide a screenshot of your Device Manager, with the "Ports" and "Universal Serial Bus controllers" expanded.

                     

                    Regards,

                    Intel_Jesus

                    • 7. Re: COM Port Issues - PC Does Not Recognize Board
                      Nemanja

                      Hi,

                       

                      I am experiencing the same problem. I have ordered 3 boards, 2 are working but one is not detected from device manager. Driver etc is properly installed and working fine for other 2 devices.

                       

                      Can somebody help with this issue?

                       

                      Regards,

                       

                      Nemanja

                      • 8. Re: COM Port Issues - PC Does Not Recognize Board
                        Mauen

                        I am using one of the *very earliest* Gen I boards with Win 7 and a serial to USB converter. I electrically tested the leads on the converter to make sure the connections were good and not crossed. The green USB light is on. CDFI Installer ran. I try to update the drivers on "USB-SERIAL CHANNEL 340 (COM10)," recognized by Arduino 1.53.  The board is set to Intel Galileo Gen I board.  I even try the firmware flash using COM 10. It says Galileo not on COM port 10.  I can switch the USB/Serial to other USB ports with the same result. I also tried Arduino for Intel 1.6 on a different Win 7 computer with similar results. I have followed the instructions and cannot get it to recognize it as "Galileo."

                         

                        Any way to tell if there are problems with my serial coms or if this is just a bad board?

                         

                        Thank you kindly!

                        Mauen

                        • 9. Re: COM Port Issues - PC Does Not Recognize Board
                          Mauen

                          BEWARE OF MECHANICAL CONNECTIONS on USB cables

                           

                          I noticed that one of my USB cables would be come visible if I "tilted" it up within the CLIENT USB port, suggesting a sketchy connection. It had the warning sign and would not take any driver updates-even if I held the cable bent at an upward angle. I have tried other USB cables before, but I figured that maybe the connector had some tolerance problems and that I might solve the problem by trying tons of other cables.  This seemed to solve the issue. I then saw "Gadget Serial" in device manager and did the normal "update the drive, browse C:\arduino-1.5.3-Intel.1.0.4\hardware\arduino\x86\tools"

                           

                          Working through Arduino, it was easy to communicate to the board and test the sample "blink" program. Works great.

                           

                          An interesting aside, I should note that I was able to use Arduino 1.53 to update the firmware. When I tried to use the firmware updater 1.04. I clicked "browse for .cap file."  I found a file firmware.cap under .galileo. When I found which was some odd  number like 724 or some 700 series number which was updated to 1.XX series number.

                          • 10. Re: COM Port Issues - PC Does Not Recognize Board
                            leo1234

                            hi,mauen

                            I use Arduino 1.53 to update the firmware, but it failed. Now my board can not connect with computer and the usb led is not light.

                            what should I do to fix it??

                             

                            Regards,

                            leo1234

                            • 11. Re: COM Port Issues - PC Does Not Recognize Board
                              Mauen

                              Hi Leo,

                              I am not an expert, but I would try some simple things first. I am sorry if this is too basic, I apologize but I would rather cover more just in case something was overlooked. It is easy to do. 

                               

                              0. Test the power supply to make sure it is putting out a steady 5 volts. I have had non-Intel power supplies break before. You can get a multi-meter for measuring voltage, at Frys, Digikey, Radio Shack, Amazon. You can even build one at Sparkfun: https://www.sparkfun.com/datasheets/Kits/SFE03-0010-KitCard-Multimeter-ReadersSpreads.pdf 

                              A multi-meter will be on of your most used tools if you really get into this hobby.

                               

                              1. unplug it for a 30 seconds to a minute.

                              2. remove any SD cars or attached components, like wifi card, button cell battery, usb cable, projects, ect.

                              3. Plug in the power and wait 30 seconds to a minute. Is the power light on?

                              4.  With it powered on and not plugged into the computer, try the reset button on the board--Once it is plugged in and you have the power light, wait a minute or so to see if the USB comes on.

                              -I would try thiat least 3 or 4 times to make sure the behavior is the same. it is truly corrupted.

                               

                              Read up on the forums about diagnosing corruption. Search for the term "Bricked Galileo."  Interrupting the programming  whether through software, or hardware (physical connection, interrupted power) can corrupt the firmware on any device really. Some USBs are limited in current. Limited current can affect the voltage in some cases. This is why it is best not to run on USB power and have a good power supply.

                                                                         

                              If the USB light turns on, re-flashing the firmware will be a little easier.

                               

                              Cheers,

                              Mauen

                              • 12. Re: COM Port Issues - PC Does Not Recognize Board
                                Mauen

                                I should have said BEWARE of ELECTRO-MECHANICAL CONNECTIONS: Not all micro-USB cables are created equal. At this point I am not even sure which one came with the board, but I am certain that not just any mico-USB cable will will work.

                                • 13. Re: COM Port Issues - PC Does Not Recognize Board
                                  Deeznuts

                                  What if you cant update the drivers!!!!!!!!!!!!!!!!! This **** intel sold me doesnt work!!!!!!!!!!!!!!!!!! Im ****** i gave you money for this. Either there is an issue with Windows or Galileo. Either way your device is far to complicated. You sold me on some silly dream that i could plug this thing in and upload code. I havent even began to learn how to code because this chunk of garbage cant get recognized by Window!!!!!!!!!!!