1 Reply Latest reply on Jan 3, 2014 10:17 AM by joe_intel

    Pc is becoming slow.. plz help

    Injamul

      My Pc Config was

      Processor : Intel Core 2 Duo E7500 , 3.93 GHz

      RAM : 2GB 1333 Bus speed Twinmos

      Motherboard : Gigabyte G41MT-ES2L

      HDD : 1TB

      GPU was Internal intel Chipset

       

      then I Install 4GB RAM and Sapphire HD7730 ddr3.. So now my config is

      Processor : Intel Core 2 Duo E7500 , 3.93 GHz
      RAM : 2GB + 4GB 1333 bus Twinmos
      Motherboard : Gigabyte G41MT-ES2L
      HDD : 1 TB
      GPU : Sapphire HD7730 ddr3 2GB
      PSU : local 400 watt (Non Branded)

      I use Windows 7 64 bit 


      After Installation my RAM n GPU my Pc is becoming a bit slow.. All games are running very well in High graphics but PC is slow then usually it has to be.. so my question is it for my PSU or Motherboard or Processor.. What should I do now.. Plz Help..

       

        • 1. Re: Pc is becoming slow.. plz help
          joe_intel

          In this type of scenario it is usually necessary to take into consideration the power supply wattage and the consumption after the latest changes made to your system. The specifications of the graphics card suggest a minimum of 400 W from the power supply but this depends on the total amount of devices connected to your system.

           

          I would suggest removing one of the components at a time (graphics or RAM) and test for results. You could also test the components in a different system or upgrade your power supply unit if needed.

           

          There is also the chance of a compatibility issue since you are installing a new graphics adapter in an older system; updating the motherboard BIOS may help.