1 2 Previous Next 21 Replies Latest reply on Apr 25, 2014 1:43 AM by AlexT_Intel

    Enable USB Audio?

    cconnaker

      Hi Guys - I'd like to enable USB audio on the Galileo. Is there a way to do this with the Intel SD image?

        • 1. Re: Enable USB Audio?
          AlexT_Intel

          As far as I recall from one of Sergey's posts on that, the kernel isn't configured for USB audio in the image, so you'd need to reconfigure and rebuild it. You can look at his instructions for some insight, however the changes he describes there were not specifically related to USB audio, so it may be not that useful.

           

          Let's see if "@-mentions" work here :-)

           

          SergeyK - care to share some more specific instructions on enabling USB audio?

          • 2. Re: Enable USB Audio?
            cconnaker

            Hi Alex - I read Sergey's article and tried to glean what I could about USB Audio but as you said it just isn't specific enough in that area.

             

            I'd love to use the already small SD Image for the Galieo and just add USB Audio support, but I can't figure it out :~(

            • 3. Re: Enable USB Audio?
              AlexT_Intel

              I'll see if I can help you if Sergey doesn't reply here.

               

              After some investigation it looks like everything is almost there, including kernel config, so it may be easier that I initially thought.

               

              To make it clear - what exact USB audio device are you trying to enable? What do you get (if anything) in dmesg command output after plugging the device in?

              • 4. Re: Enable USB Audio?
                cconnaker

                Hi Alex - Any help you can provide is much appreciated. I'd like to get a number of USB DACs working. The Linux kernel has supported USB audio, specifically Class 2 USB audio for some time. If I could get the Galileo to have the same capability I'd be thrilled!

                • 5. Re: Enable USB Audio?
                  AlexT_Intel

                  Yeah, Galileo could be a nice audio player, thanks to USB DACs.

                   

                  Have you tried just plugging it in and playing something? I guess you did and it didn't wok. What have you observed in the dmesg command output after connecting the DAC (that could show a helpful information for enabling)?

                  • 6. Re: Enable USB Audio?
                    cconnaker

                    Hi Alex - I'll check dmesg this AM. When I connect a DAC and run the aplay -L command it says no audio devices found.

                     

                    I'll get back to you in a bit. Thanks for the help.

                    • 7. Re: Enable USB Audio?
                      cconnaker

                      Hi Alex - I posted the dmesg results but it's awaiting moderation before publication for some reason. Here is some other info.

                       

                       

                       

                      Before booting from SD card begins receive these messages when USB DAC is connected:

                       

                      UsbCreateDesc: met mal-format descriptor

                      UsbParseInterfaceDesc: failed to create endpoint(index 0)

                      UsbParseConfigDesc: failed to parse interface setting

                      UsbBuildDescTable: failed to parse configure (index 0)

                      UsbEnumerateNewDev: failed to build descriptor table - Device Error

                       

                      EDIT: I see this has been identified already and the note says, "Functionality is not impacted, error messages can be ignored."

                       

                       

                       

                       

                      Connecting USB DAC receive this message:

                      [   90.130341] usb 1-1: new full-speed USB device number 3 using ohci_hcd

                       

                       

                       

                       

                      Using Alsa-utils:

                       

                       

                      root@clanton:~# aplay -L

                      null

                          Discard all samples (playback) or generate zero samples (capture)

                       

                      root@clanton:~# aplay -l

                      aplay: device_list:256: no soundcards found...

                       

                      root@clanton:~# alsactl init

                      alsactl: init:1758: No soundcards found...

                      • 8. Re: Enable USB Audio?
                        AlexT_Intel

                        Thanks, that should be helpful. And what do you see when you connect it to Linux where it works (or what's the DAC model you're using) - to see what driver is needed?

                         

                        I haven't done anything like that yet, so it's somewhat new for me too, but that's a cool opportunity to learn that, so I'm really willing to dig into this and help you as much as I can :-)

                         

                        I've checked the kernel config, which is used for building the "image-full" image and it seems like all but one option needed are already enabled, so I'm trying to understand if that's only that, or e.g. we also need some additional kernel modules and the DAC model or information form the working system would help me to understand that.

                        • 9. Re: Enable USB Audio?
                          cconnaker

                          Hi Alex - I'm using an AudioQuest DragonFly USB DAC. When I connect it to a Debian machine I receive the following message. Debian doesn't require any special drivers from the DAC manufacturer for this DAC. Debian supports both Class 1 and Class 2 USB audio devices wonderfully.

                           

                          Debian dmesg:

                          [1741591.536118] usb 2-1.1: new full-speed USB device number 6 using ehci_hcd

                          [1741591.972471] usb 2-1.1: New USB device found, idVendor=21b4, idProduct=0081

                          [1741591.972481] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3

                          [1741591.972488] usb 2-1.1: Product: AudioQuest DragonFly

                          [1741591.972493] usb 2-1.1: Manufacturer: AudioQuest inc.

                          [1741591.972497] usb 2-1.1: SerialNumber: (C) 2013 Wavelength Audio, ltd.

                           

                           

                          On Debian here is what I see when running some Alsa commands.

                           

                          root@Mypc:~# aplay -l

                          **** List of PLAYBACK Hardware Devices ****

                          card 1: DragonFly [AudioQuest DragonFly], device 0: USB Audio [USB Audio]

                            Subdevices: 1/1

                            Subdevice #0: subdevice #0

                          root@Mypc:~# aplay -L

                          null

                              Discard all samples (playback) or generate zero samples (capture)

                          default:CARD=DragonFly

                              AudioQuest DragonFly, USB Audio

                              Default Audio Device

                          sysdefault:CARD=DragonFly

                              AudioQuest DragonFly, USB Audio

                              Default Audio Device

                          front:CARD=DragonFly,DEV=0

                              AudioQuest DragonFly, USB Audio

                              Front speakers

                          surround40:CARD=DragonFly,DEV=0

                              AudioQuest DragonFly, USB Audio

                              4.0 Surround output to Front and Rear speakers

                          surround41:CARD=DragonFly,DEV=0

                              AudioQuest DragonFly, USB Audio

                              4.1 Surround output to Front, Rear and Subwoofer speakers

                          surround50:CARD=DragonFly,DEV=0

                              AudioQuest DragonFly, USB Audio

                              5.0 Surround output to Front, Center and Rear speakers

                          surround51:CARD=DragonFly,DEV=0

                              AudioQuest DragonFly, USB Audio

                              5.1 Surround output to Front, Center, Rear and Subwoofer speakers

                          surround71:CARD=DragonFly,DEV=0

                              AudioQuest DragonFly, USB Audio

                              7.1 Surround output to Front, Center, Side, Rear and Woofer speakers

                          iec958:CARD=DragonFly,DEV=0

                              AudioQuest DragonFly, USB Audio

                              IEC958 (S/PDIF) Digital Audio Output

                          • 10. Re: Enable USB Audio?
                            AlexT_Intel

                            Thanks, that's good enough for me so far, now on to research! :-)

                            • 11. Re: Enable USB Audio?
                              cconnaker

                              Hi Alex - I installed Sergey's version with USB audio support and it works fairly well. Now If we can just figure out what the USB audio portions is and figure out how to add it to the Intel SD Image all will be well :~)

                              • 12. Re: Enable USB Audio?
                                AlexT_Intel

                                Indeed - I just realized Sergey has attached a kernel config to his blog post (thanks Sergey!), and I think I've already extracted the relevant part. I'll think on how to pack that nicely to make easier to use and report back soon.

                                 

                                As far as I understand, you're building the image by yourself, right? Are you using the 0.7.5 or 0.8.0 BSP version?

                                • 13. Re: Enable USB Audio?
                                  cconnaker

                                  I'm using 0.7.5 downloaded from Intel. Then building it per Sergey's instructions.

                                  1 2 Previous Next