11 Replies Latest reply on Jul 21, 2009 10:27 AM by Syolaar

    Unknown device following bios update

    Syolaar

      I recently updated my d101ggc's BIOS and I started getting an "unknown device" popup when I start the computer. I haven't added any new hardware so I assume it's something built in but I can't figure out what. I have tried Unkown device identifier with no luck. I also activated the bootrom on the onboard RTL8101L, could that be what windows is detecting? Any help is appreciated, I can supply any necessary info on request.

        • 1. Re: Unknown device following bios update
          unplugged_24

          Hi there,

           

          Can you check in device manager which component is listed as unknown device.

           

          Try re-installing the drivers. Remember to start with the chipset (INF) drivers first then audio then the rest. Make sure you install the all the reqiored drivers.

          Link: http://downloadcenter.intel.com/Product_Filter.aspx?ProductID=2229

           

          Hope this will be useful.

           

          Cheers.

          • 2. Re: Unknown device following bios update
            Syolaar

            The device tree lists it as Other Devices>Unknown Device. After my bios update I also updated my chipset drivers, onboard video drivers (and PCIe video drivers were checked as they are both ATIs), audio drivers & codecs, everything else is still working as it was before using the default Vista drivers I think. I got updated drivers from the manufacturer's websites that were designed for Vista as all the ones here are all for XP. The only one I don't think I updated is the onboard NIC, which happens to be the one I modified in the bios (bootrom turned on), although I updated it to a Vista driver not too long before. I will try reinstalling that one and post result.

            • 3. Re: Unknown device following bios update
              Syolaar

              After the NIC driver update it still lists the device as unknown. All the devices I was aware of are listed and functionnal. Whatever this unknown device is I have never used it, or even been aware of it's existence (for almost 4 years now). 

              • 4. Re: Unknown device following bios update
                Aryan2411

                Hi there,

                 

                Try to update your windows online.

                 

                If this is not fixed, put the screenshot of the unknown device and the hardware id fo the device from the device manager. We will assist you further.

                 

                All the best,

                 

                Regards,

                Aryan

                • 5. Re: Unknown device following bios update
                  Syolaar

                  I have windows set to autoupdate and I have installed SP2. I ran a manual update and found nothing new, in either the software or drivers.

                  Device treePropertiesDetail tab
                  Device Tree.png Properties.pngDetail drop.png

                   

                  I could not find the hardware ID so I included the detail dropdown incase it's named differently. The closest I could find is "Physical Device Object name", it's value is "\device\00000020".

                  • 6. Re: Unknown device following bios update
                    Aryan2411

                    Hi there,

                     

                    This is a bit weird. Well, last thing to try from my side:

                     

                    CMOS clear for 10 minutes.

                    Reflash the board bios using the Recovery Method if possible.

                    Load Bios to Default F9 and F10

                    Install all the latest drivers from the website only

                    Try this driver for the LAN

                    http://downloadcenter.intel.com/detail_desc.aspx?agr=Y&DwnldID=12197

                    Update the windows again thru automatic mode.

                     

                    Btw, which version of OS do you have? Type Winver in RUN

                     

                    All the best,

                     

                    Regards,

                    Aryan

                    • 7. Re: Unknown device following bios update
                      Syolaar

                      I wasn't able to reflash the BIOS again as I don't have a floppy drive atm (I originally used an old blank HDD as a massive floppy to do this, which I no longer have) and my USB keys won't boot for some reason (MBR error). As for the driver, it wouldn't install because the NIC is made by Realtek (RTL8101L) not Intel. I do have a spare 3.5'' floppy drive from a PC I recently salvaged, but I don't have a 3.5'' diskette and can't find one in stores either... I'll try and find one to redo the BIOS but I wouldn't bank on it.

                      • 8. Re: Unknown device following bios update
                        Aryan2411

                        Hi there,

                         

                        Bios Recovery does not need to be a bootable usb/floppy/cd media.

                         

                        Try a bios recovery using a FAT formatted USB media.

                         

                        Instructions for Recovery BIOS Updates
                        In the unlikely event that a BIOS update is interrupted, it is possible the BIOS may be left in an unusable state. The recovery process requires the chassis to be opened to move the onboard BIOS Configuration Jumper.

                         

                        Recovery with Formatted USB Stick

                        1. Copy the recovery file (*.bio) to a formatted usb disk. (xxx.bio file)
                        2. Place the usb disk in the target system.
                        3. Shut down the system and unplug AC power.
                        4. Open the chassis and remove the BIOS Configuration Jumper. See the Technical Product Specification for details including the location of this jumper.
                        5. Power the system on.
                        6. Wait 2-5 minutes for the update to complete. When the usb drive LED is lit, the system is copying the recovery code into the FLASH device.
                        7. System will either turn off when the recovery process is completed or it will prompt you to turn off the system.
                        8. Remove usb disk
                        9. Replace the BIOS Configuration Jumper.
                        10. Restart system.

                         

                        Note: these can be found on:
                        Website: http://downloadmirror.intel.com/17197/eng/BIOS%20Update%20Readme.pdf
                        Page 3

                         

                        For the drivers, i have no clue for this.

                         

                        All the best,

                         

                        Regards,

                        Aryan

                        • 9. Re: Unknown device following bios update
                          Syolaar

                          I have .bin files (Award BIOS) not .bio... will it work with those?

                           

                          P.S. Appologies for the delayed response.

                          • 10. Re: Unknown device following bios update
                            tech24

                            hello,

                             

                            The BIOS update might have enabled the IR in BIOS.

                             

                            Try disabling the IR by pressing F2 upon boot up

                             

                             

                             

                            Go to Advance> Peripheral configuration> Enhanced consumer IR and select "Disable"

                             

                            Hope this helps

                             

                             

                            BIOS update instructions:  http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&Inst=Yes&ProductID=2229&DwnldID=11738&strOSs=38&OSFullName=OS%20Independent&lang=eng

                            • 11. Re: Unknown device following bios update
                              Syolaar

                              No such options exist in this BIOS. It's what I'd call a "barebones" BIOS with basic options only... The new update actually added memory timing options (which I left on automatic) but nothing else. Everything that has an option in the BIOS seems to be working perfectly (haven't used PXE boot, but it does try to connect when I tested). Could this unknown device be a side effect of flashing from my HDD in dos? I am now able to boot from USB thanks to flashboot.

                               

                              I am preparing to migrate to a 64bit Vista and a test install didn't seem to get the "Unknown device" popup. I didn't take the time to check the device manager, but I hope this new installation will solve the issue. I thought of repairing my current Vista, unfortunately my 32bit disk has suffered corruption of sorts and won't load anymore. I will report back after the migration in a few days time. Until then I'm still open for possible solutions. Thanks.