1 2 Previous Next 15 Replies Latest reply on Nov 21, 2014 7:47 AM by sylvia_intel

    D34010WYK USB 3.0 controller broken?

    senel

      Hi,

       

      today I recieved my second NUC and I have same problem with two back USB port - they dont work. I had same problem problem with my first NUC (D43010WYK too), so returned it and they gave me new unit. I cant get anything to work - flash drive, printer, Bluetooth dongle. Front USBs forks fine (all on W8.1 x64 with correct drivers).

       

      So I guess this unit goes back too.

        • 1. Re: D34010WYK USB 3.0 controller broken?
          sylvia_intel

          Senel, since you already replaced the NUC, it has to be something else that is causing this behavior.

           

          So, what we recommend customer to do is to check if you are running the latest BIOS available for the product.

          Since we only support Windows flavors, here is the USB 3.0 driver that may need to be installed on the NUC   Download Center    

          • 2. Re: D34010WYK USB 3.0 controller broken?
            senel

            First time, I had same thoughts like: after I install all drivers, it will be fine...

             

            But first hint was that both keyboard and flash drive werent detected, so I plugged then to front ports and it was fine.

             

            Then I checked BIOS:

            • + updated it to latest version
            • + restored defaults
            • + checked if all USB were enabled.

             

            Then I installed W 8.1 x64 + all drivers from the bundle and USB stil didnt work so I replaced unit (SSD and RAM too). Process with second unit was same with only only difference - it run latest BIOS from the box.

             

            I guess this has to be HW malfunction because both units were in sealed package and all devices I tried werent work in back ports (different flash drivers, dongle from keyboard, BT dongle, printer...).

            • 3. Re: D34010WYK USB 3.0 controller broken?
              sylvia_intel

              Please  check the information given on the following threads. It might help you 

              https://communities.intel.com/message/214591#214591 

              https://communities.intel.com/message/213356#213356

               

               

              Please let me know if it work for you.

              • 4. Re: D34010WYK USB 3.0 controller broken?
                faiello

                Any news? I have the same problem, the usb ports on the back do not work at all.

                • 5. Re: D34010WYK USB 3.0 controller broken?
                  senel

                  Only solution is to replace unit or send it back to repair under warranty.

                   

                  Currently, I am still waiting for my third i3 unit. The first two unit had same problem (broken USB controller), one of them had functionless HDMI port.

                   

                   

                  My personal thought is, that I had bad luck for defective products or generally NUC is s***y product.

                  • 6. Re: D34010WYK USB 3.0 controller broken?
                    ChrisHawk

                    Ok, so today I got the exact same problem; only the two USB ports in the front are powered, this was the case both pre- and post BIOS upgrade.

                     

                    Yesterday when I received the unit, this worked fine. Is this a BIOS power management issue, or an outright hardware fault?

                     

                    Senel- did you get the third unit to work?  I will be looking to replace mine, but if you've had three NUC crashes in a row, I'll need to re-evaluate my options.

                     

                    Regards,

                    CH

                    • 7. Re: D34010WYK USB 3.0 controller broken?
                      crhendo

                      I have been playing around with USB3 on this NUC for a while now and the one thing that I have discovered is that if I disconnect my devices from ALL the USB3 ports and then let Win 8.1 64bit boot, I can then plug all the devices in when Windows is loaded and they all work fine.

                       

                      I have also found that I cannot do a BIOS Recovery from the front ports, only the back ports.

                       

                      I know this doesn't help but it does point to a booting problem of some kind.

                      • 8. Re: D34010WYK USB 3.0 controller broken?
                        kari-s

                        I have the same problem. I just got my d34010wyk and both of its back USB ports are dead. I have not seen any sign of life there. I have probably tried all possible settings in BIOS. Windows 8.1. installed fine and there are no malfunctioning devices in device manager.

                         

                        Is there anything else that I could do?

                        • 9. Re: D34010WYK USB 3.0 controller broken?
                          sylvia_intel

                          Hi all,

                           

                          The USB 3.0 drive I used to reproduce this is on its way to our BIOS engineers for debugging and fix-finding. As soon as I have a test BIOS available, I'll update this thread.

                           

                          Regards,

                          • 10. Re: D34010WYK USB 3.0 controller broken?
                            senel

                            ChrisHawk - Not yet. Tomorrow, I should get repaired/new unit. I will test it and report back.

                             

                            silvia_intel - Thank you for info. I had chance to see internal communication between my local reseller and Intel. Generally, Intel somebody from Intel know about it and its really HW issue ("fried" USB controller). Allegedly, there is several batches of NUCs with this problem (+ some of them are having issues with HDMI not working) on market. My seller was advised to replace NUCs piece by piece if somebody bring it with this problem.

                             

                            EDIT:

                             

                            So, yesterday I received new unit (same as all before, with i3 CPU) and USBs "working". The quotation marks are there on purpose because every time I occupy both back ports, I get error that USB controller hasn`t enough resources on W8.1 and YES, I updated all drivers and BIOS to latest versions.

                             

                            One of the devices is USB BT 3 dongle (to connect kb and mouse) and on second device, it doesn`t really matter. Even if I connect printer which is TURNED OF , I get same error. Same with USB External HDD (with external power source), USB kb etc.

                             

                            I tried all possible combinations (printer + HDD, printer + mouse, mouse + kb...) and still same. With one device connected, I am not receiving any errors. Front USBs works fine, even with two connected devices.

                             

                            With this experience, I can say that NUC is sh*tty product, I'm really disappointed and honestly, I don`t have time and mood to send it back and wait another month for another broken device...

                            • 11. Re: D34010WYK USB 3.0 controller broken?
                              sylvia_intel

                              The following link includes the latest version of the USB 3.0 driver.


                              https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=21129

                               

                              https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=22824


                              Could you please install it and let me know the results?

                              • 12. Re: D34010WYK USB 3.0 controller broken?
                                AndiLoor

                                Hi, I have the same problem with two ports on the back not working. How can i know wich one of the drivers above to use? It uses Intel i3-4010U CPUs 1.7GHz

                                • 13. Re: D34010WYK USB 3.0 controller broken?
                                  sylvia_intel

                                  AndiLoor, if you are using the D34010WYK NUC, please  try this one https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=21129

                                  • 14. Re: D34010WYK USB 3.0 controller broken?
                                    TechieTony

                                    Hi, I have the same issue on my DC3217IYE system where the rear usb ports are inconsistent. Sometime it will work and sometimes it wont detect anything plugged in. I think I found a solution to the issue by removing my Wifi Card from pci-e slot on the system. Removing it seems to fix the issue and all my usb ports work perfectly. I just purchase a new Wifi Card and waiting for it to come to see if it was actually the card causing it or the pci-e slot on the system. My theory is that the Wifi Card maybe using to much power and cause insufficient power to the rear usb ports. The Wifi card I was using was the Intel Centrino® Advanced-N 6235. I am going to replace it with the newer Intel 7260 wifi card which uses less power and see if that resolve the issue.

                                     

                                    EDIT:

                                     

                                    So I installed my new WiFi card and now all the USB ports are working. I'm not sure why my old WiFi card was interfering with my USB ports but replacing it solved my issue. I will continue testing this system.

                                    1 of 1 people found this helpful
                                    1 2 Previous Next