11 Replies Latest reply on Dec 11, 2013 2:22 PM by robertjal

    Serious UEFI issue with DZ87KLT-75K

    robertjal

      Hi,

       

      I recently bought a DZ87KLT-75K. given my previous experience with with the DZ77HB-55K I should have know better than to buy this board. None the less i did and now I'm stuck with Visual bios problems again.

       

      seems that UEFI is broken with this board. It can see UEFI devices in the bios (F2) but cannot boot from them. it worked for 1 day then started to fail for no reason. I also tried using the boot menu (F10) the sdd is not listed there. I switched the disk to another board and there it boots with UEFI without issues. I also tried booting the win7 and win8 dvd roms in UEFI mode but could not. the boot menu does show UEFI network boot options.

      I tried flashing al versions available on the website, none of them work. Load defaults several times. even flashed the bioses through recovery mode. No improvement. Remove cmos batter and wait 15 mins no result.

      weird thing is that the UEFI devices are listed twice in the UEFI menu in the bios config (F2).  In the boot menu UEFI network boot options only become available if legacy boot is turned off.

       

      there is something screwed up in the settings but there is no way to reset the bios to factory defaults. none of the things i tried does this. If I change the color settings for visual bios, do a load defaults, save,  remove the cmos battery but the scheme stays the same. There is simply no way to wipe the settings clean. some things remain present even after these steps.

       

      the old visual bios had the option to go back to the real configuration screens, think it was called classic bios. That option is gone. how do i get it back ? i need access to the bios core so to speak not the confusing and buggy shell that has been build around it.

        • 1. Re: Serious UEFI issue with DZ87KLT-75K
          sylvia_intel

          Hello Robertjal, would you please provide me the AA# and the Serial number of the motherboard in order to compare it with the one we are using?

           

          I recommend you to get in touch with our Warranty Department so they can help you to replace the unit: http://www.intel.com/p/en_US/support/contactsupport

          • 2. Re: Serious UEFI issue with DZ87KLT-75K
            robertjal

            Hi Silvia,

             

            S/N  

            AA#    G74721-304

             

             

            i also noticed other issues which i did not want to mention at first but:

            there is no way to select a memory profile. Only the slider in the memory tab but it only shows a bus speed. i cannot configure timing params anywhere. I also cannot select and see the jedec/xmp profiles.

            more important, my memories jedec/spd default is 1333mhz, the slider is at that this speed when i load defaults but the moment i touch it, it goes to 1600 and will not go back to 1333. nothing that I do besides loading defaults again will set it back to 1333.

             

            The default settings are also unsafe from the start. unlock extreme voltages is checked when default settings are loaded. the GPU voltage offset was also set to +0.2 or so for a while when loading defaults. What changed is unclear to me but it now shows there is no GP offset. guess the many flashes and attempts at resetting things did fix something somewhere.

             

            if legacy boot is disabled, you cannot get the setup to display on the display port output. It simply does not show anything. I legacy is enabled it does show a message that it's entering setup but hangs at this screen and never actually enters. Apparently it is waiting for a hdmi monitor since plugging in seems will solve the issue and show the bios screen on both monitors. I'm using a 30" screen (2560x1600) on the display port output b.t.w.

             

            I can and will ship off the board to warranty but I am a little annoyed that I have to constantly ship boards back to Intel. Besides the last two boards I have always favored Intel boards over other brands but somehow it seems impossible for Intel to make a board that just works out of the box. given that I find these issues within a very short period of time I'm guessing no testing and debugging is done anymore.

             

            FYI: this board is still C1 and has a manuf date of 29 aug 2013.

             

            my setup:

             

            RAM:  Kingston Beast 32GB DDR3-2400MHz KHX24C11T3K4/32X

            CPU: 4770K

            SSD: intel 520 240GB

            • 3. Re: Serious UEFI issue with DZ87KLT-75K
              robertjal

              issues that I have with this board right now:

               

              1. when legacy boot is disabled it is not possible to use the optical drive in windows. You also cannot boot a UEFI install from it.

              edit: needs more investigation. it seems booting is possible sometimes but I am not yet sure what triggers it. it not showing up in windows could also be a windows problem but all solutions I've found and tried so far have been unsuccessful.

              Fixed the problem. still  not sure if this is an issue with windows or UEFI. I'm guessing something in the overlap/gap between them. Turns out that if I enable sata hot plugging for the port the drive shows up in windows and I can also read data off the disk. the booting from the optical disk is still a bit buggy but it works if only the iGP is enabled. If the PEG is used I have no video (sapphire forums claim I have UEFI GOP card [ref design R9 290]) but I'm suspecting something is not right there which is at the root of this issue.

               

              2. in UEFI boot mode no [iGP] display port is available, there do not seem to be DP drivers or so in UEFI. Not sure if the iGP has support for DP in EUFI mode. Is this by design ?

               

              3. sata boot drives get populated with UEFI capable drives but you cannot boot from from those. I currently have 3 entries in the list for only 1 ssd, it seems that as you move the drive from sata port to sata port the old, now defunct entry stays and a new one appears, there is no way to purge that list

              edit: I found a way to clean the variables. Use bcdedit in windows to edit the nvram variables:  Remove Duplicate Firmware Objects in BCD and NVRAM

              sometimes the boot order is changed for (to me) no good reason, this is quite annoying since I have no boot screen in start up and when this happens I need to open the pc, remove the PEG, reboot with iGP fix it, reboot, shutdown, put everything back and power up again (while hoping it does not 'fix' the boot order on it's own again).

               

              4. when a DP to dual-link (active) convertor is connected to the thunderbolt/DP port, the computer shutdowns randomly. (This is also a problem with ivybrige but there the display (driver) only crashes and the screens goes blank no shutdowns.) this effectively makes this the second cpu from which I cannot use the integrated graphics. Once again I have to use external graphics.

              edit:

              it seems this also happens when the hdmi output is used and with a lower resolution (1920x1080) however the shutdowns are further apart.

              I'm thinking there is some incompatibility with my monitor ? It's a HP LP3065, was quite a good and expensive monitor when I bought it. Never had issues with any ext GPU or laptops etc. only the iGP of ivybrige and haswell have this problem....

              I had a similar unexplained shutdown today using PEG. So may not be caused by the converter after all. Still under investigation.

              20131204: no unexplained crashes for days with PEG, things are looking good.

               

               

              5. no option to go into the classic (AMI_TSE) bios, not really a bug but surely a big nuisance.

               

              6. RAM timing cannot be configured, only a slider available that allows you to set every possible speed this board supports irrespective of the actual capabilities reported by the dimms.

               

              7. memory speed slider cannot be set to default (jedec) speeds. Slider's left most value is 1333, when moved to the right then back to the left the lowest speed is now 1600

              7. memory speed slider cannot be set to lowest available speed. if the slider is set to the left the speed should be 1333. It's on that speed after loading defaults. when the slider is moved to the right and then back to the left most position that position now corresponds to 1600. The only way to get 1333 back is to load bios defaults and then not touch the slider.

               

              8. extreme voltages are enabled by default. also if this setting is changed manually to not allow extreme voltages and then the memory slider is touched, this setting is enabled again. Although the latter is not really a bug ( I assume it's b design) this is an unsafe action. At the very least a waring should be given that the extreme voltages will now be unlocked or even better the slider should not allow speeds that need extreme voltages and instead give a message that to get higher speeds the user should first enable extreme voltages.

               

              9. cpu (thermal) protection (throttling) is disabled after loading bios defaults.

              9. 'Processor VR faults' is disabled after loading default settings. So no over current protection is the standard settings. This is not safe !

              9. checked it again, extreme voltages are enabled (unsafe) but this setting is safe when it's enabled not disabled.

               

              10. secondary sata controller when disabled in the bios still shows up in windows but devices connected to it do not.

               

              11. dimm's embedded (JEDEC/XMP) profiles are not selectable

              hidden deep inside the performance tab....

               

              12. full dimm timings cannot be set manually

              hidden deep inside the performance tab....

               

               

              13. when UEFi is enabled and external graphics is used you cannot enter into the bios screen. (also not the efi shell)

              edit: ok, so this is not a problem with the mainboard. The graphics card I'm using does not have a GOP vbios, only a legacy bios. I recently bought a R9 290 and it to seems to not have a GOP vbios. Mind boggling that this is not standard yet, it's a brand new design...

              sapphire forum user claims the card does have a GOP vbios. Unsure at the moment. Needs further investigation.

              20131204: so the card did not have a GOP capable vbios flashed in it. I got one, flashed it and now things work. However I had the bios config screen hang on me twice in one hour when I use the external card.

               

               

               

              Robert

               

              Message was edited by: robert jal renamed bug list to issue list. added updates to the issue list

              • 4. Re: Serious UEFI issue with DZ87KLT-75K
                spearson

                Robert,

                 

                Regarding Item 5, the support for classic BIOS Setup was removed because it is redundant; all BIOS Setup parameters can be accessed from within Visual BIOS (read on).

                 

                Regarding Items 6, 11 and 12, you can do this from within Visual BIOS. Some people haven't noticed that, within the Performance Dashboard display, there are links (Host Clock, Ring, Cores, Memory, etc.) that enable scenes for extended/manual settings. In your case, click on the Memory link and a tabbed display will appear that will allows you to select from XMP profiles and/or set the memory timings (etc.) manually.

                 

                Regarding Item 2, there are DP drivers in UEFI. I enabled UEFI boot and disabled Legacy boot. I then powered up with my monitor connected to the Thunderbolt/DP connector. The monitor is working just fine. Your issue may have something to do with the converter you mention in Item 4.

                 

                I have also requested that the internal team review Items 3, 4, 7 and 8...

                 

                ...Scott

                1 of 1 people found this helpful
                • 5. Re: Serious UEFI issue with DZ87KLT-75K
                  robertjal

                  Hi Scott,

                   

                  thanks for checking.

                  regarding items 6, 11  and 12  I'll try it out later. it's really hidden well I guess . That screen is the most confusing to me. I kind of know something about electronics being an electrical engineer but that screen makes my head hurt. I have no idea what all the lines mean and how the multiplier connects to the voltage. ( sure the higher voltage enables a higher clock thus a bigger multiplier but it's not visualized at all this way.)

                   

                  item 5: I'm sure it's redundant but some people (like me) like the old classic view. The visual bios is confusing to me. I do not need the memory clock to stare me in the face with 1 inch big numbers. I can see it perfectly fine with the font set at normal sizes

                  i now need to click through maybe 20 screens/tabs to cover all items where I used to be able to do it with 7 or 8 in classic mode.

                   

                   

                  item 2:  I'll try to find a DP monitor to test.

                   

                   

                  Robert

                  • 6. Re: Serious UEFI issue with DZ87KLT-75K
                    robertjal

                    ok, found the memory timing settings. However if you had not pointed me to them i would have never found. Please to support all your customers also re-enable the text mode. I know it's there it's part of the standard bios...

                    • 7. Re: Serious UEFI issue with DZ87KLT-75K
                      spearson

                      Robert,

                       

                      I am sorry to have to say, don't get your hopes up. Text-Mode BIOS Setup is NOT an integral part of the standard BIOS that can just be "switched back on"; it is a feature, like so many others, and there is a cost to implementing and maintaining each and every feature. In this case, the costs were weighted and the decision was made to remove this feature. It is unlikely that this decision will be reversed. Weigh this against the effort to fix the other bugs that you've reported here...

                       

                      Sorry,

                      ...Scott

                      • 8. Re: Serious UEFI issue with DZ87KLT-75K
                        robertjal

                        well ok but would it be possible to improve the layout ? right now a lot of screen space is basically unused. I guess you could call it eye-candy, I don't really like that look but maybe others do.

                        Anyway, the performance tab is just not intuitive i think. i know hat pll's are and what a pll structure looks like and in this overview these are mixed up the the VRM controls and even the timing parameters of the dram.

                        Nope, to me this does not make sense. i can imagine that you would like to visualize things a bit given that you have a graphical interface at hand. In that case just draw a normal pll structure diagram. make another one for the VRM's and put the dram timing in a separate tab...

                        • 9. Re: Serious UEFI issue with DZ87KLT-75K
                          robertjal

                          Only a few issues remain:

                           

                          1. unlock extreme voltages is enabled by default or if you touch the memory speed slider on the main page

                          2. in UEFI (only) mode the boot order list is populated with both UEFI capable devices and remnants of the legacy boot list. The way to clear this is to load defaults, shutdown, disconnect all devices, start up into bios setup, disable legacy mode, shutdown, reconnect devices, powerup into setup again, configure uefi boot order that you are then good to go.

                           

                          3. the secondary sata controller shows up in windows when it has been disabled in the bios.

                           

                          4. problem with on-board graphics and active DP to DVI convertor (also see point 4 above)

                           

                          5. not sure if you can classify this as a bug but if sata hot pug is disabled on a port and an optical drive is connected to it the drive does not show up in windows. It's undetectable, as if there is nothing connected to the port. Booting does seem to work....

                          • 10. Re: Serious UEFI issue with DZ87KLT-75K
                            robertjal

                            suggestion to Intel team:

                             

                            it seems to me that Intel boards Z77 and Z87 are all sensitive to graphics cards that do not have a UEFI GOP capable vbios. There seem to be many posts with people disabling legacy and then having a lockup of some sort. I know my Z77BH-55K had these issues as well. I even had to send back the board once. With the DZ87KLT-75K i had severe boot and graphics issues as well when enabling UEFI mode which became much better when I got a GOP bios for my videocard.

                            Seems to me that it's a good thing to mention in the manual that GOP is a requirement when UEFI is enabled. Other manufacturers have a CSM module which can be turned off as with these boards but if the board detects a non GOP bios it reboots with the CSM re-enabled in someway.

                            Let people know GOP is essential, maybe even build that into the bios. If a user enables UEFI and disables legacy, test if the PEG has GOP capabilities and generate a warning.

                            • 11. Re: Serious UEFI issue with DZ87KLT-75K
                              robertjal

                              simpler solution to item 2

                               

                              Bcdedit /set {fwbootmgr} displayorder {bootmgr} /addfirst

                               

                              it will clear the list of any duplicate bootmanager entries it seems.

                               

                              Check this link for more info

                              BCD System Store Settings for UEFI