1 2 3 Previous Next 268 Replies Latest reply on Nov 10, 2015 7:41 AM by mikec_intel

    D54250WYK 'headless' issue?

    oviano

      So I just recently received one of these new machines.

       

      Overall I'm impressed but one thing I've noticed is that when no connected display is active - for example if the display port goes into a HDMI switch box which is switched to a different input - I cannot log into the NUC via VNC. Or more precisely, I can but I get a black screen. As soon as switch the display on/make the NUC the active input to the HDMI switch then VNC works fine. I'm using TightVNC on the NUC and I my client is Remotix, which I've tried from both iOS and OS X.

       

      This is inferior to the first gen NUC where even if there was nothing active on the HDMI port you could still log in using VNC and the display would be labelled as 'Generic PnP Monitor'.

       

      Is there anything I can do in software by way of configuration that could make the new NUC behave like the old one in this respect?

       

      Or have I got to now faff about with EDID emulators and use the mini HDMI port instead of the mini DP?

        • 1. Re: D54250WYK 'headless' issue?
          Diego_Intel

          Have you tested with Microsoft* Windows* 8 or Microsoft* Windows* 7? Keep in mind that these are the only operating system that are officially listed as tested and validated for this product as per this article:

          Intel(R) NUC | Supported operating systems

          Is the system using the latest BIOS available too?

          Have you tested any other remote software application?

          • 2. Re: D54250WYK 'headless' issue?
            oviano

            I'm using Windows 8.1. Latest BIOS and all latest drivers installed.

             

            I've not tested any other remote software, no, only TightVNC as the server and Remotix as the client.

             

            I've worked around the problem by using a Dr HDMI (EDID emulator) and used the Mini HDMI port. Not ideal, but solves the problem.

             

            Was this NUC tested as a headless PC with any VNC type software?

            • 3. Re: D54250WYK 'headless' issue?
              Diego_Intel

              The only software that has been tested on these units is the one that is listed there:

              Intel(R) NUC Boards and Kits | Software compatibility

              As a matter of fact no similar software is listed.

              In fact the issue could be caused by no EDID being detected, as you may know, the video drivers in these systems rely on the EDID to work with the display connected.

              • 4. Re: D54250WYK 'headless' issue?
                oviano

                Yeah it's definitely being caused by no EDID being detected.

                 

                I've just installed the previous generation NUC with exactly the same setup (Windows 8.1, TightVNC) and confirmed that in this situation (nothing connected) it works fine, i.e. you can use VNC and the monitor listed is "Display Device on VGA", and it lets you choose the usual resolutions.

                • 5. Re: D54250WYK 'headless' issue?
                  Diego_Intel

                  Let me forward this for further research and get back to you.

                  • 6. Re: D54250WYK 'headless' issue?
                    oviano

                    Thanks Diego.

                     

                    As I say, it's not a huge issue for me personally as I have a workaround, but maybe others will come across the same issue.

                     

                    Just should say, I think it's great that we can log on somewhere like this and get responses from you guys - kudos.

                    • 7. Re: D54250WYK 'headless' issue?
                      BSalita

                      Thanks Oviano for initiating this bug report. I can verify this is also an issue with the Intel NUC D34010WYK.

                       

                      My usage scenario, probably somewhat common, is to use the device as a Windows HTPC  in a headless configuration. Well, I'm totally blocked from doing so. Using either LogMeIn or SplashTop remote software, and I assume VNC and Remote Desktop too, the device seems to lock up when the HDMI cable is unplugged. I also believe this is an issue in booting without a monitor.

                       

                      To reproduce, install some remote desktop software (LogMeIn, SplashTop, whatever) and yank out the HDMI cable, wait 10 to 30 seconds. The result is a black screen and a frozen mouse cursor. The expected behavior is for the remote desktop to continue to appear and be usable. I agree with Oviano that this is an EDID related issue. I know the graphics driver guy is going to slap his head when he hears this bug report.

                       

                      I'm using Windows 8.1 Pro N with the latest BIOS, graphics drivers and all others.

                      • 8. Re: D54250WYK 'headless' issue?
                        oviano

                        If you are willing to spend $100 you can solve it if you buy a 'Dr HDMI' device (Google). It's an EDID emulator and you literally just plug it into a short cable and into the NUC and you're sorted.

                         

                        Of course, you shouldn't need to spend money on this, esp as the first generation NUC did not have this problem and so it's probably a reasonable expectation for the second generation to behave similarly.

                        • 9. Re: D54250WYK 'headless' issue?
                          BSalita

                          I actually owned a Dr HDMI device at one time. For $100, I could buy a monitor too. We only have one monitor in the house -- a small TV. It's impracticable to share it with the NUC. I'm going to try to find a workaround. Maybe I can fake the HDMI connection with my receiver or a DisplayPort cable.

                          • 10. Re: D54250WYK 'headless' issue?
                            oviano

                            I believe it's possible to tape a resistor over the appropriate pins of a DisplayPort to VGA cable (or something like that) and make a dongle that would serve the same purpose - I recall stumbling across a website a year or so ago when trying to workaround a similar problem with a headless Mac Mini.

                            • 11. Re: D54250WYK 'headless' issue?
                              oviano

                              I believe it's possible to tape a resistor over the appropriate pins of a DisplayPort to VGA cable (or something like that) and make a dongle that would serve the same purpose - I recall stumbling across a website a year or so ago when trying to workaround a similar problem with a headless Mac Mini.

                              • 12. Re: D54250WYK 'headless' issue?
                                lhill

                                Hello Oviano,

                                 

                                I've opened an incident report with our engineers on this issue.  Can you please fill out our escalation checklist at https://communities.intel.com/docs/DOC-21212?  It will help us to reproduce the problem here, if we can match your configuration exactly.

                                 

                                Regards,

                                Lois H.

                                Intel

                                • 13. Re: D54250WYK 'headless' issue?
                                  oviano

                                  Hi Lois

                                   

                                  Just to give you the information on that form:

                                   

                                  Problem description - I think this has been covered in this thread

                                  Impact - Doesn't bother me anymore, I've worked around it with an EDID emulator

                                   

                                  NUC model : D54250WYK

                                  Serial Number : G6YK342000GJ, G6YK3420008N, G6YK3420005H, G6YK3420009W (I've reproduced the issue on 4 machines)

                                  BIOS version : latest from your website

                                  Operating System : Windows 8.1

                                   

                                  Graphics:

                                  Monitor : None

                                  Graphics driver version : latest from your website

                                  Graphics port used : None (that's the point )

                                  Graphics converter/adaptor used : No

                                  AV receiver used? No

                                   

                                  Networking

                                   

                                  LAN device used : Wires

                                  LAN driver version : Latest from your website

                                  LAN connectivity description : Ugh, switches, routers, modems, homeplug….not relevant though!

                                   

                                  Other hardware:

                                   

                                  Memory : Corsair 2 x 4GB, CL9, DDRL

                                  SSD : Intel 525 60GB

                                  USB devices : None

                                  Thunderbolt device : None

                                  Infrared devices : Built-in only

                                  Audio devices : None

                                  Other : Nothing

                                   

                                  Software:

                                  I use TightVNC as the VNC server, and log in using Remotix on Mac and iOS.

                                   

                                  Hope this helps.

                                   

                                  Regards

                                   

                                  Oliver

                                  • 14. Re: D54250WYK 'headless' issue?
                                    BSalita

                                    I've found an unsatisfying work around for the problem. By attaching the NUC to a AV receiver, the receiver apparently delivers an EDID to satisfy the NUC thus keeping the remoted screen and mouse alive. This is a lousy fix because the receiver has to be on whenever the NUC needs to be accessed. This defeats the goal of a low consumption, always on device.

                                    1 2 3 Previous Next