11 Replies Latest reply on Dec 10, 2013 8:10 AM by meka

    USB issues with Intel DH87RL

    meka

      Hello,

       

      I've bought an Intel Desktop board DH87RL ... mainly because of it praised low power consumption. But I've two have two issues with this Board which I find rather annoying.

       

      1. The board won't detect my USB Sounddevice on any USB port (USB3 or USB2)! It is usually detected as an UAC3556B device and using internal Windows sound-device driver. If I plug it into the board, Windows 7 x64 instantly reports an "Unknown Device" without any chance to install any driver or even get the USB PID and VID of that device. But it is instantly detected as an UAC3556B Sounddevice and will work correctly, if I plug it into an external USB2.0 Hub. Directly attached to the board ... doesn't work at all, at an USB hub ... works fine (doesn't even matter which, all USB hubs I tried did work just fine).
      2. The second USB issue results when trying to boot from an USB stick. I first thought I made an error in creating a bootable USB stick, but the device won't even show as a bootable device in the UEFI BIOS. But the same thing happens as in (1); if I plug the USB stick into an external USB hub the stick will get detected from the BIOS as a bootable device and the stick will boot just fine (again I've tried numerous models). The stick is detected in windows correctly—this only affects its capability to boot from. I've the current BIOS version 322 installed and no idea what I could try... I tried enabling "USB legacy" in the BIOS but it didn't change anything regarding this issue (or the above).

       

      What can I do about these issues?

        • 1. Re: USB issues with Intel DH87RL
          kunal.natta


          Try using the Intel USB3.0 driver

          • 2. Re: USB issues with Intel DH87RL
            meka

            Thanks. They are installed ( Download-Centerhttps://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22589 ) but didn't help for (1). For (2) the problem exists at boot time prior to any driver being loaded.

            • 3. Re: USB issues with Intel DH87RL
              AccountInfinity

              Just want to support this question. I've had the same issue with my Logitech USB H540 headset.

               

              (the UEFI issue though is one that i don't expect to be fixed, but I switched to legacy and IDE when i want to do a usb boot, and then switch back to legacy and AHCI when i'm done)

               

              But it sure would be good if you all would fix your usb 3 drivers so that usb sound devices can be recognized.

               

              Ironically enough the usb 3 drivers which were included with my board, DID recognized my usb sound device, BUT did not enable any usb 3.0 speeds. And as soon as i updated to the latest, the problem is reversed. now i have usb 3.0 speeds but no usb sound device recognition

              1 of 1 people found this helpful
              • 4. Re: USB issues with Intel DH87RL
                meka

                Thanks! It could be the same sounddevice chip... it's a pretty common one and I've read Logitech uses it at least in other products. It's good to hear it did initially work without the Intel USB drivers... this means it can be fixes by Intel driver side!

                 

                What do you mean about the UEFI issue? USB boot does only work in IDE and not AHCI? But why does it work when the Thumbdrive is attached to an USB hub?

                • 5. Re: USB issues with Intel DH87RL
                  sylvia_intel

                  Hello Guys, we are going to make some test in our system using different 3.0 USB devices in order to see if we got the same behavior.

                  I would really appreciate if you can reply with your system configuration, including the model number of the USB devices you have tested

                   

                  I’ll keep you all posted with the results.

                  • 6. Re: USB issues with Intel DH87RL
                    AccountInfinity

                    @meka

                    i was just agreeing that the UEFI was a bust with me on this board. could not get it to work.

                    AHCI + legacy though worked fine.

                     

                    and i'm sorry i actually mixed up my pcs. i also have a laptop that lenovo that would only boot off the usb if i put it on IDE+legacy setting. (also using windows 7). i'm drawing the conclusion that windows 7 hates UEFI

                     

                    @sylvia

                     

                    my system is:

                    windows 7 ultimate

                    intel DH87RL board + intel i5-4570

                    and ofcourse the problem logitech usb headset H540

                     

                    (corsair neutron SSD, 8 gigs bargain value memory, and Radeon 6950 round out the rest of my machine tho i don't think these 3 components matter much?)

                     

                    hope it helps

                    • 7. Re: USB issues with Intel DH87RL
                      meka

                      Hello Sylvia, thank you for your input.

                       

                      the device are USB speakers (Nubert nuPro A-10) and the internal sound device is the UAC3556B (USB ID: VID_0754D, PID_3556 REV_008).

                       

                      My system is an Intel Core i7 4771, 16GB Ram, Windows 7 x64 (up-to-date), Curcial M500 960GB SSD, Intel IGP and now NVIDIA 770 4GB VRAM, NVIDIA  with the Intel DH87RL Board (Bios 322).

                       

                      Thanks!

                      • 8. Re: USB issues with Intel DH87RL
                        gcvsa

                        I am having the same issues with UEFI boot. DH87RL BIOS v.322

                         

                        My USB stick formatted as GPT works fine (it has the ISO for Linux Mint 16 Cinnamon 64-bit), if UEFI boot is enabled and Legacy boot is disabled, only the Blu-ray drive and the USB stick are recognized as boot options. My HDD and my SSD are not recognized as boot options.

                         

                        When I installed Mint to the SSD, the install ran fine. I formatted the SSD as a GPT disk under Mac OS X so that the EFI boot partition would be created correctly (tools for this under Linux are sketchy at best), and allocated the rest of the drive for my root partition, no swap partition. I told the installer to put the bootloader on the EFI system partition, as recommended. However, two things happened: 1) Although the /etc/fstab on the installed system did correctly assign /boot/efi to the EFI system partition, nothing was copied there, and looking on the root partition under /boot/efi, the directory is empty. Also, the UUIDs didn't match between the actual drive and the fstab. This may be a Linux Mint 16 issue, not sure.

                         

                        However, 2) the EFI boot files do seem to get written to /boot/grub, and interestingly, if I copy these files from /boot/grub/x86_64-efi to the EFI system partition, and call it manually through the BIOS EFI Shell, everything boots fine, as it does if I call it from a startup.nsh on the EFI system partition, but the drives still aren't recognized as bootable.

                         

                        This board also exhibits the common problem where the Windows 7 Installer (in my case, Ultimate 64-bit), when the system is in UEFI boot mode, will freeze at the "Starting Windows" screen.

                         

                        Since I am getting this problem with Windows 7, and I did *not* have this problem a few weeks ago when installing Windows 7 64-bit in UEFI mode to a 3TB RAID1 (using the Intel built-in RAID) on an MSI MPower Z87 chipset motherboard (legacy boot cannot be involved, because 64-bit Windows will not work at all without UEFI, and MBR disks cannot be greater than 2TB, so GPT is also required), it looks to me like its the DH87RL BIOS that's at fault here. It just doesn't recognize HDDs as bootable when UEFI is activated alone.I have erased and redone the USB drive, the SSD, and the HDD in several different ways, and each time, the result is the same. Only the USB thumb drive and the optical drive are ever recognized as bootable devices.

                        • 9. Re: USB issues with Intel DH87RL
                          gcvsa

                          OK, I started over. Re-partitioned both the SSD and the USB in Mac OS X as GPT disks with 1 FAT32 partition. Transferred USB stick to DH87RL, entered BIOS UEFI shell, verified no files exist.

                           

                          Transferred USB to Linux Mint 15 32-bit system, and used UNetBootin to copy Linux Mint 16 Cinnamon 64-bit ISO to USB second partition. Transferred both USB and SSD to new system with DH87RL board, Core i3-4130. Set BIOS to UEFI only. SSD not recognised as bootable, only USB recognised as bootable.

                           

                          Entered BIOS UEFI shell, verified NO files exist in fs0:\

                           

                          USB stick boots perfectly, with GRUB selection screen. Ran Linux Mint 16 Installer, installed to SSD, manual partitioning: EFI system partition, root partition formatted as ext4, no swap, bootloader on /dev/sda1 (EFI system partition). Install completes perfectly.

                           

                          Reboot into BIOS UEFI shell, files exist in fs0:\EFI\ubuntu, SSD still not recognised as bootable. Tried setting UEFI+Legacy Boot, still not recognised, but calling fs0:\EFI\ubuntu\grubx64.efi or shimx64.efi results in system booting, but without GRUB selection menu. Checking /etc/fstab and the EFI system partition, this time the UUIDs match, which should apparently be 70D6-1701. Not sure how this got screwed up the last time, nor how the boot files didn't get copied to the EFI system partition (probably because the UUID mismatch), but at least that's fixed.

                           

                          Anyway, I'm confident that this is as clean an install as one could possible achieve, yet UEFI boot is not working properly, because if the BIOS doesn't recognise the SSD or HDD as a bootable device, it's just not ever going to look for a bootloader.

                           

                          As far as Windows 7 is concerned, I followed Microsoft's advice to boot the Windows 7 Installer directly from the BIOS UEFI shell, but it still locks up at "Starting Windows". I'm pretty well convinced these problems are related.

                          • 10. Re: USB issues with Intel DH87RL
                            gcvsa

                            OK, have solved problem!

                             

                            BIOS will NOT recognise a HDD drive as UEFI bootable UNLESS "fsX:\EFI\BOOT\BOOTX64.EFI" exists.

                             

                            Copied fsX:\EFI\ubuntu\grubx64.efi to fsX:\EFI\BOOT\BOOTX64.EFI, and system is working.

                             

                            Missing GRUB menu is actually expected behavior, according to what I've found. Once you have a successful boot in Mint 16, GRUB sets itself to not show the menu until a boot fails.

                             

                            Have also needed to add a "rootdelay=10" to accommodate my SSD booting inconsistently with "root device doesn't exist" type of error.

                             

                            Now, to fix the machine restarts instead of powering off when Linux "shutdown" command is issued. One post said this would be fixed by disabling Wake On LAN, but that didn't solve it for me. And also to fix the Windows 7 freeze, if I can.

                            • 11. Re: USB issues with Intel DH87RL
                              meka

                              @sylvia

                              Any news reproducing the missing interoperability with the UAC3556B soundchip?

                               

                              Thanks