8 Replies Latest reply on Oct 1, 2014 1:45 PM by AlexT_Intel

    Bricked Galileo? Assert EFI ERROR

    Clayton Hofrock

      My Galileo no longer can be detected as a COM device when I connect it to my computer.

       

      I connected up the Serial cable to it and here is the output from the serial cable when it is trying to boot up.

       

      EFI_Assert.jpg

       

      Since I cannot detect a COM port I cannot upgrade the firmware, to put a new firmware image on it. Is there anything else I should try?

        • 1. Re: Bricked Galileo? Assert EFI ERROR
          AlexT_Intel

          I'm by no means an expert here, but as far as I understand, you can flash it either using the CapsuleApp.efi (i.e. from the onboard EFI shell), or using DediProg, if it's not getting as far as the EFI shell. The BSP Build Guide has instructions on that, see Section 10 (https://communities.intel.com/servlet/JiveServlet/downloadBody/21882-102-1-25153/Quark_BSPBuildGuide_329687_001.pdf).

           

          Out of the curiosity - how did you get the board to that state? I'm currently preparing to try the newer 0.8.0 BSP on my board and as long as I haven't done many such FW upgrades yet, I'm gathering the information around on what can go wrong to make sure I'm prepared :-)

          1 of 1 people found this helpful
          • 2. Re: Bricked Galileo? Assert EFI ERROR
            intel_jassowski

            I am having the same symptoms with my Galileo.  The symptoms occurred between power cycles: i.e. it did not happen as a result of attempting to download a new sketch, or due to a FW upgrade.

            • 3. Re: Bricked Galileo? Assert EFI ERROR
              intel_jassowski

              I've copied the messages from the serial port as it boots:

               

              ¦Ftw: Init.. find first record not SpareCompleted, abort()
              Ftw: Abort() success
              Ftw: Allocate() success, Caller:FE5CEA76-4F72-49E8-986F-2CD899DFFE5D, # 1


                   Press [Enter] to directly boot.
                   Press [F7]    to show boot menu options.

              ASSERT_EFI_ERROR (Status = Bad Buffer Size)

               

              The first block of text (with the Ftw:) goes by too fast to easily read, but my impression is that I didn't see these when the Galileo was working.

               

              If no keys are pressed, I get the ASSERT_EFI_ERROR after 5 seconds.  If I press [F7], I get the error message immediately.

              • 4. Re: Bricked Galileo? Assert EFI ERROR
                Clayton Hofrock

                Thanks for the pointer to the BSP document. I think this is what I need. I have a Dediprog, and it has recognized the chip, now I just need a bin file to load on it. I tried using the LITTLE_LINUX????.cap file, but that did not work.

                 

                There are instructions for creating a bin file in the same document, but they are Linux based, so it looks like I will need to finally get around to installing a Virtual Machine on my computer.

                 

                I got my Galileo into this state by not following the advice of powering the board with a AC adapter. I was playing around with a motor shield, and was trying to get a stepper motor to work, and was having problems. So, I unplugged the AC adapter, but I did not unplug the USB cable. So it kept running, and I assume the motor shield was taking too much power so the Galileo board did not have enough.

                • 5. Re: Bricked Galileo? Assert EFI ERROR
                  Clayton Hofrock

                  I have been able to fix my Galileo. It required re-flashing the image on the board using a dediprog.

                   

                  What you will need:

                   

                  Steps:

                  1. Install the DediProg software.
                  2. Remove all power supplies from the Galileo board (USB, and power)
                  3. Plug in the SF-100 DediProg to the Galileo board. (Using the 2X5 cable)
                    • Sony Camera 076.JPG
                  4. Plug in the SF-100 DediProg to the system running the DediProg software
                    1. You may need to install the device driver for the DediProg
                  5. Start the DediProg software
                    1. Start -> Programs -> DediProg -> DediProg Engineering
                  6. Select the Flash Chip Version
                    1. flash_version.jpg
                    2. W25Q64FV
                    3. Click OK
                  7. Open the File to Flash
                    1. Click on File, then on Find, and select the file.
                  8. Click on Batch
                    1. This should, identify the chip,  erase the chip, program the chip, and verify the programming.
                  9. Disconnect the SF-100 from the Galileo board.
                  10. Boot up the Galileo board.

                   

                  Message was edited by: Clay Hofrock Removed the instructions to set the offset, since the linked file is 8MB. It should start at an offset of 0x0.

                  1 of 1 people found this helpful
                  • 6. Re: Bricked Galileo? Assert EFI ERROR
                    AlexT_Intel

                    Thanks for the additional information and the flashing instructions!

                     

                    For anyone who'd follow - please note that you'll get a non-unique Ethernet MAC address by using this FW image as-is, because per the BSP FW image building instructions there's a step of adding the one assigned to your board to the bin file.

                     

                    It will work though and if you need to quickly restore your board, that approach could be used. However if you've got some more time, it would make sense to do the characterization step to make sure you arent't duplicating the MACs, which can result in some weird networking issues if you happen to have two devices with the same MACs on the same network segment.

                     

                    I think we together could make the process of building the FW easier though, I personally interested in that and going to investigate what could be done here. I'll post my findings.

                    • 7. Re: Bricked Galileo? Assert EFI ERROR
                      leehamel

                      My Galileo Gen1 isn't detected by Windows Device Manager any more.  I used to have a COM5 port, now I don't.  I've tried reflashing your image after I ran platform-patch-data.py on it using my Dediprog SF100, but no behavior changes.  I've tried building with Quark BSP 1.0.2 with no luck.  Before I had done any builds I ensured my board worked, and uploaded the Blink example to it.  Are there any suggestions for a board that doesn't get detected by Windows any more?

                      • 8. Re: Bricked Galileo? Assert EFI ERROR
                        AlexT_Intel

                        The first thing I'd do in this case is connect to the serial console and see what's going on there, that should give a clue to next steps.