8 Replies Latest reply on Jan 23, 2015 2:44 PM by AlexT_Intel

    Cannot boot the board from SD card

    AlexT_Intel

      Hello everyone,

       

      I've run out of ideas, so tapping into broader audience.

      As the topic impiles, I can't make it boot off the SD card (standard SPI boot works fine and galileo sketches work).

       

      So I have a Galileo board and an SD card (8GB SDHC Kingston, works just fine in other devices and laptop).

       

      After I unpack the contents of LINUX_IMAGE_FOR_SD_Intel_Galileo_v0.7.5.7z into the root and try to boot the board, all I get is:

      1) from power-on till ~20 sec the SD card LED is blinking irregularly;

      2) from 20 till ~145 sec the SD card LED is almost continuosly on (suggesting it's heavily working with the SD card - theoretically a good sign);

      3) after that the SD card LED is off and doesn't blink any more;

       

      And that's it - the board is not recognized by Windows (it doesn't create that COM port dynamic entry in Device Manager), Arduino IDE doesn't see it either. DHCP server doesn't see any IP address requests coming from the board and I don't see any broadcast traffic from it.

       

      I've tried formatting the card with WIn7 standard formatter, HP USB disk tool, Win7 diskpart, tried decreasing the partition size from the whole card to 2GB, tried copying the files using various tools (sometimes these strange things help to boot from a USB stick) - no dice.

       

      Alas, I don't have a RS-232 cable, it would've been much simpler in that case. I'll work on getting one, but that may take some several days.

       

      So here's the question - what may be wrong here? As far as I can see from the forums, it just works for everyone, so I don't get it

        • 1. Re: Cannot boot the board from SD card
          AlexT_Intel

          Looks like that's some card incompatibility or whatever. Just tried a different card, worked like a charm.

           

          Just in case here are the card specs:

           

          1) The one that didn't work:

          Kingston 8GB MicroSDHC class 10, has the following marking: N0350-002.A00LF;

           

          2) The one that did work:

          ADATA 16GB MicroSDHC class 4 (hmm, Kingston was too fast? :) ), no additional markings;

          1 of 1 people found this helpful
          • 2. Re: Cannot boot the board from SD card
            Jartal

            Hello.

             

            I`ve just started using the intel Galileo and I´m having the same problem about booting from SD card. How do I know if the microSD card that I have is working or not?. Of course mine is not working but I dont know why.

             

            My microSd card is this one:

             

            Kingston 8GB MicroSDHC class 4, has the following marking: N0410-001.A00LF;

            • 3. Re: Cannot boot the board from SD card
              AlexT_Intel

              I haven't investigated that further after I've got another card working. Are you having teh same symptoms I did, or there are some differences?

              • 4. Re: Cannot boot the board from SD card
                Jartal

                Ok I finally manage to get it working, the problem was that I had to upgrade the firmware of the board, after that everything worked fine.

                 

                Regards

                • 5. Re: Cannot boot the board from SD card
                  AlexT_Intel

                  Thanks for reporting that back. Now that you wrote that I recall some reports about the same.

                  • 6. Re: Cannot boot the board from SD card
                    mhhoo

                    just make sure the Galileo board firmware and the SD-Card Linux Image are the latest one.

                    For my Galileo Gen 2 board, the firmware is version 1.0.4 and the SD-Card's image is SDCard1.0.4. (Notice the version numbers are the same!)

                    The SD-Card image can be downloaded from Galileo Software Downloads

                    Do not use the LINUX_IMAGE_FOR_SD_Intel_Galileo_v0.7.7.7z image because it won't work on Gen 2 boards.

                    Sketch will be save in SD card when you upload the sketch to Gen 2 board using micro USB cable.

                    Remove micro USB cable follows by power down the power adapter.

                    Power on the Gen 2 board. Wait for about 2 minutes for Galileo to boot up and load the saved sketch.

                    The micro USB can connect and disconnect without any issue.

                    • 7. Re: Cannot boot the board from SD card
                      riskico21

                      hello guys, i would like to install LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2.zip into an SD Card in my intel galileo

                      But i dont know why mp PC won't detect the SD Card from the galileo

                      i already updated my galileo to the newest firmware

                       

                      Thank you for your help

                      • 8. Re: Cannot boot the board from SD card
                        AlexT_Intel

                        First of all, you would want the image ending with 1.0.4, not 1.0.2, second, I'm not sure what exactly "my PC won't detect the SD Card from the galileo" means. Galileo does nothing to the card you boot from, which may alter it in a way that PC doesn't see it, unless you do really crazy things with it.

                         

                        Just reformat the card on your PC to FAT32, then unpack the image and you should be good. If you mean that your PC doesn't detect the SD card as a device when you insert it into the reader, that sounds more like a reader or SD card failure and you need to check if that's the one or the other by e.g. using a known working card in the same PC or known working reader with your SD card.