2 Replies Latest reply on Nov 21, 2013 8:35 AM by jaezell

    Wrong Memory or Defective Unit

    jaezell

      I just got a Intel NUC D54250WYK the other day from Amazon.  I got all my pieces and parts including the Wi-Fi/Bluetooth Card (Intel 7260.HMWG), 240GB mSATA Card (Crucial CT240M500SSD3).  The memory wasn't going to be in for a while so I scrounged around work for memory that may work and I found some from my Mac Mini 2012-edition.  It was Hynix HMT312S6BFR6C, which I now realize is 1.5V and is a no-no.  I tried to boot it up with this memory and never got any screen, but got the 3 blinks that indicates a memory error.  I then found this forum and the memory requirements for this unit.  I have since ordered 8GB or 1.35V PC3-12800 DDR3 SO-DIMM from Amazon that I saw was on the tested memory list (Crucial CT8G3S160BM), but is a single module.  I tried with this memory in DIMM1 slot and get the same thing.  So, I found a couple other troubleshooting options here that I tried.  I tried booting into the BIOS just to see a screen with this new memory by changing the BIOS security jumper (tried it with all 3 options to no success).  I also tried to unplug the CMOS battery for over an hour and then tried again to see if that would fix it (outlined here without replacement).  Nothing has worked.  A couple questions:

       

      1. Does this thing need dual channel (2 sticks) RAM or is it ok to just have 1 stick?

      2. Is this memory ok? Crucial CT8G3S160BM

      3. I have also ordered this memory.  Should this also work?

      4. Any other ideas I can try?  Everything should be seated properly and at the moment I am trying without any peripherals connected except for the HDMI.

       

      Any help would be greatly appreciated!