1 Reply Latest reply on Nov 14, 2013 8:17 AM by sylvia_intel

    [SOLVED] GPU not working after upgrading CPU to i3570

    aw77

      After upgrading from my i5-2500 to i5-3570 on my ASUS Maximus IV Gene-Z, my NVIDIA GTX 570 is no longer detected. The GPU seems to be powered -- its fan is running and my monitor is plugged into its HDMI port. I can start my computer and get to my desktop fine but the resolution is now restricted. My BIOS is 3603 -- the requirement for the i5-3570.

       

      GPU not detected in Device Manager -- not even in safe mode. But in BIOS, "Extreme Tweaker"-->"GPU DIMM POST" shows "PCIe x16 #1: nVIDIA GPU, running at x8 Native."

       

      I set my motherboard BIOS to use the PCI-E as my primary video device rather than the default "Auto," saved, restarted. Didn't work. Spent a couple hours Googling -- found no solutions (already viewed related thread: http://www.tomshardware.com/forum/382076-33-working-ins...).

       

      Tried re-seating DRAM in every permutation imaginable. Didn't work.

       

      NVIDIA GeForce Experience shows a driver version: 331.65 under "My Rig," but no GPU detected through there either.

       

      lspci output from Linux USB boot shows my GPU. So it's probably a driver issue. Any ideas? I'm desperate.

       

      Aside: Bought a new copy of Windows 7 Pro 64-bit (current version is OEM and I am switching to a SSD) that will arrive on Nov. 20 so I'll try a fresh Windows install then.

       

      Specs:

       

      Windows 7 64-bit Pro
      750W Corsair PSU
      4x4GB Corsair RAM

       

      Thanks in advance.

       

      -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

      Problem solved. My update for posterity’s sake:


      The solution that worked for me involved rolling back my NVIDIA graphic drivers to version 327.23 (WHQL) from 331.65 (WHQL). My GPU was immediately recognized.


      The settings for other relevant variables: My Asus Maximus IV Gene-Z motherboard was already running BIOS 3603, the required version (also the most recent release available) at the time of this writing, in order to accommodate the i5-3570. I also was sure to set my primary display adapter to “PCI-E” rather than the default “Automatic.” I did not clear my CMOS, reseat my GPU, do a clean Windows install or re-install Intel chipset drivers at any point.


      Good luck to other troubleshooters with this problem. Hopefully, my solution works for you as well.

        • 1. Re: GPU not working after upgrading CPU to i3570
          sylvia_intel

          It looks like this is a compatibility issue. We saw some cases like the one you are experiencing with this hardware combination, in which the video card worked with the Sandy Bridge processor, but when changing the CPU to an Ivy bridge it was not recognized anymore.

           

          Some recommendations we can give you could  be:

          • update the BIOS of the board to the latest version. You may need to contact ASUS to get support on this.
          • Test the board using the onboard video.
          • Update the firmware of your video card and latest drivers.
          • Test the system with another video card.
          1 of 1 people found this helpful