4 Replies Latest reply on Feb 12, 2014 11:54 AM by eagamezg

    Need Help Using Libraries

    Intel_Glen

      There are several library files/folders included with the Galileo Adruino IDE.  Are the ones located at: "arduino-1.5.3/hardware/arduino/x86/libraries" the only ones specifically made to work with Galileo?  I have tried running some of the Robot examples and get compile errors associated with the library files in: "arduino-1.5.3/libraries".  I've also downloaded some other examples from the Internet and have had a difficult time trying to get them compiled too, as many of the library files it tries to use are either not found or generate some other kind of compile errors.  Can anyone shed some light on how to use libraries and how to tell which ones can/cannot be used with Galileo?

        • 1. Re: Need Help Using Libraries
          Trush

          Which specific header files did it complain about ?  I tried using Firmata and had seen some errors in boards.h  which I resolved using the solution here:

          https://communities.intel.com/message/209226#209226

           

          In addition, the release notes posted in the link below talk about which sketches are supported currently

          https://communities.intel.com/docs/DOC-21837

          1 of 1 people found this helpful
          • 2. Re: Need Help Using Libraries
            arduino_4_life

            Intel_Glen, the libraries at arduino-1.5.3/hardware/arduino/x86/libraries are the ones that had to be modified/ported in order to work with Galileo. If you want to add a new library then place it in the other /libraries folder at the top-level.

            Can you be more specific about your 'compile error'? can you post the output here please?

            many arduino libraries were written to use AVR-specific header files, like avr/pgmspace.h, and won't compile for Galileo until they have been ported.

            As far as knowing which libraries will work for Galileo (outside of the supported list pointed to by Trush), the best way is to try them

            1 of 1 people found this helpful
            • 3. Re: Need Help Using Libraries
              Intel_Glen

              Thanks Trush and arduino_4_life.  It does appear that my problem lies in the AVR-specific header files.  I had received compile errors about avr/io.h and avr/pgmspace.h not being found.  I tried using a copy I found on the Internet, but then received different compile errors.  So it appears that I'll just have to wait until these libraries are ported over specifically for Galileo.  Until then, I'll stick with the ones in the release notes file Trush pointed me to.  I am new to Arduino so am trying to learn as I go.  Thanks for the help!

              • 4. Re: Need Help Using Libraries
                eagamezg

                I also have the same problem. Right now I'm just creating a dummy headers just to see if it helps. =S