13 Replies Latest reply on Nov 15, 2013 3:52 AM by jiri

    USB boot problems

    T-Dawg

      Hi all,

       

      I have the Celeron 847 NUC kit. I use it to boot from USB for OpenELEC and it works perfectly

       

      However, when doing a cold boot (power off at wall socket to first boot) the NUC always ignores my fast boot options, shows the Intel logo, and says "No bootable device found"

       

      Simply powering off (soft power off with power button) and powering back on fixes it every time. Fast boot restores (text based boot) and boots straight to USB no problems...

       

      When doing the cold boot, if I go into UEFI BIOS setup it says Fast Boot is enabled, detects the USB device etc...

       

      Seems like a UEFI BIOS bug?! Is there any fixes planned? Couldn't find anyone else posting about the same issue....

        • 1. Re: USB boot problems
          joe_intel

          Did you test a different BIOS version? Please indicate version numbers.

          • 2. Re: USB boot problems
            T-Dawg

            Hi Joe,

             

            Apologies - this is with the latest BIOS for the device (0042) - should I try earlier versions of the BIOS?

            • 3. Re: USB boot problems
              joe_intel

              If possible, that way we will see if it happens across different versions or if it is related to a specific one.

              • 4. Re: USB boot problems
                T-Dawg

                Retested with 2 previous BIOS versions, 0040 and 0039. Issue is the same on those as well (different logo on the boot screen when it starts from a cold boot since it's a different version, but exact same problem)

                 

                First cold boot it ignores fast boot and can't detect any devices. Power cycle restores fast boot and it boots fine. No keyboard/mouse activity at all during the process, just a power cycle

                 

                Also - to confirm, I have tried this (on 0042) with multiple usb drives, multiple OS's and multiple usb ports. But the fact that it forgets about fast boot regardless of what USB devices are connected suggests some weird BIOS behaviour anyway, as opposed to issues with the devices themselves

                • 5. Re: USB boot problems
                  joe_intel

                  What fast boot options do you have enabled? The USB optimization will not allow booting from USB, this is expected. I was only able to boot from USB with such option disabled. The results were always stable for me with this option enabled or disabled, cold or warm boot.

                  • 6. Re: USB boot problems
                    jiri

                    I have the Celeron NUC with BIOS version updated to 042. When I tried to install Ubuntu Studio on it as-is, after installation it would not boot anything. But then this worked for me:

                     

                    First I unchecked the "EFI boot" in BIOS and just kept the "legacy boot" option checked.

                    Then I installed Ubuntu Studio on my USB-connected external SSD. I forced it NOT to install the EFI partition. The installer warned me that the world would end but I ignored it :-)

                    After installation was complete, the only way to boot from the USB-disk was by pressing F10 and double clicking the USB disk entry.

                    But then I went back to BIOS and I re-enabled the "EFI boot" option and kept "legacy boot" option checked also... suddenly the system boots without my intervention.

                     

                    I know this works because I did it twice in the past week. I have no idea WHY this works like that but maybe you can try the same. I think that this UEFI thing just adds a layer of complexity and potential screw-ups (on the HW part, SW and user part).

                     

                    It boots OK even after cold boot (tested).

                    1 of 1 people found this helpful
                    • 7. Re: USB boot problems
                      T-Dawg

                      Thanks Jiri! I get the exact same behaviour, re-enabling EFI boot fixes it for me

                       

                      It still seems to ignore my Fast Boot option on cold boot though and gives the graphical Intel logo boot, then it disappears on subsequent warm boots. But at least re-enabling EFI lets it boot.

                       

                      Joe/Intel - Clearly a bug with the BIOS, erratic behaviour on cold boot. Can it be raised with your dev guys as a bug please?

                       

                      Thanks again

                      • 8. Re: USB boot problems
                        jiri

                        Hi T-Dawg, I am glad the work around works for you as well.

                         

                        I find the NUC a little half cooked (maybe it is just Linux support? or my ignorance...) but I still LIKE IT A LOT! I figure the issues will probably get sorted out over time.

                        • 9. Re: USB boot problems
                          joe_intel

                          Thanks for the information. Do you know if this issue happens in Windows* 7 or Windows* 8?

                          • 10. Re: USB boot problems
                            T-Dawg

                            Hi Joe,

                             

                            This was tested with Linux (Openelec) booting from USB

                            • 11. Re: USB boot problems
                              jiri

                              Joe, Windows? Really?

                              • 12. Re: USB boot problems
                                joe_intel

                                I am afraid Windows* 7 and Windows* 8 are the officially supported operating systems.

                                • 13. Re: USB boot problems
                                  jiri

                                  Joe, I forgive you :-) I don't really mind what Intel "officially supports" as long as Linux runs fine on it :-) Couple of years ago I purchased a netbook with Intel Cedartrail platform and that thing used a closed source/non-Linux graphics driver only. It gave me a major headache. It works OKish now but I still remember the pain!

                                   

                                  Back to the boot issues. I wonder how much of it caused by the fact that I boot from an external USB drive (SSD in an enclosure). But, given how exotic the mSATA drives are, one could expect many NUC users to do just that. Plus, it keeps one more device out of the box so less overheating risk also.

                                   

                                  What I mean to say is that when the BIOS is being developed, maybe these boot configurations should be thoroughly tested. Also, I suspect that a large portion of the NUC user base runs Linux on it because it is one of the few comps out there one can buy without OS. I am sure these folks would appreciate if these HW configurations (and BIOS) were tested on Linux. If you pick, say, Ubuntu and Fedora or Suse, it would not take much effort to try and see how it works.

                                   

                                  I think that the low end types of NUC have a great chance to find its place between Raspberry Pi and a regular PC - if it supports Linux well.