13 Replies Latest reply on Sep 11, 2014 10:32 AM by kevin_intel

    DH87MC memory temps incorrect

    Brian Wharry

      I'm posting this at Diego_Intel's request.  I recently used the procedures from this post (DH87MC, Video fail beep code, no video until after OS load) to fix my board not posting, and after using the power button trick to get into the BIOS, my memory temperatures in the BIOS screen have been reporting 86°C instead of the usual ~44°C, even after a cold boot where the machine has been off for a while.  This causes the MB to run the front, CPU, and back fans at full power.  I tried reloading the BIOS defaults many times.  I even re-flashed the BIOS with the same version.  Nothing has fixed the problem.  I've tried removing the memory sticks altogether and booting, then putting them back in.  I've tried 1 stick at a time in every slot.  Nothing has worked.

       

      I should mention that the first time I tried powering on after 3 beeps, the machine seemed to hang.  I tried a few more times, waiting sometimes for 4 or 5 beeps, but in those cases the machine would just power off.  I noticed that sometimes it seems hung after the 3 beeps, but it just takes a while to start (~1min).  I think that might have happened the first time and I powered it off, me thinking it was hung up.  Maybe that screwed it up if it was in the middle of reconfiguring the BIOS.

       

      While it's possible the memory chips' thermal sensors went bad simultaneously when they did, it seems highly unlikely considering they're in a cool environment and the case has 6 total fans, and I did not touch the memory DIMMs right before it happened.  More likely it's a glitch in the BIOS.

       

      I have gotten around the problem by telling the BIOS to ignore the memory temp when controlling the front, back, and CPU fans.  I also maxed out the "normal" memory temperatures.

       

      Coincidentally, the Intel Desktop Utility Summary screen reports the memory and VR temps at 170°C and 196°C, respectively.  While the Board screen reports those same values, but as negative numbers.  I don't understand why it is reporting different °C numbers than the BIOS when the other temps match what the BIOS is reporting.

       

      I'm using 2 8GB Crucial DIMMs, model # BLS2KIT8G3D1609DS1S00.

       

      Brian

        • 1. Re: DH87MC memory temps incorrect
          kevin_intel

          Hi Brian Wharry,

          Based on your description there are some troubleshooting steps I want you to try first:

          1. Please take the motherboard outside of the chassis and clear the cmos by removing the battery and disconnected all other components from the board for about 20-25 minutes.
          2. Reconnect all other components and make sure the heat sink fan is connected correctly.
          3. If possible test a different memory stick (different part number or brand).

           

          If all that troubleshooting has been done and the issue continues, you should check with your place of purchase to replace this unit if its less than 30 days old or check with your local Intel(R) customer support for a warranty replacement. For contact information please refer to: http://www.intel.com/p/en_US/support/contactsupport

          • 2. Re: DH87MC memory temps incorrect
            Cris11

            Hello Brian,

             

            I've had the same issue with this mainboard: after updating its firmware, temperatures reported were way too high, causing fans to operate at maximum speed, rendering the overall system way louder than necessary.  I too have tried lots of options, including re-flashing the BIOS, but to no avail. Eventually, I had to have it replaced.

             

            Obviously, temperatures are read out incorrectly; with my new board, things are back to normal.

             

            Regards,

             

            Christian

            1 of 1 people found this helpful
            • 3. Re: DH87MC memory temps incorrect
              Howdy!

              A similar problem, though now worse, involving a DH87MC.  Brand new build, with WD Black 1TB HDD, and Samsung 64gb SSD, and 2x4GB 1600 memory.  First boot I went into BIOS to set SATA to RAID, but no other changes.  I did a clean install of WIN 7 on HDD, followed by all Intel and Win 7 updates.

               

              During this process, after installing Intel Desktop Utilities, I noted that Memory was reporting as 1333, and Memory and VR temps as BOTH above 200c (on list), and below -200c (on graphic).  However, fans were running at 1300rpm on cpu, and 700rpm on front and rear.  I went into BIOS, changed memory profile to XMP-1600, saved, exited.  Everything worked fine, but Desktop Utilities continued to report memory as 1333, and wrong memory and vr temps.

               

              After all Intel/Win7 updates, I entered Intel RST and set HDD/SDD to Accelerated/Enhanced.  Re-booted and system worked well.  System continued to work correctly through several additional re-boots.

               

              With everything finished, I went back into BIOS to see what it was reporting as far as temps, and it was reporting memory and vr temps consistent with other temps, around mid-40c.  In addition, memory was still reporting as 1333.  I exited the BIOS, but INSTEAD of booting into Win7, the machine entered a loop going from RAID to BIOS to RAID to BIOS splash screens, and is now stuck in this loop on every re-boot.  In this loop, Ctrl-I allows entry into RAID config, but F2 does NOT enter BIOS setup.

               

              At present, if I set BIOS jumper to lockdown, the machine will boot to WIN7 (but no access to BIOS).  On several occasions, the fans go full tilt.

               

              I can enter BIOS ONLY by removing CMOS battery for 15min, and powering up with BIOS jumper set on pins 1&2.  However, once in BIOS, and going back to default settings (ie, default except for changing the SATA to RAID); after saving and exiting, the system re-enters the endless BIOS/RAID splash screen loop.

               

              With no jumper on BIOS pins (ie, set to configuration), I get reset password, etc, but no entry into BIOS.

               

              I've even done a BIOS recovery, following a CMOS battery removal, and system still enters BIOS/RAID loop instead of booting into Win7 when BIOS pins are on 1&2.

               

              ANY suggestions on getting this machine back to booting into Win7 (and being able to F2 enter into BIOS)?  Or, do I just need to replace the DH87MC altogether?

              • 4. Re: DH87MC memory temps incorrect
                Howdy!

                Just wanted to add, after the BIOS recovery effort, the Memory and VR temp are now reporting as -180c to -190c in Desktop Utilities, and 56c (VR) and 75c (Memory) in the BIOS.  And, as a result, the fans are all now running at close to 100% rpm.

                • 5. Re: DH87MC memory temps incorrect
                  spearson

                  Brian/Howdy,

                   

                  A bug in the health monitoring and fan speed control code is responsible for the incorrect temperature readings and fan speed control results. An updated BIOS is on its way that includes a fix for this issue. As well, since this same code is also used within the Intel Desktop Utilities (IDU) application, an updated release (3.2.7) of the application is on its way as well. You need both for a complete solution. Watch for them appearing on Download Center over the next couple of weeks...

                   

                  As for the other issues that you are seeing with RAID initialization, etc., these are completely unrelated. I have reported them to the BIOS team...

                   

                  ...Scott

                  • 6. Re: DH87MC memory temps incorrect
                    Brian Wharry

                    Boy Howdy!  That's a terrible fix you're in!  Luckily it looks like the good folks at Intel have a partial fix in store for us.  For your endless loop problem, try disabling UEFI boot if you haven't already.  It won't affect the performance of your machine as far as I can tell, and it saved me from returning the board.

                     

                    Also, I have a different Intel board that's about a year old (model DZ77BH-55K), and it also incorrectly reports through IDU that the memory is running at 1333 when the BIOS tells me it's 1600.  Hopefully that will be fixed with an IDU update.  I just hope IDU is wrong and the BIOS is right!

                     

                    To Kevin_Intel, I did try one of your steps.  I tried disconnecting the MOBO battery and the power supply.  I left the battery out for an hour, but would you believe it didn't clear the BIOS settings?!?  I failed to disconnect the network cable, and the power coming through it must have been enough to sustain the BIOS settings.  Ha ha.  I lost patience after that and didn't try anything else, and I'm glad I didn't seeing as Mr. Spearson says this is a bug with the MOBO!

                     

                    Thanks for your help guys!

                    Brian

                    • 7. Re: DH87MC memory temps incorrect
                      Howdy!

                      Briann Wharry: I already RMA'd the board.  Sometimes it is just easier to start fresh, especially when (a) it was fairly simple to just exchange boards, rather than try to solve the BIOS issues, and (b) the endless loop BIOS problem wasn't simply the loop, but the inability to change any settings in the BIOS that would stick.

                       

                      So, until Intel figures out the BIOS endless loop/bricked your computer issue, the ONLY change I'll make to the BIOS on the new board will be the SATA controller.

                      • 8. Re: DH87MC memory temps incorrect
                        Klaus_DK

                        Hi all,

                         

                        I just updated my DH87MC BIOS to 0152 from 0047.

                        Big surprise, as my memory suddenly was reported as being 86 C, and all fans ran at full speed.

                        To top everything: downgrade is not possible.

                         

                        A new BIOS is NOT downloadable @ dec 7.

                         

                        Guess I have to leave the chassis (CoolerMaster HAF XB) open :-)

                        • 9. Re: DH87MC memory temps incorrect
                          DavidO

                          Hello Klaus,

                           

                          Unfortunately, I think we are all on the same boat. This is my 3rd problem with this bad quality product.

                           

                          I upgraded from 0047 to 0152 today. On 0047, my temperature was negative. Now with 0152, the release notes mention a fix for a memory temp issue and it makes things worse because the temperature is now around 113 C and the fans are going full speed.

                           

                          It is also not possible to downgrade it back to 0047 as mentioned in the release notes and it is not possible to take the memory temperature away from the fan speed calculation (probably due to yet another bug).

                           

                          I had problem with the XMP profile settings not being saved properly, and I still have problem with the HDD password feature.

                           

                          I trusted Intel despite them going away from the MB business, and it is clear I was wrong!

                          • 10. Re: DH87MC memory temps incorrect
                            kevin_intel

                            Hi All,

                            I am sorry for the inconvenience. Our engineers are working to develop a new bios to fix these issues. We do not have an ETA yet but it will be released soon.

                            • 11. Re: DH87MC memory temps incorrect
                              Firestarter

                              New update is released. I updated the bios to the new version, 153. And temperature issue has been fixed in it .

                              Thank you

                              • 12. Re: DH87MC memory temps incorrect
                                vipin_singhal

                                Kevin.....

                                 

                                Having same temperature issue, I have tried bios recovery to all the version from 152 - 154 - 155 - 156 - 157 and vice versa, but nothing works.

                                 

                                Can you please help to suggest, if I need to get the motherboard replaced as had purchased hardly 20 days back.

                                 

                                And also want to report very strange issue that after upgrading bios to 154 - 155 - 156 & 157 versions, its not allowing to get into F2 setup mode and if you press F2 for setup, the system gets freezes.

                                 

                                Thanks...

                                • 13. Re: DH87MC memory temps incorrect
                                  kevin_intel

                                  You can try the steps mentioned here:

                                  http://www.intel.com/support/processors/sb/CS-029427.htm

                                   

                                  If you have done all those steps and issue persists, I would recommend you contacting your local support for replacement if necessary:

                                  http://www.intel.com/p/en_US/support/contactsupport

                                   

                                  Kevin M