5 Replies Latest reply: Nov 21, 2013 12:42 PM by joe_intel RSS

Intel Centrino Wireless-N-2200 keeps going to No Internet or Limited

droidmaker Community Member
Currently Being Moderated

I have a Toshiba laptop that has this chipset in it for wireless. (Satellite P875-S7310)

 

With Windows 8, going into the Adapter Settings and turning off N mode (802.11n) solved a lot of issues.

 

Since upgrading to Windows 8.1, it keeps dropping out, trying to connect to other networks other than my own and sits and spins when I have to try going back to mine.  Router is a Linksys E3200  I have gone into the network adapter settings and again disabled the N mode.

 

Problems persist (knocked offline, limited internet...)

 

Did the Intel Update service and allowed it to update to newest drivers.  No change

 

Noticed on here the suggestion to go into Device Manager , select the Wifi and update the driver.  When I do so, it auto detects 7 drivers that all read Intel Centrino Wireless-N-2200 (which one?)

 

What else can I do to make this thing stable?  When it drops the connection and I have to re-join, I get the "Windows is taking longer than expected..." then finally does, with no internet or limited.

 

Laptop is 22 feet away from router.  Again, this all worked fine in 8 by disabled 802.11n mode

 

Thanks


More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points