8 Replies Latest reply on Nov 17, 2013 8:49 AM by siamcat

    mSATA doesn't work on DH87MC

    ChrisG

      I bought a DH87MC (BIOS version 0047) & Core i5-4570 a few months ago to run Win8.  Everything worked as expected.  About a week ago I decided to upgrade to a 180GB 525 SSD Series (model SSDMCEAC180B301, firmware version 2.0.6) and Windows 8.1.  This is where I ran into trouble.

       

      When I attempted to load the OS, I got an error message stating:

      "Windows could not format a partition on disk 0. The error occurred while preparing the partition selected for installation. Error code:0x80070057"

       

      I have to do a hard reset when this error occurs and the mSATA SSD is missing from BIOS.  The only way I can get the mSATA SSD to show back up is to completely remove all power from the machine.

       

      At first, I thought it was a bad drive.  I ordered it from Amazon & requested a replacement.  But when it arrived, I was still getting the same results.  I even tried to load the AHCI Rapid Storage Technology drivers during installation when you're selecting a disk.  Same results.

       

      Next installed Windows 8.1 Enterprise x64 on my Seagate Constellation ES 2TB HDD. Then I opened Disk Management, selected the 525 SSD, deleted the volume, and recreated a simple volume "D:".  I opened an elevated command prompt and ran "format d: /P:0" to try to completely zero out the SSD.  The format failed with:

      "The media being formatted has been removed or has become invalid.

      Format aborted.

      Format failed."

       

      My next step was to plug in the 525 SSD into a Syba mSATA to SATA adapter (model SY-ADA40050).  Results were positive.  I was able to delete all partitions, format, and install the OS as one would expect.

       

      So this leads me to believe something is wrong with the mSATA port on the DH87MC.  I am using a 120GB 525 SSD Series on my laptop - HP 8570w - and it runs like a champ.  So I'm really disappointed it won't work on the desktop motherboard.

       

      Can someone from Intel help?