9 Replies Latest reply on Jan 14, 2015 1:40 PM by DanKline

    Problem uploading sketches.

    Clayton Hofrock

      I have run into this error several times. The only fix I have found is to restart the system running the IDE.

       

      I hope there is a better solution. Hopefully, people can help me out.

       

      Binary sketch size: 54,404 bytes (of a 262,144 byte maximum) - 20% used

      cygwin warning:

        MS-DOS style path detected: C:\Intel\arduino-1.5.3/hardware/arduino/x86/tools/izmir/clupload_win.sh

        Preferred POSIX equivalent is: /cygdrive/c/Intel/arduino-1.5.3/hardware/arduino/x86/tools/izmir/clupload_win.sh

        CYGWIN environment variable option "nodosfilewarning" turns off this warning.

        Consult the user's guide for more details about POSIX paths:

          http://cygwin.com/cygwin-ug-net/using.html#using-pathnames

      #!/bin/sh

       

       

      echo "starting download script"

      echo "Args to shell:" $*

       

       

      # ARG 1: Path to lsz executable.

      # ARG 2: Elf File to download

      # ARG 3: COM port to use.

      starting download script

       

       

      Args to shell: C:\Intel\arduino-1.5.3/hardware/tools/x86/bin C:\Users\OFFICE~1\AppData\Local\Temp\build2347904014153457648.tmp/SD_readWrite.cpp.elf COM9

      COM PORT 9

      Converted COM Port COM9 to tty port /dev/ttyS8

      Sending Command String to move to download if not already in download mode

      Deleting existing sketch on target

      #path contains \ need to change all to /

      path_to_exe=$1

      fixed_path=${path_to_exe//\\/\/}

       

       

      #COM ports are not always setup to be addressed via COM for redirect.

      #/dev/ttySx are present. Howwever, COMy -> /dev/ttySx where x = y - 1

       

       

      com_port_arg=$3

      com_port_id=${com_port_arg/COM/}

      echo "COM PORT" $com_port_id

      tty_port_id=/dev/ttyS$((com_port_id-1))

      echo "Converted COM Port" $com_port_arg "to tty port" $tty_port_id

       

       

      echo "Sending Command String to move to download if not already in download mode"

      echo "~sketch download" > $tty_port_id

       

       

      #Move the existing sketch on target.

      echo "Deleting existing sketch on target"

      $fixed_path/lsz.exe --escape -c "mv -f /sketch/sketch.elf /sketch/sketch.elf.old" <> $tty_port_id 1>&0

        • 1. Re: Problem uploading sketches.
          Intel_SteveH

          Hi,

          I am having the same issue - this is stated in the Release Notes as a known issue on current hardware. I agree that it's incredibly frustrating.

           

          Sometimes my code will upload, but very, very slowly. Instead of the upload progress flying by, the "xxxx of xxxx bytes" part crawls by. Eventually it will stop uploading.

           

          The other issue I am seeing is that /dev/ttySCM0 disappears and I can't do anything at all, I have to reboot the system running the code (note: not necessarily required to reboot the Galileo). I think this is an IDE issue because of that.

          • 2. Re: Problem uploading sketches.
            AlexT_Intel

            I've faced something like this only once or twice so far and what worked for me was pressing the sketch Reset button on the board (not the Reboot one).

            • 3. Re: Problem uploading sketches.
              Rafael.Gomez

              I am also running into this issue...

              • 4. Re: Problem uploading sketches.
                ashe

                I encountered this issue, and the only way i could get around was hit reset button multiple times.

                • 5. Re: Problem uploading sketches.
                  xale

                  Has anyone found a more reliable solution to this issue? I'm now seeing this consistently, and can't find any way to reset or upload new sketches at all. My device is completely bricked.

                  • 6. Re: Problem uploading sketches.
                    Stephen.Schieberl

                    I run into this consistently, as well. This seems to be working for me. Sometimes I don't need step 3 or steps 5 - 8, but I usually do. Following all the steps seems to work every time for me now.

                     

                    1) Close the Arduino IDE.

                    2) Open Task Manager to force quit "bash.exe" and "lsz.exe", if they are still open.

                    3) Delete the contents of /sketch on the system side (ie, over SSH).

                    4) Press the "reset" button on the Galileo.

                    5) Unplug the USB cable.

                    6) Wait a moment.

                    7) Plug the USB cable back in.

                    8) Wait to hear it connect.

                    9) Open Arduino IDE. Verify the serial port is connected and try again.

                    • 7. Re: Problem uploading sketches.
                      DanKline

                      I too am experiencing a related issue.  I was playing with the MS Iot DevKit which still works somewhat, but when I restarted the Galileo with 1.0.4 SD boot it compiles but cannot upload the sketches and errors with "C:\arduino-1.5.3-Intel.1.0.4/hardware/arduino/x86/tools/izmir/clupload_win.sh: No such file or directory error"  I've remove the SD and tried to upload using the system flash.  The same result.  I updated the firmware using the IDE which succeeded, however the attempts to upload sketches is the same. I've reinstalled the Arduino IDE with no change in results.  I've uninstalled and reinstalled the com ports and drivers, again with no change in results.  At this point, I don't seem to be able to use the Arduino IDE and I've never been able to successfully install the yocto image to an SSD.

                       

                      I'm up against the wall here.  Does anyone have any suggestions?

                      • 8. Re: Problem uploading sketches.
                        DanKline

                        I figured this out.  For unknown reasons, the C:\arduino-1.5.3-Intel.1.0.4\hardware\arduino\x86\tools\izmir\clupload_win.sh file was missing.  Even reinstalling/repairing the Arduino for Windows application did not restore it.  I needed to drill down into the zip file and manually extract it to the directory.  After that, the Arduino IDE is functional again.  I'll update this post if I figure out the sequence of events that led to the file being removed.

                        • 9. Re: Problem uploading sketches.
                          DanKline

                          This morning, to my chagrin, when I restarted everything, I was faced with the "No Such file or directory" error.  It occurred to me that the message was related to the tty object..  See my troubleshooting and solutions in the attached word document.