1 Reply Latest reply on Mar 31, 2014 12:56 PM by Yan_Adam

    ixgbe allow_unsupported_sfp no longer works

    JasonLu

      I have run  “ modprobe –r ixgbe && modprobe ixgbe allow_unsupported_sfp=1” to enable allow_unsupported_sfp after upgrading the ixgbe driver to v3.17.3. Unfortunately,  I still got “failed to load because an unsupported SFP+ module type was detected” issue. Do we need to reboot the server to apply modprobe?

        • 1. Re: ixgbe allow_unsupported_sfp no longer works
          Yan_Adam

          Just in case anyone comes looking here, the possible solution to the above is to use:

          modprobe ixgbe allow_unsupported_sfp=1,1


          As in: you have to spell out allow for both ports in the case of an 82599 NIC for example.

          It must seem obvious to most since it's barely mentioned anywhere but hey... modinfo DOES say it's an array


           

          parm:       allow_unsupported_sfp:Allow unsupported and untested SFP+ modules on 82599 based adapters, default 0 = Disable (array of int)