12 Replies Latest reply on Nov 18, 2013 4:59 PM by spearson

    Enabling SecureBoot -> Black Boot Screen

    Pro

      Hi,

      my mainboard is a DH77KC updated to the latest bios version 0110.

      The graphics card is a Saphire HD 7770 1GB (supports UEFI).

       

      I installed Win 8.1 and enabled Secure Boot but now the Display remains black during boot (no Intel logo, can't access bios) then Windows starts without problems.

      The monitor is plugged in to the Saphire DVI Port.

       

      If I plug the monitor into the onboard DVI Port, it shows first the error message:

      "Video OptionRom authenthicate fail".

      Then shows the boot screen but then after booted to Windows it remains black.

       

      If I disable Secure Boot everything works fine: Boot screen/intel logo shows up and then Windows boots. But this causes the watermark on the Windows Desktop that Secure Boot isn't installed properly.

       

      (I can access the bios by either plugging in the monitor to the onboard DVI port or changing the BIOS jumper to configuration setting).

       

      How can I use Secure Boot and also see the Boot screen?

      Thanks

        • 1. Re: Enabling SecureBoot -> Black Boot Screen
          sylvia_intel

          Pro, at this moment there are not drivers available for Windows 8.1 since this is a preview version.

          Regarding the issue you are experiencing, we got the following workaround. Would you please give it a try and let me know the results?

           

          1. Go to the secure boot options on BIOS

          2. Enable secure boot (if disabled)

          3. Check on the option that says “Install Intel platform key”

          4. Press F10 to save changes and restart the system

          • 2. Re: Enabling SecureBoot -> Black Boot Screen
            Pro

            @sylvia_intel Thanks for your help.

            I tried you steps but that didn't fix it. Any other ideas?

             

            By the way, Windows 8.1 should be supported because it isn't a preview version anymore! It got released on 21st october. But I don't think this is a Windows problem because Windows boots up, but the bootscreen doesn't show.

            • 3. Re: Enabling SecureBoot -> Black Boot Screen
              sylvia_intel

              Would you please try your system using the integrated graphics, no video card?

              I heard that Microsoft released a new version of Windows 8.1.

              • 4. Re: Enabling SecureBoot -> Black Boot Screen
                Pro

                If I plug the Display into the integrated graphics card, I can see the boot screen (as already mentioned). But I need to use the graphics card because of the better performance.

                I think this problem is related to secure boot and invalid or unsupported integrated graphics driver.

                Because if I disable Secure boot, the mainboard automatically switches between integrated and graphics card without problems.

                • 5. Re: Enabling SecureBoot -> Black Boot Screen
                  sylvia_intel

                  Pro, would you please access the following link and use the Intel® System Identification Utility:  http://www.intel.com/support/siu_la.htm?wapkw=%28siu%29

                   

                  That will generate an 8 digits code called Report Reference ID.  Please let us have that code, this will provide us information on what is being detected on your system. In addition please fill in the following information:

                   

                  AA number and Serial number of the motherboard:

                  BIOS version:

                  processor model:

                  Memory manufacturer and part number:

                  power supply model number:

                  Any other device connected:


                  Once I received this information I will provide this behavior to the Engineering Team.


                  Regards

                   

                  • 6. Re: Enabling SecureBoot -> Black Boot Screen
                    Pro

                    Here you go:

                     

                    Reference ID: 0219 2982

                    AA number: AAG39641-400

                    Serial number: BTKC24800M1S

                    BIOS version: KCH7710H.86A.0110.2013.0513.1018

                    processor model: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz

                    Memory: 16GB-Kit Corsair Vengeance blue DDR3 1600 MHz CL9

                    Power supply: be quiet! STRAIGHT POWER CM BQT E9-CM-480W 80+Gold

                    Other devices connected:

                         - GPU: Sapphire Vapor-X Radeon HD 7770 OC, 1GB GDDR5

                         - Monitor: Dell U2410

                     

                    One thing i found out:

                    I installed the most recent driver for Intel Graphics HD 4000 ( https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23323 ) but in the Device Manager the graphics card has a yellow error triangle. If I open the details page there is the following error: Code 43: Windows has stopped this device because it has reported problems. I already tried the steps as described here but that didn't fix it: Code 43: Windows has stopped this device because it has reported problems

                     

                    Thanks for your help!

                    • 7. Re: Enabling SecureBoot -> Black Boot Screen
                      sylvia_intel

                      Thanks for the information. I'm going to provide all this to the engineers.

                      • 8. Re: Enabling SecureBoot -> Black Boot Screen
                        sappersix

                        I have the same problem.

                         

                        DH77DF, AA #: G40293-301, BIOS 0110.

                         

                        I set the Secure Boot in the BIOS and now when I restart my machine, there is no intel logo, no ability to press F2 to enter BIOS and it boots straight to Windows 8.1,

                         

                        Ironically, I enabled SecureBoot in hopes of getting rid of the "SecureBook isn't configured correctly" watermark and it's still there.

                         

                        How do I get have into the BIOS settings?  Do I really need to open my case and set the BIOS jumper to configure?

                        • 9. Re: Enabling SecureBoot -> Black Boot Screen
                          Pro

                          You can remove the "SecureBook isn't configured correctly" watermark by resetting the Secure Boot keys to Intel defaults, this worked at least on my mainboard.


                          To get into BIOS, plug you Display into the socket of the embedded graphics. Then afterwards plug it back into the externa GPU socket.

                          • 10. Re: Enabling SecureBoot -> Black Boot Screen
                            RainStaff

                            Same motherboard, same problem plus :

                             

                            Now, even if I disable Secureboot my bootscreen stays black.

                             

                            Like Pro, if I plug the monitor into the onboard DVI Port, I get the Video OptionRom authenthicate fail message whereas I never used to get that before activating secureboot.

                             

                            Somehow, turning on secureboot broke something somewhere in the BIOS that cannot get fixed by a firmware update (I just updated from 0108 to 0110).

                             

                            I'm considering purchasing a new graphics card, maybe a GTX760, but I'm unsure this will solve the problem.


                            PS : Turning off "UEFI boot" in BIOS seems to fix the issue but is an unacceptable solution.

                            • 11. Re: Enabling SecureBoot -> Black Boot Screen
                              Pro

                              I had to enable "Legacy Boot" which automatically disables Secure Boot to solve the video problem. Now I can see the Intel logo again during boot, but disabled Secure Boot is not an option for me!

                              • 12. Re: Enabling SecureBoot -> Black Boot Screen
                                spearson

                                All,

                                 

                                When you enable Secure Boot, the BIOS must have UEFI drivers for all necessary hardware in order to support the use of this hardware during the boot process. The BIOS provides the drivers for the embedded features, including Intel graphics, but add-in cards, to be included, must provide their own UEFI driver (via OP-ROM). The authentication failure message is an indicator that the OP-ROM provided on the graphics card is not in compliance and/or does not provide the necessary UEFI driver. Look to the board's manufacturer for an updated OP-ROM that brings it into compliance...

                                 

                                ...Scott