1 2 Previous Next 16 Replies Latest reply on Jul 16, 2015 12:57 PM by MonaJalal

    Problems updating firmware

    SdC

      HI there,

      I'm very happy to have a galileo board, I think the combination of Intel processor and arduino board is quite cool.

      Buuut, after some hour trying to blinking a LED I gave up, I can't update the firmware via IDE

       

      I downloaded the latest Arduino IDE version, following step by step the quick start guide.

      When I try to update firmware, after the message asking me to confirm that 5V power cable is plugged in, an error occur:

      << Target Firmware Version Query Failed >>

       

      Can it depends of I've not delete previous version of Arduino?? (I really can't delete it...)

        • 1. Re: Problems updating firmware
          flummer

          Hi,

           

          It's propbably because you have a space in the path or filename of the special Arduino IDE, I had the same problem and eliminating spaces fixed it.

           

          /Thomas

          • 2. Re: Problems updating firmware
            roberto.gallea

            Hi,

            I confirm Thomas solution. Avoid either space and/or long (>8 chars) names.

            • 3. Re: Problems updating firmware
              Pintux

              Unfortunately, it doesn't seem to work for me. In my case the IDE file name on OSX is "Galileo.app" 

              • 4. Re: Problems updating firmware
                flummer

                Hi Pintux,

                 

                Is the IDE otherwise functioning correctly when e.g. compiling the blink sketch?

                 

                Did you put the .app file into the "Applications" folder, or did you try to run it from a different location?

                 

                /Thomas

                • 5. Re: Problems updating firmware
                  Pintux

                  Hi,

                   

                  yes, it works, also uploading my own sketch (sometimes it has difficuly to connect to the ethernet but it runs).

                  The .app is under /Applications folder but I've renamed it "Galileo.app".

                  Thank you.

                   

                  .a

                  • 6. Re: Problems updating firmware
                    nuke

                    That error usually means the Galileo is not available on the selected serial (USB) port in the IDE. Sometimes it may happen if there is a sketch running on the board.

                     

                    Try rebooting the board and your computer, then connect the USB cable and reselect the correct serial port in the IDE. That will probably get you going.

                    • 7. Re: Problems updating firmware
                      Pintux

                      Thank you Nuke,

                      it worked.

                      • 8. Re: Problems updating firmware
                        newera

                        Hello, Guys

                        I have the same problem and none of above solutions works for me. My machine uses Win 7 with latest updates.

                        IDE works, drivres are installed no problems there. My first gues was smoting wrong with board but seems to be "a live".

                        Takes some time to boot, SD LED blinks before pc to detect the connected board. If there is a way to test if the board is good please share.

                        • 9. Re: Problems updating firmware
                          Rod_H

                          Try the Blink example, if that works then your board should be fine. If you are booting your board with SD card then that could be the issue, power off you board take SD card out, power up your board, check the com port, and then try the firmware update.

                          1 of 1 people found this helpful
                          • 10. Re: Problems updating firmware
                            newera

                            Hello , Rod_H. I'm not using SD card and I try Blink example. The sketch is compiling and returns massage "Done Uploading" - LED  is aways On and doesn't  blink.

                            • 11. Re: Problems updating firmware
                              rexstjohn

                              I'm on Mavericks. The following procedure resolved "Target Firmware Version Query Failed" for me:

                               

                              • Make sure green "USB" LED is on.
                                • If it is turned off, unplug your USB cable and plug it back in again
                                • If you hit the reset button, the green light will turn off...it won't work unless that light is green
                              • Every time you close and reopen the Ardunio IDE, you must make sure that the "usbmodemXXXX.cu" serial port has been selected
                                • If you exit Arduino IDE, you may have to re-select this port (Tools -> Serial Port)
                              • Make sure that Galileo board is selected in Arduino IDE
                                • Tools -> Board -> Galileo
                              • Try uploading the "Blink" example from: https://learn.sparkfun.com/tutorials/galileo-getting-started-guide/uploading-blink
                                • Copy+Paste the code  + Hit "Upload" and read the resulting terminal output.
                                • If you see warnings about "Transfer incomplete" try restarting the board / unplugging and plugging the USB back in
                                  • Again, make sure USB light is green

                               

                              Other notes:

                              • Didn't have the SD card in the board when I did this
                              • 12. Re: Problems updating firmware
                                SimplyKen

                                Hi I'm getting the "Target Firmware Version Query Failed" Error as well.

                                 

                                OS X 10.7.5

                                System info - USB shows Gadget Serial v2.4

                                Arduino IDE renamed to "Galileo" and placed in the Applications folder. 

                                /dev/cu.usbmodemmfd211 is selected under tools. 

                                USB light is green

                                No SD card is in the board

                                 

                                Note that upon opening System Preferences - Network there is a Gadget Serial v2.4 here but it is not configured. 

                                Blink will compile but when trying to upload it, it will throw errors.

                                 

                                Any thoughts?

                                 

                                This is the complete error from the compiler window:

                                Binary sketch size: 50,658 bytes (of a 262,144 byte maximum) - 19% used

                                starting download script

                                Args to shell: /Applications/Arduino/Galileo.app/Contents/Resources/Java/hardware/tools/x86/bin /var/folders/0s/682hjcws5w39r6mqyg98wr5w0000gn/T/build1007156708558349956.tmp/Blink.cpp.elf /dev/cu.usbmodemfd211

                                Serial Port PORT (note: should be /dev/cu.xxxxxx for OSX)

                                #!/bin/sh

                                Using tty Port /dev/cu.usbmodemfd211

                                Sending Command String to move to download if not already in download mode

                                #

                                echo "starting download script"

                                echo "Args to shell:" $*

                                #

                                # ARG 1: Path to lsz executable.

                                # ARG 2: Elf File to download

                                # ARG 3: TTY port to use.

                                #

                                #path may contain \ need to change all to /

                                path_to_exe=$1

                                fixed_path=${path_to_exe//\\/\/}

                                #

                                tty_port_id=$3

                                echo "Serial Port PORT" $com_port_id "(note: should be /dev/cu.xxxxxx for OSX)"

                                echo "Using tty Port" $tty_port_id

                                #

                                echo "Sending Command String to move to download if not already in download mode"

                                echo "~sketch download" > $tty_port_id

                                #Give the host time to stop the process and wait for download

                                sleep 1

                                #

                                Deleting existing sketch on target

                                #Move the existing sketch on target.

                                echo "Deleting existing sketch on target"

                                "$fixed_path/lsz" --escape -c "mv -f /sketch/sketch.elf /sketch/sketch.elf.old" < $tty_port_id > $tty_port_id

                                /Applications/Arduino/Galileo.app/Contents/Resources/Java/hardware/arduino/x86/tools/izmir/clupload_osx.sh: line 25: 15116 Segmentation fault: 11  "$fixed_path/lsz" --escape -c "mv -f /sketch/sketch.elf /sketch/sketch.elf.old" < $tty_port_id > $tty_port_id

                                #"$fixed_path/lsz.exe" --escape -c "mv -f /sketch/sketch.elf /sketch/sketch.elf.old" < $tty_port_id > $tty_port 1>&0

                                #

                                # Execute the target download command

                                #

                                #Download the file.

                                host_file_name=$2

                                "$fixed_path/lsz" --escape --binary --overwrite $host_file_name < $tty_port_id  > $tty_port_id

                                /Applications/Arduino/Galileo.app/Contents/Resources/Java/hardware/arduino/x86/tools/izmir/clupload_osx.sh: line 32: 15117 Segmentation fault: 11  "$fixed_path/lsz" --escape --binary --overwrite $host_file_name < $tty_port_id > $tty_port_id

                                #

                                Moving downloaded file to /sketch/sketch.elf on target

                                #mv the downloaded file to /sketch/sketch.elf

                                target_download_name="${host_file_name##*/}"

                                echo "Moving downloaded file to /sketch/sketch.elf on target"

                                "$fixed_path/lsz" --escape -c "mv $target_download_name /sketch/sketch.elf; chmod +x /sketch/sketch.elf" < $tty_port_id > $tty_port_id

                                /Applications/Arduino/Galileo.app/Contents/Resources/Java/hardware/arduino/x86/tools/izmir/clupload_osx.sh: line 37: 15118 Segmentation fault: 11  "$fixed_path/lsz" --escape -c "mv $target_download_name /sketch/sketch.elf; chmod +x /sketch/sketch.elf" < $tty_port_id > $tty_port_id

                                #

                                #

                                • 13. Re: Problems updating firmware
                                  ghanashyamprabhu

                                  I am using Debian 7,6* and I faced the problem with detecting the Galileo board for firmware update - The error that I got was same as

                                  << Target Firmware Version Query Failed >>

                                  I tried the dmesg and the message was that

                                   

                                  usb 3-1 : device not accepting address 14, error =71

                                   

                                  I got it resolved by removing the ehci_hcd module

                                  > sudo rmmod ehci_hcd

                                   

                                  and could update the firmware easily.

                                   

                                  Adding this here since this is one of the possible solutions to this problem of ' Target Firmware version query failed'

                                   

                                  /g

                                  • 14. Re: Problems updating firmware
                                    MonaJalal

                                    I have the same problem. Here is the folder I have my IDE in:

                                    C:\Users\jalal\Downloads\Intel_Galileo_Arduino_SW_1.5.3_on_Windows_v1.0.0

                                    Any suggestion how can I get it fixed on Windows?

                                    1 2 Previous Next