10 Replies Latest reply on Aug 19, 2014 4:23 PM by RGee

    galileo and windows xp

    riklab

      Hi,

      is there anyone who can help me about where find more information to install intel galileo on windows xp?

       

      Thanks

      Rik

        • 1. Re: galileo and windows xp
          JohnS

          While you can run Arduino IDE sketches on the Galileo board using Windows 7 & 8, Mac, and Linux operating systems, Galileo is a Linux based platform and does not support Windows.

           

          Regards,

          John S.

          • 2. Re: galileo and windows xp
            srikanthvasuki

            Please refer to the following link on getting started with Intel Galileo :

             

            http://download.intel.com/support/galileo/Galileo_GettingStarted_329685_002.pdf

             

            Regards,

            Srikanth

            • 3. Re: galileo and windows xp
              MikeMcCullough

              There is no answer whatsoever here. Evidently, nobody has read the question. Please do not point to the "Getting started guide."

               

              I cannot find usber.sys anywhere on Windows XP and I did not see anything on the device manager. So?

               

              BTW, I am working from an Internet cafe while travelling. It would be nice if I did not need an admin password. I love Intel, but Arduino is supposed to be user friendly.

               

              Thanks and best Regards,

               

              Mike

              1 of 1 people found this helpful
              • 4. Re: galileo and windows xp
                MikeMcCullough

                You might want to reconsider, with all due respect.  GRBL dominates the maker 3D printer market and Mach3 simply screams to hosted on a Galileo. Poor Tormach has to ship a legacy PC with each mill just to run it.

                 

                Best Regards,

                 

                Mike

                • 5. Re: galileo and windows xp
                  nuke

                  Running the IDE is not supported in Windows XP. Windows 7 and Windows 8 are supported.

                  • 6. Re: galileo and windows xp
                    riklab

                    Hello everyone,

                    I wanted to tell you that Intel Galileo also works with Xp.

                    I had problems with the installation of the driver, but I solved following these steps:

                    1. I have download the latest IDE and firmaware for windows from this address https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23171 is a zip file.
                    2. I have unzipped the ide file.
                    3. after installation I tried to see if the Arduino IDE worked in Windows Xp. And it works!!
                    4. I have followed the instuction from Galileo_GettingStarted ,as recommended by Srikanth. (link: http://download.intel.com/support/galileo/Galileo_GettingStarted_329685_002.pdf)

                     

                    "( from page 5)
                    2.

                     

                    Connect the USB cable to the USB Device Port (closest to the Ethernet) and to a

                    PC. Wait for Windows to begin its driver installation process. After a few moments,

                    the process will fail.

                    3.

                    Click on the StartMenu, and open up the Control Panel. While in the Control Panel, navigate to System. Next, click on System. Once the System window is up, open the Device Manager.

                     

                    4.

                    Look under Ports (COM & LPT). You should see an open port named Gadget Serial V2.4.

                     

                     

                     

                    5. Right-click on the Gadget Serial V2.4 port and choose the Update Driver Software option.

                     

                    6.

                    Next, choose the

                     

                    Browse my computer for Driver software

                    option.

                    7.

                    Finally, navigate to and select the driver file named linux-cdc-acm.inf, located in the hardware/arduino/x86/toolsdirectory).

                     

                    8.

                    Once the driver is successfully installed, Device Manager will show a Gadget Serial (COMx)device under Ports (COM&LPT). Note the COMxport number as it will be needed in the IDE later."

                     

                     

                    After updating Galileo board, i have upload blink sketch. Works!!

                     

                    I hope I was helpful to someone.
                    Thanks for your help and sorry for my bad english!


                    Best Regards,

                    Riccardo

                    • 7. Re: galileo and windows xp
                      MikeMcCullough

                      Hi and thanks!

                       

                      I followed your instructions and device manager shows Galileo (COM4).

                       

                      When I try to upgrade the firmware

                       

                      "target firmware version query failed."

                       

                       

                      Arduino: 1.5.3 (Windows XP), Board: "Intel® Galileo"

                       

                      When I try to run blink I get

                       

                      i586-poky-linux-uclibc-g++: error: and: No such file or directory

                      i586-poky-linux-uclibc-g++: error: Settings\Administrator\Desktop\arduino-1.5.3/hardware/tools/x86/i586-poky-linux-uclibc: No such file or directory

                       

                      Life can be so cruel. I got a board at the Rome show and the USB port on my laptop promptly failed. I am travelling in Asia and don't want to get it fixed because it is under warranty and all the Internet cafes here run XP. Sigh.

                       

                      Best Regards,

                       

                      Mike

                      • 8. Re: galileo and windows xp
                        transmissions4less

                        thank i followed your instruction to have it working under winxp n got it installed ,  my first start with this fuzzy board is not promising not to mention the amount of heat coming from the processor is heating all the room, can not wait till i get 86duino based on real chip with vga support. it seem i am just gonna through this Galileo myth out on the freezing snow and let it freeze to death and forget it even existed so i can forget the money and time I lost today with this bad adventure. very shameful , Intel CEO with all the show in the media for this, very disappointing, better Intel come-up with modified version of Galileo with Linux32 support and hdmi at least they can find a reason for this pricey board when compared to beagleboneblack. I am still shocked is this really Intel product !!..

                        • 9. Re: galileo and windows xp
                          ahazelton

                          I too confirm it works on an old T41 running XP (slow, but it works).  I think it is much better than my now-screwed-up win7 system which still does not work with RNDIS.

                           

                          I think the Edison firmware update process nearly works too, except one of the scripts uses the 'timeout' command that isn't supported under XP (but you can edit this to 'pause').  Zadig has an XP version zadig_xp_v2.0.1.160.7z which worked fine, gadget driver installed ok, dfu_utils works ok too.  In the end I think the problem I was having installing the ww33 image was the same on win7 as on xp  and having had to revert to WW32 twice to get  it working on win7 I could not be bothered to go and repeat the exercise on XP.  I will try it on WW34 when it comes out.

                           

                          andyH

                          • 10. Re: galileo and windows xp
                            RGee

                            Yep, been using an old Dell XP with ~10 years of junk on it since the day I got a Galileo. Really have not had a single problem that could be attributed to XP - or at least that I could not have attributed to XP before Galileo. When I tested out the terminal / Linux sketch through the little audio jack, I had to reincarnate a version of hypertrm because I couldn't remember the names of other simple terminal programs I had on there. I hate throwing stuff out...still have a Kim-1 and a  TRS-80 M1 in the closet....but I haven't got the IDE to work with them yet (ok I'm kidding, but they really are in the closet).