1 Reply Latest reply on Sep 23, 2013 10:23 AM by sylvia_intel

    DP45SG Not Working with HD7850

    MrCaffeineX

      I purchased a Radeon HD 7850 as an upgrade for my aging 9800GTX+.  I went through the normal process of uninstalling the old video driver, shutting down the PC, shutting off the power supply, waiting until all the on-board LEDs went off, removing the old video card, replacing it with the new video card, switching the PSU back on, and booting the system back up.  When I turn the system back on however, it never displays anything.  The system does not make the normal audible beeps, and the fans spin at full speed instead of throttling down like normal, until I get tired of waiting for something to happen (in excess of 5 minutes one time), at which time I cut the power.

       

      I tested the video card in another PC and it works fine.  The PC with the DP45SG motherboard functions normally with the 9800GTX+, and with a GTX 460 from another PC, but for some reason refuses to accept the 7850.  I updated the BIOS to the latest version on the off-chance that some setting was interfering and I tried loading the default BIOS settings as well as the optimal default BIOS settings to no avail.  Is the DP45SG not compatible with the Radeon HD7850?  Or with PCIe 3.0 video cards in general (I don't have another PCIe 3.0 card to test with)?  Is there something else that needs to be done in order for it to work?

       

      Complete system specs in case they are necessary:

      Intel Core 2 Quad Q9550S

      Intel DP45SG

      2 x Hynix 1GB DDR3-1066 (will be upgraded if I can get the video card working)

      Western Digital Caviar Blue 250GB

      Seasonic 650W Gold Certified PSU (overkill, but its what I had on-hand)

       

      Message was edited by: Robert Haynes - fixed typos.

        • 1. Re: DP45SG Not Working with HD7850
          sylvia_intel

          Hello MrCaffeineX,  I am afraid to say that this motherboard has been out of support since July, 2011, http://www.intel.com/support/motherboards/desktop/sb/CS-032519.htm

           

          However, these are some recommendations we can try:

           

          1. Take the system outside of the chassis. Make sure you disconnect all other components from the motherboard and take the product out in a non-conducted surface.

           

          2.Clear the CMOS. The correct way is, while having all components disconnected from the motherboard, disconnect the BIOS jumper and remove the battery for about 15-20 minutes.

           

          3. You mentioned that you have the BIOS updated to the latest version.  So you may want to search for the latest firmware for your graphics card.

           

          4. Tested a different power supply. Based on the card specifications, it is necessary a 500W or greater power supply to use it. Testing a higher power supply will help us to discard any possible power issue.

           

          If doing these basic troubleshooting steps is still not working in the motherboard, there might be a compatibility issue between these components.

           

          The following link will provide you the list of tested peripherals.

          http://www.intel.com/support/motherboards/desktop/dp45sg/sb/CS-030400.htm