8 Replies Latest reply on Sep 19, 2013 7:24 AM by JasonHoffman

    NUC wireless PXE?

    SirParadox

      Question:  What am I missing?  I want to be able to network PXE boot, via my wireless network, to my Windows Remote Deployment Server.

           What key do I hit?

           Where do I punch in the wireless SSID and Keys?

           Or am I unable to, and I have to initially boot/install via a wired connection?


      Ok so I've been out of the hardware field for too long.  I know intel.. I know pxe.. I don't even come close to being versed in the current tech.

       

      I have a brand new (my first) NUC.  I installed the Ram, SSD, and Wireless.  Per the videos

       

           1x Intel Next Unit of Computing Kit with Dual HDMI, Gigabit LAN, Core i3-3217U DC3217IYE

           1x Intel 6235AN.HWMWB Centrino Wifi Card Advanced-N 6235 Dual Band w/ Bluetooth


      Going through the bios, F2, F10, F12, F... I can't find the little click/press I need.  Not to mention I'm getting old and the screen goes WAY too fast.


      Thanks in advance!


      -Ryan



       



        • 1. Re: NUC wireless PXE?
          JasonHoffman

          Hi Ryan,

            

          The network boot option should be enabled in the bios: turn on the unit and press F2 (quickly).  I usually keep pressing it over and over until I get to the bios screen.  Once you’re in the bios go to advanced settings, then boot, then make sure the Boot to Network box is checked.  Once it is go ahead and reboot.

           

          I don’t have an image server set up but according to the support page:

           

          “Intel® Boot Agent settings
          Intel® Boot Agent initializes during the system startup, even if it is not the first boot device. Once the initialization screen displays, press Control-S to configure the Boot Agent settings.”

           

          Let me know if that works.

           

          Jason Hoffman

          1 of 1 people found this helpful
          • 2. Re: NUC wireless PXE?
            SirParadox

            Thanks for the reply Jason.

             

            The boot to network option is on.

            I see references to LAN in the bios, and the onboard wired port.

            However nowhere in the bios do I see a mention of having an SSD disk, nor a second LAN 'wireless'.

            Looking under PCI, Attached devices ect.

             

            So I enabled all the extra boot menu check boxes.. They apparently are for display only.  F12 network boot, then ctrl-s, and such doesn't do anything new.

             

            I took it apart.  I booted without the SSD or WIFI card and observe no changes in the bios except for the SATA option missing, as expected.

             

            When it boots.  I get the classic Intel Boot Agent, testing media connection.  Tried ctrl-s here.  Didn't work.

            I expected that boot agent to exit, and it then fire up the boot agent on the next LAN/WIFI card.   So I let it time out, proceed, and it really seemed as if it was just cycling attempts at that one device.  Not carrying on to the next.  I vaguly remember from experience the coded PXE-E61, PXE-M04 or whatnot should tell you which card is attempting to go.

             

            So I'll google some more about the Intel Boot agent.  Strange I don't see any bios mentions about the card but I do understand that's before the right stack is loaded and such.  So it appears as if the bios is doing its job, my problem is understanding the keys I need to monkey with the boot agent to get some form of network config, wireless, etc, options.

             

            Again thanks in advance for any more input/assistance. 

             

            -Ryan

            • 3. Re: NUC wireless PXE?
              JasonHoffman

              Ryan,

               

              Are you at the most current BIOS level?  Have you tried booting it and continuously hitting CTRL+S?  I'm not sure why CTRL+S isn't working but I'll see if I can come up with anything on my NUC.

               

              Jason

              1 of 1 people found this helpful
              • 4. Re: NUC wireless PXE?
                SirParadox

                Thanks again Jason.

                 

                I am running the factory installed bios GKPPT10H.86A.0040.2013.0325.1514

                I am using a wireless anker keyboard, and wireless microsoft mouse.

                For ***** and giggles I plugged in my backup wired USB keyboard.

                I tried Ctrl-S in many situations, no joy.

                     The only bug on that keyboard is I have to enable f-lock fast to be able to hit F2/F11/etc.

                 

                My google foo about the intel boot agent, and getting to the menu, all tell me 'ctrl-s'.  A few places suggest I boot to an Intel Boot Agent on a USB stick but now we're getting complicated.  I have a usb stick right here.  Windows server on the other hdmi port, etc, etc.. So that's an option, however I was really trying to get things going out of the box.

                 

                My years of historical knowledge of how things use to work, TMI on google, and such is getting in the way.

                 

                Again, to be honest, I'm trying to get it working out of the box without wires.  I surely could run a 1 foot ethernet cable, and try and update the bios.. if you feel that's necessary.

                 

                I'm going to attempt that now...The bios update...

                 

                -Ryan

                • 5. Re: NUC wireless PXE?
                  JasonHoffman

                  Ryan,

                   

                  I really wouldn't expect you'd need to jump through hoops to get this working, but I just tried enabling the boot agent on mine and using CTRL+S...no joy.  So you're not alone.  I'll do some more searching and if I can't find anything useful I'll see if I can find someone in the know tomorrow.

                   

                  I'd be interested to know if CTRL+S works when it's plugged in with an Ethernet cable.

                   

                  Jason

                  • 6. Re: NUC wireless PXE?
                    SirParadox

                    I tried a few different methods.. disabling/enabling the legacy boot.. F4, Ctrl-S, S, etc.. a few more keys.. all yes.. all at different stages.

                     

                    I did plug in the wired ethernet and verified the PXE stack is able to see my image server.  However even when the LAN was doing it's PXE magic, pre, and post, ctrl-S and other keys didn't access any form of configuration menu.

                     

                    It's late and I'm giving up for the evening.  Thanks again!

                    • 7. Re: NUC wireless PXE?
                      SirParadox

                      My 'In The Know' PXE expert says he's never seen a stack that supports any form of wireless PXE.

                      As far as configuration.  Most devices require you to boot to an OS, and run the pxe configuration editor to change things like link speed, duplex.  This chip might be one of them, and not have the full on 4.x (I think I saw references between 1.x and 4.x intel boot agent) configuration screen.  Even if it had one, it would be pretty advanced to be able to edit the link settings (to configure wireless) at or before the pxe stack initiates.

                       

                      So.  I'm going to PXE over wired.    I'll try again in a year to PXE over wireless.

                       

                      Thanks again for all your help!  If anyone finds any information to the contrary, post it here.

                       

                      -Ryan

                      • 8. Re: NUC wireless PXE?
                        JasonHoffman

                        Well that's what I get for typing without knowing.  It's been so long since I've used PXE it didn't occur to me they wouldn't have it running over wireless.  Live and learn.