9 Replies Latest reply on Sep 29, 2013 5:18 AM by Fernando

    intel rst stopped working (11.2.0.1006)

    vang124578

      I have a windows 7 64 pc where I've installed Intel® Rapid Storage Technology (11.2.0.1006)  The configuration has to mirror two disks

      to day I suddenly accidentally discovered the raid configuration stopped working.

      the icon in the system tray looked a little different then before.

       

      I'm very disappointed in this tool:

      I expect it to copy my files, and if it stops for any reason, it has to warn me in an annoying way. (but it didn't)

       

      computer management showed me one of the two disk is offline. it says:

      "The disk is offline because it has a signature collision with another disk that is online"

       

      having a problem is one thing, solving is something completely different

      I've tried to open Intel® Rapid Storage Technology, by dubble clicking on the system tray icon. the user interface didn´t start

      and i tried to open it with 'control panel' and 'hardware and sounds'

       

      in the taskmanager under 'services' there is a item called IAStorDataMgrSvr (running), under Process is an item IAStorIcon.exe *32

       

      what triggered this malfunction? and (after reinstalling) do I have to check this program everyday in the future?

      I have no idea when it stopped working (because it didn't warn me), could it something to do with an bios update?

       

      how do i get this configuration up and running? do i have to buy a third diskdrive or can i configure a raid volume with (at least) one filled drive?

       

      is there a newer version which is more stable and does work with my configuration?

       

      i hope you can help me questions.

        • 1. Re: intel rst stopped working (11.2.0.1006)
          Fernando

          vang124578 schrieb:

           

          I have a windows 7 64 pc where I've installed Intel® Rapid Storage Technology (11.2.0.1006)  The configuration has to mirror two disks

          to day I suddenly accidentally discovered the raid configuration stopped working.

          the icon in the system tray looked a little different then before.

           

          what triggered this malfunction? and (after reinstalling) do I have to check this program everyday in the future?

          I have no idea when it stopped working (because it didn't warn me), could it something to do with an bios update?

          Of course it has something to do with a BIOS update.

          The default setting of the SATA Controller usually is "AHCI", sometimes "IDE", but never "RAID"!

          Solution:

          Enter the BIOS, set the Intel SATA Controller to "RAID", save the new setting and reboot.

          After having done this, your RAID1  (Mirror) should be detected by the OS and working.

           

          Good luck!

          Fernando

          • 2. Re: intel rst stopped working (11.2.0.1006)
            vang124578

            forgot about that parameter, because the OS booted as it did before the update.

            the last time i swited it to raid, i had to clear install the OS (w7).

             

            after rebooting in raid-mode, the system recognized the raid configuration, before entering the windows OS.

            I think it start rebuilding but I'n not sure it takes the right drive as "source/original" and the right drive as "destination". this will result in deleting al files which are made in the period after updating the bios and now.

             

            at the moment, one partition seems to be lost. This is a partitions where i installed some programs like Thunderbird. some directories are locked. I will reboot my pc again to find out if it can recover some data.

             

            does intel something about my concerns about the lack of communication of this software if it isn't working?

            I had marked all the possible notifications, except the mail. At the moment I've configured the mail-notification as wel, but I'm not sure the program will detect and act if its malfunctioning again

             

            thanks so far,

            • 3. Re: intel rst stopped working (11.2.0.1006)
              Fernando

              vang124578 schrieb:

               

              forgot about that parameter, because the OS booted as it did before the update.

              the last time i swited it to raid, i had to clear install the OS (w7).

              after rebooting in raid-mode, the system recognized the raid configuration, before entering the windows OS.

              So you obviously got your RAID back by just switching the SATA mode BIOS setting.

              Please remember:

              1. Before you are going to flash a new BIOS version, you should note all your individual BIOS settings.
              2. After having flashed a new BIOS version, the first step is always to enter the BIOS and to reset the appropriate SATA mode of the SATA Controller. Otherwise you are not able to boot into your previously used SATA configuration.

              vang124578 schrieb:

               

              at the moment, one partition seems to be lost. This is a partitions where i installed some programs like Thunderbird. some directories are locked. I will reboot my pc again to find out if it can recover some data.

              As a workaround to save some of your recently created or received data you may temporarily reset the SATA Controller to "AHCI" mode, reboot into the previously working system, save the most important data onto an extern medium (USB flash drive) and then recover your RAID configuaration.

              vang124578 schrieb:

               

              does intel something about my concerns about the lack of communication of this software if it isn't working?

              The Intel RST Console would have given you all needed informations, if you would have looked for them. AHCI and RAID systems are using exactly the same RST Console software.

              You obviously got the information by the RST Console, that there was something wrong with your system, but you didn't realize, that you had caused the issue yourself by having updated the BIOS without redoing the individual BIOS settings.

              1 of 1 people found this helpful
              • 4. Re: intel rst stopped working (11.2.0.1006)
                vang124578

                stil working on data and system recovery

                 

                lost lots of data by switching too raid-mode in bios,

                later turned back to AHCI mode so i could install a datarecovery program

                returning in windows didn't trigger lots of alarm bells, intel RST only seems to gives notifications if at start up if it is running correct.


                every time I start the computer again, it offers an inconstancy check.

                which ends in a 696E647863686B2E 12D8 or 696E647863686B2E 1362 error

                is this a checkdsk error?

                and some folders have a lock in the icon, double click will open them normal.

                 

                at this point i don't know what the do

                how do i solve the checkdsk errors?

                do i have disable the raid and enable is again?

                can make a raid configuration based on a filled hdd?


                I hope someone has an idea

                 

                at the end it is very ironic that i lost data by the making a mistake with a raid configuration,

                when i hadn't choose for a raid configuration i properly never lost data.



                • 5. Re: intel rst stopped working (11.2.0.1006)
                  Fernando

                  vang124578 schrieb:

                   

                  at this point i don't know what the do

                  how do i solve the checkdsk errors?

                  do i have disable the raid and enable is again?

                  can make a raid configuration based on a filled hdd?

                  If I were you, I would save as many data as possible and then do a fresh install of the OS onto the system partition.

                  vang124578 schrieb:

                   

                  at the end it is very ironic that i lost data by the making a mistake with a raid configuration,

                  when i hadn't choose for a raid configuration i properly never lost data.

                  You have made a big mistake not to check your BIOS settings after having flashed a new BIOS. Additionally came your misfortune, that you were able to boot into your OS without realizing, that your drives were running in AHCI instead of RAID mode.

                  • 6. Re: intel rst stopped working (11.2.0.1006)
                    vang124578

                    I have a ssd drive with the OS, and two hdd in raid

                    this will be the reason why my OS still worked, in RAID and in AHCI, and mij RAID configuration didn't

                     

                    the OS isn't on the RAID, so is a reinstall necessary?

                    can i solve this problem by disattach (unmount, disconnect) the raid configuration in the intel RST interface, and reattach without loosing data?

                     

                    thanks all ready

                    • 7. Re: intel rst stopped working (11.2.0.1006)
                      Fernando

                      vang124578 schrieb:

                       

                      I have a ssd drive with the OS, and two hdd in raid

                      this will be the reason why my OS still worked, in RAID and in AHCI, and mij RAID configuration didn't

                      the OS isn't on the RAID, so is a reinstall necessary?

                      The SSD obviously is not part of the RAID array, but has been run in AHCI mode for a while, although the OS had been installed in RAID mode. So there may be some data even on the SSD, which cannot be detected by the OS.

                      So I recommend to do a fresh OS installation.

                      vang124578 schrieb:

                       

                      can i solve this problem by disattach (unmount, disconnect) the raid configuration in the intel RST interface, and reattach without loosing data?

                      You may try that additionally, but I don't know, if you will loose data. Do a complete backup first!

                      • 8. Re: intel rst stopped working (11.2.0.1006)
                        vang124578

                        i'm ready searching and recovering data.

                        now i want to reconfigure the raid.

                         

                        i'v set the bios to AHCI, and disconnected one drive

                        the os (win7) works fine

                         

                        i have to format some partitions on the disk, because it contains 11GB, where windows thinks 22GB is taken.

                         

                        can i format (with gparted in ubuntu) the partitions on one disk, and leave the data on the other disk, and reboot windows with intel rapid storage technology. does the intel rst copy all files from the filled drive to the empty one?

                        and do it later the other way around?

                         

                        thanks all ready

                        • 9. Re: intel rst stopped working (11.2.0.1006)
                          Fernando

                          Hello vang,

                          I am sorry for my late reply (I am just making holidays far away from home).

                          vang124578 schrieb:

                           

                          i'm ready searching and recovering data.

                          now i want to reconfigure the raid.

                          can i format (with gparted in ubuntu) the partitions on one disk, and leave the data on the other disk, and reboot windows with intel rapid storage technology. does the intel rst copy all files from the filled drive to the empty one?

                          and do it later the other way around?

                          To be honest: I don't know, if you will succeed this way.

                          Since you obviously were able to recover and backup your data from the RAID1 array, I would do the following:

                          1. Enter the BIOS and set the SATA Controller to "RAID" mode.
                          2. Hit CTRL+I while rebooting and delete the existing RAID1 array.
                          3. Do a secure erase of both formerly RAID members.
                          4. Recreate the RAID1 array.
                          5. Reconstruct your formerly RAID1 data or begin the data storage from scratch.

                           

                          Good luck!

                          Fernando