5 Replies Latest reply on Dec 7, 2015 12:47 AM by Eka_Chan

    Turbo boost not working after update

    JaimeCruz

      Hello, I have a Samsung ultrabook with core i5-3337U@1.8 Mhz processor.

      Until yesterday the turbo boost monitor shown that the processor use additional processor power when needed reaching up to 2.6 Mhz.

      Yesterday I update the Wifi, Widi and HD4000 graphics drivers to the latest versions.

       

      Now when I start my system I get the following message:

      Capture.PNG

      now the turbo boost feature don't work and the processor never go beyond 1.8 Mhz

       

      How I can enable the turbo boost?

       

      Thanks for your help.

       

      Jaime

        • 1. Re: Turbo boost not working after update
          kevin_intel

          Hi JaimeCruz,

          The Turbo Boost Feature can be disabled or enabled at bios level depending on the options that the manufacturer has developed.

           

          I recommend you accessing the bios and resetting the settings defaults since the drivers you install should not affect at all this processor feature.

          • 2. Re: Turbo boost not working after update
            JaimeCruz

            Hi Kevin,

                          thanks for your answer. At bios level I can only put on or off the processor ECO mode. Tried On and OFF and not change in the turbo boost. Another problem I found was that I can't change the screen brightness.

             

            Finally the only solution I found is to make a system restore to a point before loading the new Intel drivers.

            Now everything works OK.

             

            I think that Samsung drivers have a "some" difference from the original Intel drivers.

             

            Thanks anyway and good bye.

             

            Jaime

            • 3. Re: Turbo boost not working after update
              kevin_intel

              Hi JaimeCruz,

               

              You are welcome. Let us know if further assistance is required.

              • 4. Re: Turbo boost not working after update
                Eka_Chan

                Hi JaimeCruz,

                I also have this problem on same ultrabook with yours (samsung ultrabook series 5 with core i5-3337U@1.8 Mhz processor).

                I did factory reset few days ago and then updated all samsung software (because of hdd replacement).

                Then, I notice that cpu clock on task manager stay in 1,8GHz and  a notification about Virtualization (if I am not mistaken) is not supported in this processor while installing a software. I checked Hyper-V in Windows Features dialog box.

                 

                - What is name of old samsung application to change cpu clock / eco mode? I still have old samsung' systemsoftware backup. I hope by reinstall it will solve the problem.

                - I don't think to do reset to factory setting anymore. I did twice last month TT__TT.

                 

                 

                Thank you.

                • 5. Re: Turbo boost not working after update
                  Eka_Chan

                  Hi,

                   

                  After I reset my samsung ultrabook to factory setting, I did a little troubleshoot and then found the answer.

                   

                  It is because of << Hyper-V checked (on) >>!!!

                   

                  In this ultrabook (processor i-5 3337U), if you check Hyper-V feature in Windows Add Features dialog

                  -- Windows fail to read processor Turbo Boost (I guess). Windows Task Manager will show processor speed is 1,80 GHz all time.

                  -- This failure will affect to processor fan. The fan will never change it speed to higher speed and make my ultrabook temperature increase.

                   

                  Next, I tried to check (activate) Hyper-V on my brother Microsoft Surface Pro with i-5 4000U processor. Everything run normal.

                   

                  So, I can guess that there must be something (bug, error or...) in this (my ultrabook) i-5 3337U processor, don't know it is at processor level or windows level.

                   

                  need replacement if I want to activate Hyper-V.     TT___TT