10 Replies Latest reply on Jan 24, 2014 1:51 PM by joe_intel

    520 SSD BSOD 0x3D when running SSD Toolbox

    Taurothar

      Hello all,

       

      I get a BSOD any time I try to run the latest Intel Solid State Toolbox.  The software prompted me to update to the newest version, v3.1.8, recently.  After the install, if I allow the software to run immediately or if I wait and manually run it from the start menu, I get the STOP 0x0000003D code INTERRUPT_EXCEPTION_NOT_HANDLED message every time.  I don't even get the software to load before the BSOD occurs.

       

      I've checked updates on my SATA controller, latest driver already installed. I've downloaded and ran the CD based firmware updater for the SSD and the latest firmware was already installed.  Tried downloading a fresh copy of the toolbox from Intel's downloads and installing again several times.  Latest BIOS is installed and has not recently been changed, settings are all correct for AHCI. 

       

      Hardware is as follows:

      ASUS Sabertooth x58 Motherboard with Marvell 91xx SATA 6G controller.

      Intel SSD 520 180GB with firmware version 400i

      Intel i7 960 stock clocked

      Corsair DDR3 3x4gb

      OS is Windows 7 Ultimate x64

       

      There have been no recent hardware changes, and all equipment has been running stable and unchanged aside from mechanical hard drive changes since I bought the 520 I believe in May of 2012.

        • 1. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
          joe_intel

          Hello Taurothar, I see your motherboard has three SATA controllers, is the Intel® SSD 520 connected to the Marvell controller? Is this the operating system drive?

           

          For compatibility we recommend connecting the Intel® SSD to the Intel® SATA controller. If it is the boot drive the operating system must be reinstalled after changing to a different controller.

          1 of 1 people found this helpful
          • 2. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
            Taurothar

            Thank you for your reply Joe/

             

            I have it plugged into the Marvell controller because those are the only two 6gpbs connectors on the MoBo.  The Intel controller only supports 3gpbs.  Since the 520 is compatible with the higher speeds, I'd like to continue using this controller if possible.

            • 3. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
              joe_intel

              We will investigate about this issue. Would you be able to try with the Intel® SSD connected to the Intel® SATA controller just as a test and provide the results?

               

              Then, you can move it back to the Marvell* controller again and use an older version of Intel® SSD Toolbox in the meantime. I will send you a private message with a temporary download link.

              • 4. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
                Taurothar

                I have tried the Intel controller a few minutes ago, and the same BSOD error occurs.

                I have returned the connection to the Marvell controller as it's been otherwise stable.

                • 5. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
                  joe_intel

                  Did you reinstall the operating system after connecting the drive to Intel® controller? I suggested it on my first reply.

                  • 6. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
                    Chain

                    Just bought a new 240GB Intel 335-series SSD today ("INTEL SSDSC2CT240A4").

                    I'm on a P6X58D-E motherboard with the latest firmware. I've tried both the SATA 2 (Intel) and SATA 3 (Marvell) connections.

                    The disk is empty and is just an extra disk. No OS on it.

                     

                    Trying to launch the latest SSD Toolbox gives immediate BSOD 0x3D.

                    Any solution? I'd like to check if I have the latest firmware and such before I start using the drive (and whatever else the tool does)...

                    This thread indicates that an older version might work, is it possible to get a download link for that?

                     

                    Windows 7 Home Premium 64-bit.

                    A OCZ Vertex 3 (w/OS) and some HDDs are also connected to the SATA 2 controller.

                     

                    Ps: I even attempted to download a custom firmware for the motherboard that updates the Marvell bios from 1.0.0.1019 to 1.0.0.1029 but it did not change anythin. The disk is now on the Intel controller as apparently the Marvell one is utter crap anyway according to my googling.

                     

                    Message was edited by: Jonas Rogne Added some more info after testing some more.

                    • 7. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
                      joe_intel

                      Chain, it is rare that you have the issue with the SSD(s) connected to Intel® ICH10R because we identified that the error appeared when the SSD was connected to the Marvell® PCIe 9128 controller; therefore, that was the workaround.

                       

                      Unfortunately we have seen (here) that using an older version of Intel® SSD Toolbox does not make a difference but we are still investigating. I believe your issue is different somehow. Does it still occur if the Intel® SSD is connected to the SATA port 0?

                      • 8. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
                        Chain

                        I have figured it out. Short version: Marvell creates utter crap and my next motherboard will not feature any of their stuff that's for sure (I often have to restart their network device as well).

                         

                        If ANY drive whatsoever is connected to the Marvell controller (I had a regular HDD connected) then starting SSD Toolbox will give a BSOD 0x3D (no matter where the SSD itself is connected). I guess it happens because the toolbox is trying to ask Marvell for some disk info (god forbid)?

                         

                        The workaround is to disconnect all/any drives from the Marvell 9128 controller (basically the two SATA 3-connections on the motherboard). It's also possible to completely disable it in BIOS.

                         

                        I guess Asus/Marvell needs to work this out, but perhaps the Toolbox can be improved a bit in the future for other user so it takes more care around Marvell 9128.

                         

                        I've completely disabled my Marvell controller now since it just causes occasional random bluescreens in Windows anyway (not 0x3D however, that's just when running the toolbox).

                        • 9. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
                          joe_intel

                          Chain, thank you for the information provided. We have forwarded it to the Intel® SSD Toolbox programmers.

                          • 10. Re: 520 SSD BSOD 0x3D when running SSD Toolbox
                            joe_intel

                            Please try updating your Marvell* SATA controller driver, this fixed the issue for another person.