8 Replies Latest reply on Jun 4, 2015 2:13 AM by Nitin-Arnold-Victor

    Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected

    Special_Agent_Sam

      I have had no luck yet in getting this solved, any ideas would be highly appreciated:

       

      My current symptoms after changing BIOS settings from "Legacy boot" to "UEFI boot" (nothing else was changed!):

       

      1) System (WITH graphics card installed) is booting right into black screen saying "A bootable device has not been detected. Please refer to the Product Guide at  [Intel URL]"

      2) System (WITHOUT graphics card) is freezing with 2 beeps + 2 beeps ("no graphics options available")

       

      And to complicate things somewhat:

      - the BIOS is not accessible at all in any of the two cases (via F2 or any other F-key)

      - BIOS reset (battery out for an hour) and BIOS recovery (with latest 320) do not change the situation

       

      Any idea how I could access the BIOS in this situation and return to "legacy boot" again?

       

      Here is some more background:

       

      - I built a brand new system one week ago with these components:

        Desktop Board: DH87RL, board revision is -400 (first version, the latest version now being -403)

        Intel processor: i5-4570 with Scythe Muygen 4 cooler

        Samsung SSD 840 Evo Basic (250 GB)

        LiteOn DVD writer iHAS524

        Power supply: Enermax ETL300AWT

        Casing: Corsaire Carbide 200

        Screen: Fujitsu 17" via DVI

        Wireless USB mouse + keyboard

        Initially run with integrated graphics Intel 4600, then upgraded to PCIe graphics card (XFX AMD 7790 1GB)

       

      (This system was a recommended configuration in a PC magazine recently - and it is extremely silent and power saving, yet quite powerful when you need it, so making perfect use of the new Haswell processors)

       

      - After building the system I updated the BIOS to 320 and adjusted some BIOS settings: fans + CPU low power mode

      - I installed Windows 7 Professional successfully

       

      So the integrated graphics worked fine, benchmarks where according to the magazine which had recommended this PC configuration (c't magazin Germany).

       

      - After 5 days (daily operating time about 4 hours) I installed a graphics card (XFX AMD 7790 1GB) into the PCIe x16 slot

      - To avoid collision of internal and external graphics I changed the BIOS setting:

        Internal graphics -> "always disable"

      - I then saved BIOS settings and installed the latest AMD graphics drivers in Win 7

      - Everything worked fine, benchmark results were as expected

       

      Then I had a very stupid idea which caused the current situation ("never change a running system" - I know...):

       

      - Just for curiosity I went into the BIOS and looked for settings to further improve system performance

      - I had heard a lot about the new UEFI mode, so I activated "UEFI boot" (hoping system start would be faster - ok, now I learned that more changes are needed for UEFI to work)

      - To make things worse I deactivated "Allow legacy boot"

       

      I saved the new BIOS settings ("UEFI = on" and "Legacy boot = off") and rebooted.

       

      Then for the first time a black screen appeared with the text stated above ("No bootable device detected...").

      And no BIOS splash screen beforehand and no reaction to any key (F2 or anything else).

      The system just stayed there with the black screen - all fans and lights on, but no more.

       

      I was not worried at that time since I thought that a BIOS reset would easily bring me back to start.

      But I got more and more worried while I tried everything I could imagine but nothing improved the situation:

       

      - I tried a basic BIOS reset: removed BIOS battery and waited for an hour (still the same black screen)

      - I removed the BIOS recovery jumper and loaded version 320 again via USB stick (recovery worked but still the black screen)

       

      - I removed the graphics card and tried another BIOS reset: interestingly "two times two beeps" stated "system is missing graphics"

        So BIOS reset obviously had not worked - the system still searched for a graphics card, and did not use the internal graphics!

       

      - I re-installed the graphics card again: the beeps disappeared and the black screen appeared again

      - I offered a bootable DVD - no boot, still the black screen

      - I offered a bootable USB stick - no boot, still the black screen

      - I removed all SATA devices (SSD, DVD) - no change

       

      - I left battery and graphics card and power away over night (~8 hours) - and no change still !

       

      Of course I tried BIOS recovery every time upon any change via USB stick.

      The recovery always concluded "Successful, shut-down power, re-install the recovery jumper and power on again for full system reset".

      So I re-installed the jumper, powered on and still the same black screen "no bootable devices detected".

       

      So the current status is as stated in the two lines at the top:

       

      1) WITH graphics card I get to the black screen ("no bootable devices detected")

         No key seems to work - not F2 or any other F-key regardless when pressed during system start.

         So I can not enter the BIOS in any way (the USB keyboard works fine though during BIOS recovery and also if used with another computer!)

       

      2) WITHOUT graphics card the system beeps twice ("no graphics installed")

         So the BIOS seems to remember that internal graphics had been deactivated - but why is it still remembering after several BIOS resets and recoveries?

       

      It also does not matter, where I connect the DVI cable to:

      - the screen will always show the black screen only when I attach the DVI cable to the first port of the graphics card (so integrated port does not work)

      - only when I activate BIOS recovery (via jumper) I can connect to the integrated graphics port and it nicely shows the recovery progress

       

      So this is really frustrating:

      BIOS reset: seems not to make any difference (so no reset seems to happen), not even after removing the battery for several hours

      BIOS recovery: successfully passes, but does not change anything as well (specifically resulting not in a reset, since the system is still searching for a graphics card)

       

      What else can I try to return to "legacy boot"?

      Certainly the only issue is the change to UEFI boot (perhaps together with the setting "internal graphics = always disable") and now the BIOS is not letting me in anymore...

        • 1. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
          Special_Agent_Sam

          Solved - I got the whole thing to work again today as follows:

           

          - I removed the graphics card, the BIOS battery and all cables from the mainboard this morning

          - Tonight, 10 hours later, I reconnected only the power cables (no SATA cables) and re-installed the battery

          - First I tried to boot with integrated graphics (= no graphics card installed)

            No luck - it would still "beep, beep" and cry for a graphics option.

          - I did another successful BIOS recovery via USB stick - still no change: "beep, beep"

          - I then re-installed the graphics card and connected the DVI to the primary DVI port of the graphics card (it's got two)

            No luck - still into the black screen with "A bootable device was not detected".

            I also noticed that USB devices (only the keyboard was connected) would not even get powered in this state.

          - Then I changed the DVI cable to the secondary DVI port of the graphics card (which I had tried last night already several times) - AND THE SYSTEM BOOTED TO THE BIOS SPLASH SCREEN !!

           

          Then I could reload defaults with F9 and saved with F10.

          Since I had all SATA cables still disconnected the system booted up to the point where it says "no boot media found...", but now I knew that everything was fine again.

           

          So in a nutshell:

          - After changing a relatively popular BIOS setting ("UEFI = on") the system went into a stuck state ("A bootable device could not be detected...")

          - Key issue was that there was no way to reset or recover the BIOS anymore with the integrated graphics option - in my opinion a severe issue

          - Only after re-installing the PCIe graphics card AND only in the secondary port AND only after removing any power for several hours the system returned into an operable state (= BIOS could be called with F2)

           

          ==> DEAR INTEL TEAM: THIS IS A SEVERE ISSUE AND IT WOULD BE GREAT IF YOU COULD LOOK INTO THIS AND ENSURE THAT A BIOS RESET / RECOVERY IS POSSIBLE UNDER ANY CIRCUMSTANCES (as long as everything else is disconnected and the board is just like it came out of the box).

           

          Besides this headache the Intel board does a great job in power saving, fan management and performance:

          With...

          ... an idle power consumption of 16 Watts under Windows 7 (when using the integrated graphics, and even less in Windows 8)

          ... and a volume that is so close to silence

          ... and ultra high performance when needed (Cinebench R11.5 with 5.82 points in multi-core!)


          this PC setup is a small revolution in PC technology!

           

          For comparison: a NAS with Intel Atom processor consumes more energy in idle mode and is by far less powerful (in any state).

           

          So with the right software this PC configuration is a real allrounder: for office, basic gaming, as small server or NAS.

           

          If Intel now fixes these tiny little issues I will buy Intel boards forever...well Intel announced to terminate mainboard business, so I can take this risk...

          • 2. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
            sylvia_intel

            I really appreciate your feedback and all the troubleshooting you performed. I am going to forward this information to the Engineering team.

            Thanks a lot.

            • 3. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
              whale

              I believe that the issue may be caused by the lack of UEFI support in the graphic card ROM. The BIOS of other motherboards display an error message when the user attempts to enable UEFI boot without UEFI-supported graphic ROM: My Video Card fails to operate under UEFI.

              • 4. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
                sylvia_intel

                Whale thanks for the information. I am going to share this info to the Engineers.

                • 5. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
                  joedoe

                  Well, we got stuck in the very same situation, too.

                   

                  It all started with the BIOS not being able to boot from SSD, though we reinstalled Ubuntu 13.10 twice. After trying various options suddenly "A bootable device has not been detected...." and there we are stuck in an infinite loop!

                   

                  Is intel serious about that bug? You actually do have to remove the battery for 10 hours because you misconfigured the SATA boot devices?? How do misconfigured boot devices prevent you from entering BIOS Setup and hence leading to a dead lock?

                   

                  I admit that I am quite disappointed, I assumed we bought robust and well tested boards, but I was mistaken. At least the boot device management of the board gives the impression to be beta software. Hopefully this posting will help the engineers to convince their managers to get the ressources they need to resolve those problems!

                   

                  Okay, enough ranting - I hope the cure described in this thread works, I will report back afterwards.

                   

                  Regards, Joe

                  • 6. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
                    joedoe

                    Well, I was able to recover the BIOS access by removing the BIOS protection jumper and powering the system up. No need to remove the battery for hours. At least this mechanism worked as expected.

                     

                    Regards, Joe

                    • 7. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
                      appu

                      dear brother " Special_Agent_Sam" i am also facing this problem i just change graphic optin in bios and save exit thats it my pc only beep beep beep plz help me bro and give ur email or skype id i wanna chat withu u

                      my email is (imranshaktimet@gmail.com)

                      • 8. Re: Desktop Board DH87RL (-400): BIOS reset not working after activating UEFI / no bootable devices detected
                        Nitin-Arnold-Victor

                        Hi,

                         

                        I have Intel DH87RL Motherboard. I faced exactly the same problem that Sam did - 2 long beeps followed by another 2 long beeps. I tried everything I could, moving wires. battery, jumper, trying bios update etc. but nothing worked. Even after plugging the USB Drive to update the BIOS, there was nothing getting displayed except for those annoying beeps.

                         

                        But I found the solution by reading the 'Intel Desktop Board DH87RL Technical Product Specification' Manual. In section 3.9.3 (Power Button Menu), I found that in order to get F2 working (so that I could load default values...), I have to keep the power button pressed (during power on) until the machine beeps 3 times, then release it and wait for it to startup (the machine will turn off for 2-3 seconds after releasing the power button and start again...)

                         

                        The Power Menu gets displayed having options like:

                        [ESC] Normal Boot

                        [F2] Intel® Visual BIOS

                        [F3] Disable Fast Boot

                        [F4] BIOS Recovery

                        [F7] Update BIOS

                        [F10] Enter Boot Menu

                        [F12] Network Boot

                         

                        (However, First time I tried it, it didn't work. Second time, accidentally it beeped 4 times, but the Menu opened up.)

                        Now, You can choose whatever you want to do.

                         

                        Sam posted his message in year 2013 and its now 2015; surely the Intel guys updated the Bios and brought-in this feature. It's easy to reset the BIOS this way now.

                        I just posted this because many people might be googling to find a solution to their problem. They can try this.